Configuring GIR (Cisco NX-OS Release 7.1(0)N1(1))

This chapter contains the following section

Information About GIR

You can use Graceful Insertion and Removal (GIR) to isolate a switch from the network in order to perform debugging or an upgrade. When switch maintenance is complete, you can return the switch to normal mode.

When you place the switch in maintenance mode, all protocols are gracefully brought down and all physical ports are shut down. When normal mode is restored, all the protocols and ports are brought back up.

The following protocols are supported:

  • Border Gateway Protocol (BGP)

  • BGPv6

  • Enhanced Interior Gateway Routing Protocol (EIGRP)

  • EIGRPv6

  • Intermediate System-to-Intermediate System (ISIS)

  • Open Shortest Path First (OSPF)

  • OSPFv3

Also supported are:

  • Virtual port channel (vPC) switches


    Note


    GIR is not supported on vPC+ switches.


  • Interfaces

  • FabricPath

You can create a maintenance mode profile file before you put the switch in maintenance mode or you can allow the system to create a maintenance mode profile file when you enter the [no] system mode maintenance command.

Use the snapshot command to capture the running states of selected features and to store them on the persistent storage media.

Snapshots are useful to compare the state of a switch before it went into maintenance mode and after it came back to normal mode. The snapshot process consists of three parts:

  • Creating a snapshot of the states of a few preselected features on the switch and storing them on the persistent storage media.

  • Listing the snapshots taken at various time intervals and managing them.

  • Comparing snapshots and showing the summary and details of each feature.

Guidelines and Limitations for GIR

Graceful Insertion and Removal (GIR) has the following guidelines and limitations:

  • You can create maintenance mode or normal-mode profile files by using the config profile maintenance-mode type admin and config profile normal-mode type admin commands respectively.

  • We recommend not using GIR maintenance mode when a switch is being upgraded to Cisco NX-OS Release 7.3(0)N1(1) or higher from any release prior to Cisco NX-OS Release 7.3(0)N1(1). If a switch that is in GIR maintenance mode has completed upgrading to Cisco NX-OS Release 7.3(0)N1(1) or higher from any release prior to Cisco NX-OS Release 7.3(0)N1(1), the switch will be isolated from the network. In such a scenario, the GIR maintenance mode configuration that was applied before upgrading the switch has to be manually removed from the switch to restore normal operation. This process of manually removing the GIR maintenance mode configuration will have to be done whenever the switch is rebooted.

    However, this issue can be permanently resolved by downgrading the switch to the previous version, which can be any release prior to Cisco NX-OS Release 7.3(0)N1(1), removing the GIR configuration, and then upgrading to Cisco NX-OS Release 7.3(0)N1(1) or higher without GIR.

Performing the GIR Cycle

Procedure


Step 1

(Optional) Create the maintenance mode profile file.

See Configuring the Maintenance Mode Profile File.

Step 2

(Optional) Create the normal mode profile file.

See Configuring the Normal Mode Profile File.

Step 3

Take a snapshot before entering maintenance mode.

See Creating a Snapshot.

Step 4

Put the switch into maintenance mode.

See Entering Maintenance Mode .

Step 5

(Optional) Enter the copy running-config startup-config command.

Step 6

Return the switch to normal mode.

See Returning to Normal Mode.

Step 7

Take a snapshot after returning to normal mode.

See Creating a Snapshot.


Configuring the Normal Mode Profile File

Procedure

  Command or Action Purpose

Step 1

switch# configure terminal

Enters global configuration mode.

Step 2

switch(config)# configure profile normal-mode type admin

Enters a configuration session for the normal mode profile file.

Note

 

Depending on which protocols you have configured, you must now enter the appropriate commands to bring up the protocols.

Step 3

switch# end

Closes the normal mode profile file.

Example

This example shows how to create a normal mode profile file:

switch# configure terminal
switch(config)# configure profile normal-mode type admin
switch(config-profile)# router ospf 100
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# router eigrp 101
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# router isis 102
switch(config-profile-router)# no shutdown
switch(config-profile-router)# no set-overload-bit always
switch(config-profile-router)# exit
switch(config-profile)# router bgp 103
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# vpc domain 20
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit         
switch(config-profile)# no system interface shutdown
switch(config-profile)# end
Exit configure profile mode.
switch#

This example shows how to create a normal mode custom profile file:

switch# configure terminal
switch(config)# configure profile normal-mode type admin
switch(config-profile)# router bgp 65501
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# router eigrp 100
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# address-family ipv6 unicast
switch(config-profile)# no shutdown
switch(config-profile)# router eigrp 600
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# address-family ipv6 unicast
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# router ospf 100
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# router ospfv3 ospf_ipv6
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit
switch(config-profile)# router isis isp
switch(config-profile-router)# no set-overload-bit always
switch(config-profile-router)# exit
switch(config-profile)# vpc domain 2
switch(config-profile-router)# no shutdown
switch(config-profile-router)# exit         
switch(config-profile)# no system interface shutdown
switch(config-profile)# end
Exit configure profile mode.
switch#

Creating a Snapshot

Procedure

Command or Action Purpose

switch# snapshot create name description

Creates a snapshot. The name variable can be 64 characters in length. The description variable can be 256 characters in length.

Example

This example shows how to create a snapshot:

switch# snapshot create snap1 For documentation purposes.
Executing show interface... Done
Executing show bgp sessions vrf all... Done
Executing show ip eigrp topology summary... Done
Executing show ipv6 eigrp topology summary... Done
Executing show vpc... Done
Executing show ip ospf vrf all... Done
Feature 'ospfv3' not enabled, skipping...
Executing show isis vrf all... Done
Snapshot 'snap1' created
switch#

Entering Maintenance Mode

Before you begin

If you are going to create your own profile rather than let the system mode maintenance command do it for you, see Configuring the Maintenance Mode Profile File.

Procedure

  Command or Action Purpose

Step 1

switch# configure terminal

Enters global configuration mode.

Step 2

switch(config)# system mode maintenance [dont-generate-profile]

Executes a previously created maintenance mode profile file or dynamically creates a maintenance mode profile file. The dont-generate-profile option suppresses the creation of the maintenance mode profile file.

Note

 

The system prompts you to continue. Enter y to continue or n to terminate the process.

The switch is now in maintenance mode.

Note


It is not possible to perform an in-service software downgrade (ISSD) in maintenance mode.


Example

This example shows how to place the switch in maintenance mode by using a previously created maintenance mode profile file:

switch# configure terminal
switch(config)# system mode maintenance dont-generate-profile
Do you want to continue (y/n)? [n] y

Progressing..............................................Done.

System mode operation completed successfully
switch(config)# 

Returning to Normal Mode

Procedure

  Command or Action Purpose

Step 1

switch# configure terminal

Enters global configuration mode.

Step 2

switch(config)# no system mode maintenance [dont-generate-profile]

Executes a previously created normal mode profile file or a dynamically created normal mode profile file. The dont-generate-profile option suppresses the creation of the normal mode profile file.

Note

 

The system prompts you to continue. Enter y to continue or n to terminate the process.

The switch is now in normal mode.

Example

This example shows how to return to normal mode from maintenance mode:

switch# configure terminal
switch(config)# no system mode maintenance dont-generate-profile
Do you want to continue (y/n)? [n] y

Progressing................Done.

System mode operation completed successfully

switch(config)#

Configuring the Maintenance Mode Profile File

Procedure

  Command or Action Purpose

Step 1

switch# configure terminal

Enters global configuration mode.

Step 2

switch(config)# configure profile maintenance-mode type admin

Enters a configuration session for the maintenance mode profile file.

Note

 

Depending on which protocols you have configured, you must now enter the appropriate commands to bring down the protocols.

Step 3

switch# end

Closes the maintenance mode profile file.

Example

This example shows how to create a maintenance mode profile file:

switch# configure terminal
switch(config)# configure profile maintenance-mode type admin
switch(config-profile)# router ospf 100
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# router eigrp 101
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# router isis 102
switch(config-profile-router)# shutdown
switch(config-profile-router)# set-overload-bit always
switch(config-profile-router)# exit
switch(config-profile)# router bgp 103
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# vpc domain 20
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit         
switch(config-profile)# system interface shutdown
switch(config-profile)# end
Exit configure profile mode.
switch#

This example shows how to create a maintenance mode custom profile file:

switch# configure terminal
switch(config)# configure profile maintenance-mode type admin
switch(config-profile)# router bgp 65501
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# address-family ipv6 unicast
switch(config-profile)# shutdown
switch(config-profile)# router eigrp 600
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# address-family ipv6 unicast
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# router ospf 100
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# router ospfv3 ospf_ipv6
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# router isis isp
switch(config-profile-router)# set-overload-bit always
switch(config-profile-router)# exit
switch(config-profile)# vpc domain 2
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit         
switch(config-profile)# system interface shutdown
switch(config-profile)# end
Exit configure profile mode.
switch#

This example shows how to create a maintenance mode profile for IPv6 protocols:

switch# configure terminal
switch(config)# configure profile maintenance-mode type admin
switch(config-profile)# router ospfv3 ospf_ipv6
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit
switch(config-profile)# router eigrp 660
switch(config-profile-router)# address-family ipv6 unicast
switch(config-profile-router-af)# shutdown
switch(config-profile-router-af)# exit
switch(config-profile-router)# router isis isp
switch(config-profile-router)# set-overload-bit always
switch(config-profile-router)# exit
switch(config-profile)# router bgp 655551
switch(config-profile)# address-family ipv6 unicast
switch(config-profile-router)# shutdown
switch(config-profile-router)# exit         
switch(config-profile)# 

Verifying GIR

Use one of the following commands to verify the configuration:

Command

Purpose

show system mode

Displays current system mode.

show interface brief

Displays abbreviated interface information.

show snapshots before-maintenance-mode description

Displays snapshots present on the switch.

show config-profile name

Displays the details of the config-profile files.

show system mode Command

switch# show system mode 
System Mode : Maintenance

show interface brief Command

switch# show interface brief

-----------------------------------------------------------------------------
Ehternet       VLAN     Type Mode   Status  Reason               Speed   Port     
Interface                                                                Ch #
-----------------------------------------------------------------------------
Eth1/1         - -      eth  routed  down   sysIntfShut           10G(D) - -
Eth1/2         - -      eth  routed  down   sysIntfShut           10G(D) - -
Eth1/3         - -      eth  routed  down   sysIntfShut           10G(D) - -
Eth1/4         - -      eth  routed  down   sysIntfShut           10G(D) - -
Eth1/5         - -      eth  routed  down   sysIntfShut           10G(D) - -
Eth1/6         - -      eth  routed  down   sysIntfShut           10G(D) - -
Eth1/7         - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/8         - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/9         - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/10        - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/12        - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/13        - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/14        - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/15        - -      eth  routed  down   SFP not inserted      10G(D) - -
Eth1/16        - -      eth  routed  down   SFP not inserted      10G(D) - -

-------------------------------------------------------------------------------
Port-channel  VLAN    Type Mode    Status  Reason                   Speed   Protocol
Interface
-------------------------------------------------------------------------------
Po1           1       eth  access  down    No operational members   auto(I)  none
Po100         1       eth  access  down    No operational members   auto(I)  none

-------------------------------------------------------------------------------
Port     VRF         Status IP Address                              Speed    MTU
-------------------------------------------------------------------------------
mgmt0    - -         up     192.0.0.1                               1000     1500
switch#

show snapshots Command

switch# show snapshots
Snapshot Name
---------------------------------------------------------------------------------------
snapshot_before_maintenance      Wed Sep 10 20:19:31 2014      system-internal-snapshot
snapshot_after_maintenance       Wed Sep 10 20:29:54 2014      system-internal-snapshot
snap1                            Wed Sep 10 20:36:15 2014      For testing

show config-profile Command

switch# show config-profile

config-profile maintenance-mode type admin
  router ospf 100
   shutdown
  router eigrp 101
   shutdown
  router isis 102
   set-overload-bit always
  router bgp 103
   shutdown
  vpc domain 20
   shutdown
  system interface shutdown exclude fex-fabric

config-profile normal-mode type admin
  router ospf 100
   no shutdown
  router eigrp 101
   no shutdown
  router isis 102
   no set-overload-bit always
  router bgp 103
   no shutdown
  vpc domain 20
   no shutdown
  no system interface shutdown