Configuring BFD Support for EIGRP IPv6

Prerequisites for BFD Support for EIGRP IPv6

EIGRP IPv6 sessions have a shutdown option in router, address family, and address-family interface configuration modes. To enable BFD support on EIGRP IPv6 sessions, the routing process should be in no shut mode in the abovementioned modes.

Restrictions for BFD Support for EIGRP IPv6

  • The BFD Support for EIGRP IPv6 feature is supported only in EIGRP named mode.

  • EIGRP supports only single-hop Bidirectional Forwarding Detection (BFD).

  • The BFD Support for EIGRP IPv6 feature is not supported on passive interfaces.

Information About BFD Support for EIGRP IPv6

The BFD Support for EIGRP IPv6 feature provides Bidirectional Forwarding Detection (BFD) support for Enhanced Interior Gateway Routing Protocol (EIGRP) IPv6 sessions. It facilitates rapid fault detection and alternate-path selection in EIGRP IPv6 topologies. BFD is a detection protocol that provides a consistent failure-detection method for network administrators. Network administrators use BFD to detect forwarding path failures at a uniform rate and not at variable rates for 'Hello' mechanisms of different routing protocols. This failure-detection methodology ensures easy network profiling and planning and consistent and predictable reconvergence time. This document provides information about BFD support for EIGRP IPv6 networks and explains how to configure BFD support in EIGRP IPv6 networks.

How to Configure BFD Support for EIGRP IPv6

The following sections provide information on configuring BFD support for EIGRP IPv6 for an interface and all interfaces.

Configuring BFD Support on All Interfaces

The following steps show how to configure BFD support on all interfaces:

Procedure

  Command or Action Purpose

Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

ipv6 unicast-routing

Example:

Device(config)# ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams.

Step 4

interface type number

Example:

Device(config)# interface ethernet0/0

Specifies the interface type and number, and enters the interface configuration mode.

Step 5

ipv6 address ipv6-address/prefix-length

Example:

Device(config-if)# ipv6 address 2001:DB8:A:B::1/64

Configures an IPv6 address.

Step 6

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

Example:

Device(config-if)# bfd interval 50 min_rx 50 multiplier 3

Sets the baseline BFD session parameters on an interface.

Step 7

exit

Example:

Device(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 8

router eigrp virtual-name

Example:

Device(config)# router eigrp name

Specifies an EIGRP routing process and enters router configuration mode.

Step 9

address-family ipv6 autonomous-system as-number

Example:

Device(config-router)# address-family ipv6 autonomous-system 3

Enters address family configuration mode for IPv6 and configures an EIGRP routing instance.

Step 10

eigrp router-id ip-address

Example:

Device(config-router-af)# eigrp router-id 172.16.1.3

Sets the device ID used by EIGRP for this address family when EIGRP peers communicate with their neighbors.

Step 11

af-interface default

Example:

Device(config-router-af)# af-interface default

Configures interface-specific commands on all interfaces that belong to an address family in EIGRP named mode configurations. Enters address-family interface configuration mode.

Step 12

bfd

Example:

Device(config-router-af-interface)# bfd

Enables BFD on all interfaces.

Step 13

End

Example:

Device(config-router-af-interface)# end

Exits address-family interface configuration mode and returns to privileged EXEC mode.

Step 14

show eigrp address-family ipv6 neighbors detail

Example:

Device# show eigrp address-family ipv6 neighbors detail

(Optional) Displays detailed information about the neighbors that are discovered by EIGRP with BFD enabled on an interface.

Step 15

show bfd neighbors

Example:

Device# show bfd neighbors

(Optional) Displays BFD information to neighbors.

Configuring BFD Support on an Interface

The following steps show how to configure BFD support on an interface:

Procedure

  Command or Action Purpose

Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

ipv6 unicast-routing

Example:

Device(config)# ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams.

Step 4

interface type number

Example:

Device(config)# interface ethernet0/0

Specifies the interface type and number, and enters the interface configuration mode.

Step 5

ipv6 address ipv6-address /prefix-length

Example:

Device(config-if)# ipv6 address 2001:DB8:A:B::1/64

Configures an IPv6 address.

Step 6

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

Example:

Device(config-if)# bfd interval 50 min_rx 50 multiplier 3

Sets the baseline BFD session parameters on an interface.

Step 7

exit

Example:

Device(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 8

router eigrp virtual-name

Example:

Device(config)# router eigrp name

Specifies an EIGRP routing process and enters router configuration mode.

Step 9

address-family ipv6 autonomous-system as-number

Example:

Device(config-router)# address-family ipv6 autonomous-system 3

Enters address family configuration mode for IPv6 and configures an EIGRP routing instance.

Step 10

eigrp router-id ip-address

Example:

Device(config-router-af)# eigrp router-id 172.16.1.3

Sets the device ID used by EIGRP for this address family when EIGRP peers communicate with their neighbors.

Step 11

af-interface interface-type interface-number

Example:

Device(config-router-af)# af-interface ethernet0/0

Configures interface-specific commands on an interface that belongs to an address family in an EIGRP named mode configuration. Enters address-family interface configuration mode.

Step 12

bfd

Example:

Device(config-router-af-interface)# bfd

Enables BFD on the specified interface.

Step 13

end

Example:

Device(config-router-af-interface)# end

Exits address-family interface configuration mode and returns to privileged EXEC mode.

Step 14

show eigrp address-family ipv6 neighbors

Example:

Device# show eigrp address-family ipv6 neighbors

(Optional) Displays neighbors for which have BFD enabled.

Step 15

show bfd neighbors

Example:

Device# show bfd neighbors

(Optional) Displays BFD information to neighbors.

Configuration Examples for BFD Support for EIGRP IPv6

The following sections provide configuration examples for BFD support for EIGRP:

Example: Configuring BFD Support on All Interfaces

Device> enable
Device# configure terminal
Device(config)# ipv6 unicast-routing
Device(config)# interface Ethernet0/0
Device(config-if)# ipv6 address 2001:0DB8:1::12/64
Device(config-if)# bfd interval 50 min_rx 50 multiplier 3
Device(config-if)# exit 
Device(config)# router eigrp name
Device(config-router)# address-family ipv6 unicast autonomous-system 1 
Device(config-router-af)# eigrp router-id 172.16.0.1
Device(config-router-af)# af-interface default
Device(config-router-af-interface)# bfd
Device(config-router-af-interface)# end

The following example displays the output for the show eigrp address-family ipv6 neighbors detail command.

Device# show eigrp address-family ipv6 neighbors detail
EIGRP-IPv6 VR(test) Address-Family Neighbors for AS(5)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Et0/0                    14 00:02:04    1  4500  0  4
    FE80::10:2
   Version 23.0/2.0, Retrans: 2, Retries: 0, Prefixes: 1
   Topology-ids from peer - 0
   Topologies advertised to peer:   base

Max Nbrs: 0, Current Nbrs: 0

BFD sessions
NeighAddr         Interface
FE80::10:2            Ethernet0/0

The following example displays the output for the show bfd neighbor command.

Device# show bfd neighbors

IPv6 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
FE80::10:2                              2/0          Down      Down      Et0/0

Example: Configuring BFD Support on an Interface

The following example shows how to configure BFD Support on an interface:

Device> enable
Device# configure terminal
Device(config)# ipv6 unicast-routing
Device(config)# Ethernet0/0
Device(config-if)# ipv6 address 2001:DB8:A:B::1/64
Device(config-if)# bfd interval 50 min_rx 50 multiplier 3
Device(config-if)# exit
Device(config)# router eigrp name
Device(config-router)# address-family ipv6 autonomous-system 3
Device(config-router-af)# af-interface Ethernet0/0
Device(config-router-af-interface)# bfd
Device(config-router-af-interface)# end

Additional References

Related Documents

Related Topic

Document Title

BFD commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples.

See the IP Routing section of the Command Reference (Catalyst 9400 Series Switches)

EIGRP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples.

See the IP Routing section of the Command Reference (Catalyst 9400 Series Switches)

Configuring EIGRP

See the Routing section of the Software Configuration Guide (Catalyst 9400 Series Switches)

Feature History for Configuring BFD-EIGRP Support

This table provides release and related information for the features explained in this module.

These features are available in all the releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Everest 16.6.x

BFD-EIGRP Support

The BFD-EIGRP Support feature configures the EIGRP with BFD so that EIGRP registers with BFD and receives all forwarding path detection failure messages from BFD.

Use the Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn.