Configuring Ethernet Management Port

Prerequisites for Ethernet Management Port

When connecting a PC to the Ethernet management port, you must first assign an IP address.

Restrictions for Ethernet Management Port

The ethernet management port relay is not supported on the Cisco Catalyst 9600 Series Supervisor 1 Module and Cisco Catalyst 9600 Series Supervisor 2 Module.

Information About the Ethernet Management Port

The Ethernet management port, also referred to as the Gi0/0 or GigabitEthernet0/0 port, is a VRF (VPN routing/forwarding) interface to which you can connect a PC. You can use the Ethernet management port instead of the device console port for network management.

In addition, Cisco Catalyst 9600 Series Switches have another Ethernet management port, TenGigabitEthernet0/1, an SFP+ interface that provides pluggable connectivity from the device to the management network. This interface supports 10G and 1G transceivers.

By default, GigabitEthernet0/0 is enabled. You can disable GigabitEthernet0/0 and enable TenGigabitEthernet0/1 by doing either one of the following:

  • Using the platform management-interface TenGigabitEthernet0/1 command and restarting the device. You can switch back to the default management port by using the no platform management-interface TenGigabitEthernet0/1 command and restarting the device.

  • Setting the environment variable ETHER_PORT to 1 in the ROMMON mode and restarting the switch. You can switch back to the default management port by setting the ETHER_PORT variable to 2 in ROMMON mode and restarting the switch.

Ethernet Management Port Direct Connection to a Device

Figure 1. Connecting a Device to a PC. This figure displays how to connect the Ethernet management port to the PC for a device or a standalone device.


Ethernet Management Port with StackWise Virtual

Physically, the Ethernet management port needs to be connected from both active and standby switches to the uplink switch. Since the switches in a Cisco StackWise Virtual solution use a single management plane, the same IP address is applicable to both active and standby switches. After stateful switchover (SSO) between the active and standby switches, the Ethernet Management port on the active (previously standby) switch will link up and continue to support management functionalities.


Note


Any SSH, SCP, or Telnet sessions established by clients over the Ethernet management port IP address before stateful switchover to a new active switch in StackWise Virtual will be terminated and a new session has to be initiated after switchover.


Ethernet Management Port and Routing

By default, the Ethernet management port is enabled. The device cannot route packets from the Ethernet management port to a network port, and the reverse. Even though the Ethernet management port does not support routing, you may need to enable routing protocols on the port.

Figure 2. Network Example with Routing Protocols Enabled. Enable routing protocols on the Ethernet management port when the PC is multiple hops away from the device and the packets must pass through multiple Layer 3 devices to reach the PC.


In the above figure, if the Ethernet management port and the network ports are associated with the same routing process, the routes are propagated as follows:

  • The routes from the Ethernet management port are propagated through the network ports to the network.

  • The routes from the network ports are propagated through the Ethernet management port to the network.

Because routing is not supported between the Ethernet management port and the network ports, traffic between these ports cannot be sent or received. If this happens, data packet loops occur between the ports, which disrupt the device and network operation. To prevent the loops, configure route filters to avoid routes between the Ethernet management port and the network ports.

Supported Features on the Ethernet Management Port

The Ethernet management port supports these features:

  • Express Setup (only in device stacks)

  • Network Assistant

  • Telnet with passwords

  • TFTP

  • Secure Shell (SSH)

  • DHCP-based autoconfiguration

  • SNMP (only ENTITY-MIB and IF-MIB)

  • IP ping

  • Interface features:

    • Speed: 10 Mb/s, 100 Mb/s, 1000 Mb/s, and autonegotiation (default)

    • Duplex mode: Full, half, and autonegotiation

    • Loopback detection

  • Cisco Discovery Protocol (CDP)

  • DHCP relay agent


Caution


Before enabling a feature on the Ethernet management port, make sure that the feature is supported. If you try to configure an unsupported feature on the Ethernet Management port, the feature might not work properly, and the device might fail.


How to Configure the Ethernet Management Port

This section contains the procedures of how to configure the Ethernet Management Port.

Disabling and Enabling the Ethernet Management Port

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 2

interface gigabitethernet0/0

Example:

Device(config)# interface gigabitethernet0/0

Specifies the Ethernet management port in the CLI.

Step 3

shutdown

Example:

Device(config-if)# shutdown

Disables the Ethernet management port.

Step 4

no shutdown

Example:

Device(config-if)# no shutdown

Enables the Ethernet management port.

Step 5

exit

Example:

Device(config-if)# exit

Exits interface configuration mode.

Step 6

show interfaces gigabitethernet0/0

Example:

Device# show interfaces gigabitethernet0/0

Displays the link status.

To find out the link status to the PC, you can monitor the LED for the Ethernet management port. The LED is green (on) when the link is active, and the LED is off when the link is down. The LED is amber when there is a POST failure.

What to do next

Proceed to manage or configure your device using the Ethernet management port. See the Network Management section.

Enabling TenGigabitEthernet Management Port

Follow these steps to enable the SFP+ interface that provides pluggable connectivity from the device to the management interface. Enabling the TenGigabitEthernet management port on the Supervisor disables the GigabitEthernet management port.

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 2

platform management-interface TenGigabitEthernet0/1

Example:

Device(config)# platform management-interface TenGigabitEthernet0/1

Changes the default management port of GigabitEthernet0/0 to TenGigabitEthernet0/1.

This change will take effect after restarting the device.

To switch back to the default management port, use the no form of this command, and restart the device.

Step 3

end

Example:

Device(config)# end

Exits the global configuration mode and enters privileged EXEC mode.

Step 4

show platform management-interface

Example:

Device# show platform management-interface

(Optional) Displays information about the active and configured management port.

Step 5

reload

Example:

Device# reload

Boots up the device.

Step 6

show platform management-interface

Example:

Device# show platform management-interface

(Optional) Displays information about the active management port.

Example for Configuring IP Address on Ethernet Management Interface

This example shows how to configure IP address on the GigabitEthernet0/0 management interface.

Device# configure terminal
Device(config)# interface gigabitethernet0/0 
Device(config-if)# vrf forwarding Mgmt-vrf
Device(config-if)# ip address 192.168.247.10 255.255.0.0
Device(config-if)# end
Device# show running-config interface Gi0/0

Building configuration...

Current configuration : 118 bytes
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
ip address 192.168.247.10 255.255.0.0
negotiation auto
end

This example shows how to configure IP address on the TenGigabitEthernet0/1 management interface.

Device# configure terminal
Device(config)# interface TenGigabitEthernet0/1 
Device(config-if)# vrf forwarding Mgmt-vrf
Device(config-if)# ip address 192.168.247.20 255.255.0.0
Device(config-if)# negotiation auto
Device(config-if)# end
Device# show running-config interface Te0/1

Building configuration...

Current configuration : 118 bytes
!
interface TenGigabitEthernet0/1
 vrf forwarding Mgmt-vrf
 ip address 192.168.247.20 255.255.0.0
 negotiation auto
end

Monitoring the Ethernet Management Port

Commands entered at the privileged EXEC prompt display information about the management port, including the list of transceivers that are supported on the pluggable management port.

Table 1. show Commands for Ethernet Management Port

Command

Purpose

show platform management-interface

Displays the active management port.

show interfaces transceiver supported-list | b management interface

Displays the list of transceivers that are supported on the pluggable management port.

The following example shows a sample output of the show platform management-interface command. The command output displays the active management port.

Device# show platform management-interface

Management interface is GigabitEthernet0/0

The following example shows a sample output of the show interfaces transceiver supported-list | b management interface command. The command output displays all the transceivers that are supported on the pluggable management port.

Device# show interfaces transceiver supported-list | b management interface

Transceivers supported on management interface TenGigabitEthernet0/1:
   GLC-SX-MM                NONE
   GLC-SX-MMD               ALL
   SFP-10G-LR               ALL
   SFP-10G-LR-S             ALL
   SFP-10G-SR               ALL
   SFP-10G-SR-S             ALL
   SFP-H10GB-CU1M           NONE
   SFP-H10GB-CU3M           NONE
   SFP-H10GB-CU5M           NONE

Additional References for Ethernet Management Port

Related Documents

Related Topic Document Title
Bootloader configuration

See the System Management section of this guide.

Bootloader commands

See the System Management Commands section of the Command Reference (Catalyst 9600 Series Switches).

Feature History for Ethernet Management Port

This table provides release and related information for features explained in this module.

These features are available on all releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Gibraltar 16.11.1

Ethernet Management Port

The Ethernet management port is a VRF interface to which you can connect a PC. You can use the Ethernet management port instead of the device console port for network management.

Cisco IOS XE Gibraltar 16.12.x

Changing Ethernet Management Port

The platform management-interface command was introduced to change the default management port.

Use Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/.