Configuring Smartports Macros


This chapter describes how to configure Smartports macros on the IE 3000 switch.


Note For complete syntax and usage information for the commands used in this chapter, see the command reference for this release.


Understanding Smartports Macros

Configuring Smartports Macros

Displaying Smartports Macros

Understanding Smartports Macros

Smartports macros provide a convenient way to save and share common configurations. You can use Smartports macros to enable features and settings based on the location of a switch in the network and for mass configuration deployments across the network.

Each Smartports macro is a set of CLI commands that you define. Smartports macros do not contain new CLI commands; they are simply a group of existing CLI commands.

When you apply a Smartports macro to an interface, the CLI commands within the macro are configured on the interface. When the macro is applied to an interface, the existing interface configurations are not lost. The new commands are added to the interface and are saved in the running configuration file.

Configuring Smartports Macros

Default Smartports Configuration

Smartports Configuration Guidelines

Applying Smartports Macros

Default Smartports Configuration

There are no Smartports macros enabled on the switch.

Table 14-1 Default Smartports Macros 

Macro Name 1
Description

cisco-ie-global

Use this global configuration macro to configure the switch settings for the industrial Ethernet environment. This macro is automatically applied when you use Express Setup to initially configure the switch.

Note You must first apply the cisco-ie-global macro for the cisco-ethernetip macro to work properly.

cisco-ie-desktop

Use this interface configuration macro for increased network security and reliability when connecting a desktop device, such as a PC, to a switch port. This macro is optimized for industrial automation traffic.

cisco-ie-phone

Use this interface configuration macro when connecting a desktop device such as a PC with a Cisco IP Phone to a switch port. This macro is an extension of the cisco-ie-desktop macro and provides the same security and resiliency features, but with the addition of dedicated voice VLANs to ensure proper treatment of delay-sensitive voice traffic. This macro is optimized for industrial automation traffic.

cisco-ie-switch

Use this interface configuration macro when connecting an access switch and a distribution switch or between access switches connected using small form-factor pluggable (SFP) modules. This macro is optimized for industrial automation traffic.

cisco-ie-router

Use this interface configuration macro when connecting the switch and a WAN router. This macro is optimized for industrial automation traffic.

cisco-ie-wireless

Use this interface configuration macro when connecting the switch and a wireless access point. This macro is optimized for industrial automation traffic.

cisco-ethernetip

Use this interface configuration macro when connecting the switch to an EtherNet IP device.

Note You must first apply the cisco-ie-global macro for the cisco-ethernetip macro to work properly.

1 Cisco-default Smartports macros vary, depending on the software version running on your switch.


Smartports Configuration Guidelines

When a macro is applied globally to a switch or to a switch interface, all existing configuration on the interface is retained. This is helpful when applying an incremental configuration.

If a command fails because of a syntax or a configuration error, the macro continues to apply the remaining commands. You can use the macro global trace macro-name global configuration command or the macro trace macro-name interface configuration command to apply and debug a macro to find any syntax or configuration errors.

Some CLI commands are specific to certain interface types. If you apply a macro to an interface that does not accept the configuration, the macro fails the syntax or the configuration check, and the switch returns an error message.

Applying a macro to an interface range is the same as applying a macro to a single interface. When you use an interface range, the macro is applied sequentially to each interface within the range. If a macro command fails on one interface, it is still applied to the remaining interfaces.

When you apply a macro to a switch or a switch interface, the macro name is automatically added to the switch or interface. You can display the applied commands and macro names by using the show running-config user EXEC command.

Applying Smartports Macros

Beginning in privileged EXEC mode, follow these steps to apply a Smartports macro:

 
Command
Purpose

Step 1 

show parser macro

Display the Cisco-default Smartports macros embedded in the switch software.

Step 2 

show parser macro name macro-name

Display the specific macro that you want to apply.

Step 3 

configure terminal

Enter global configuration mode.

Step 4 

macro global {apply | trace} macro-name [parameter {value}] [parameter {value}] [parameter {value}]

Apply each individual command defined in the macro to the switch by entering macro global apply macro-name. Specify macro global trace macro-name to apply and to debug a macro to find any syntax or configuration errors.

Append the macro with the required values by using the parameter value keywords. Keywords that begin with $ require a unique parameter value.

You can use the macro global apply macro-name ? command to display a list of any required values for the macro. If you apply a macro without entering the keyword values, the commands are invalid and are not applied.

(Optional) Specify unique parameter values that are specific to the switch. You can enter up to three keyword-value pairs. Parameter keyword matching is case sensitive. The corresponding value replaces all matching occurrences of the keyword.

Step 5 

interface interface-id

(Optional) Enter interface configuration mode, and specify the interface on which to apply the macro.

Step 6 

default interface interface-id

(Optional) Clear all configuration from the specified interface.

Step 7 

macro {apply | trace} macro-name [parameter {value}] [parameter {value}] [parameter {value}]

Apply each individual command defined in the macro to the port by entering macro global apply macro-name. Specify macro global trace macro-name to apply and to debug a macro to find any syntax or configuration errors.

Append the macro with the required values by using the parameter value keywords. Keywords that begin with $ require a unique parameter value.

You can use the macro global apply macro-name ? command to display a list of any required values for the macro. If you apply a macro without entering the keyword values, the commands are invalid and are not applied.

(Optional) Specify unique parameter values that are specific to the switch. You can enter up to three keyword-value pairs. Parameter keyword matching is case sensitive. The corresponding value replaces all matching occurrences of the keyword.

Step 8 

end

Return to privileged EXEC mode.

Step 9 

show running-config interface interface-id

Verify that the macro is applied to an interface.

Step 10 

copy running-config startup-config

(Optional) Save your entries in the configuration file.

You can only delete a global macro-applied configuration on a switch by entering the no version of each command in the macro. You can delete a macro-applied configuration on a port by entering the default interface interface-id interface configuration command.

This example shows how to display the cisco-ie-desktop macro, how to apply the macro and to set the access VLAN ID to 25 on an interface:

Switch# show parser macro name cisco-ie-desktop
--------------------------------------------------------------
Macro name : cisco-ie-desktop 
Macro type : default interface 
# macro keywords $access_vlan  
#macro name cisco-ie-desktop 
switchport mode access 
switchport access vlan $access_vlan 
switchport port-security 
switchport port-security maximum 1 
switchport port-security aging time 2 
switchport port-security violation restrict 
switchport port-security aging type inactivity 
spanning-tree portfast 
spanning-tree bpduguard enable 
no macro description  
macro description cisco-ie-desktop
--------------------------------------------------------------
Switch#
Switch# configure terminal
Switch(config)# interface gigabitethernet1/4
Switch(config-if)# macro apply cisco-ie-desktop $AVID 25

This example shows how to display the cisco-ethernetip macro and how to apply it to an interface:

Switch# show parser macro name cisco-ethernetip
Macro name : cisco-ie-global
Macro type : default interface
#macro name cisco-ethernetip
#macro keywords $access_vlan
#macro description cisco-ethernetip
switchport host
switchport access vlan $access_vlan
storm-control broadcast level 3.00 1.00
service-policy input CIP-Traffic
#service-policy input 1588

Switch# configure terminal 
Switch(config)# interface fastethernet 1/1 
Switch(config-if)# macro apply cisco-ethernetip $access_vlan 1 
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled 

Displaying Smartports Macros

To display the Smartports macros, use one or more of the privileged EXEC commands in Table 14-2.

Table 14-2 Commands for Displaying Smartports Macros 

Command
Purpose

show parser macro

Displays all Smartports macros.

show parser macro name macro-name

Displays a specific Smartports macro.

show parser macro brief

Displays the Smartports macro names.

show parser macro description [interface interface-id]

Displays the Smartports macro description for all interfaces or for a specified interface.