IPv6 Support on Flex and Mesh

IPv6 Support on Flex + Mesh Deployment

IPv6 is the backhaul transport of the Service Provider. The IPv6 support over flex + mesh feature is now supported on the Cisco Catalyst 9800 Series Wireless Controller . WLAN accepts IPv6 clients and forward the traffic.

Configuring IPv6 Support for Flex + Mesh

Follow the procedure given below to enable the IPv6 routing on the controller :

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 2

interface vlan vlan-interface-number

Example:

Device(config)#interface vlan 89

Creates an interface and enters the interface configuration mode.

Step 3

shutdown

Example:

Device(config-if)#shutdown

Disables the interface configuration.

Step 4

ipv6 enable

Example:

Device(config-if)#ipv6 enable

Optional. Enables IPv6 on the interface.

Step 5

ipv6 address X:X:X:X::X/<0-128>

Example:

Device(config-if)#ipv6 address 1:1:1:1::1/64

Configures IPv6 address on the interface using the IPv6 prefix option.

Step 6

no shutdown

Example:

Device(config-if)#no shutdown

Enables the IPv6 address.

Step 7

no shutdown

Example:

Device(config-if)#no shutdown

Enables the PIM dense-mode operation.

Step 8

end

Example:

Device(config-if)#end

Returns to privileged EXEC mode.

Step 9

show ipv6 interface brief

Example:

Device#show ipv6 interface brief

Verifies your entries.

Step 10

ping ipv6 destination-address or hostname

Example:

Device#ping ipv6 1:1:1:1::10

Checks the gateway connectivity.

Configuring Preferred IP Address as IPv6 (GUI)

Procedure


Step 1

Choose Configuration > Tags & Profiles > AP Join.

Step 2

Click the AP Join Profile Name. The Edit AP Join Profile window is displayed.

Step 3

Choose CAPWAP > Advanced.

Step 4

From the Preferred Mode drop-down list, select IPV6.

Step 5

Click Update & Apply to Device.


Configuring Preferred IP Address as IPv6

Procedure

  Command or Action Purpose

Step 1

Configure Terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 2

ap profile default-ap-profile

Example:

Device(config)# ap profile default-ap-profile

Enters AP profile configuration mode.

Step 3

preferred-mode ipv6

Example:

Device(config-ap-profile)# preferred-mode ipv6

Uses IPv6 to join the controller .

Step 4

end

Example:

Device(config-ap-profile)# end

Exits the configuration mode and returns to privileged EXEC mode.

Verifying IPv6 on Flex+Mesh

To verify the IPv6 configuration on the controller , use the following show command:

Device#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet2       unassigned      YES unset  up                    up      
GigabitEthernet0       unassigned      YES NVRAM  administratively down down    
Capwap1                unassigned      YES unset  up                    up      
Capwap2                unassigned      YES unset  up                    up      
Vlan1                  unassigned      YES NVRAM  administratively down down    
Vlan89                 9.10.89.90      YES NVRAM  up                    up      
Ewlc-9.10.89.90#show running-config interface vlan 89
Building configuration...
 
Current configuration : 120 bytes
!
interface Vlan89
 ip address 9.10.89.90 255.255.255.0
 ip helper-address 9.1.0.100
 no mop enabled
 no mop sysid
end