Sample UPF Configuration

Sample Configuration

The following is only a sample configuration file provided solely for your reference. You must create and modify your own configuration file according to the specific needs of your deployment.

----- snip -----
  active-charging service acs
    bandwidth-policy BWP
      flow limit-for-bandwidth id 1 group-id 2
      flow limit-for-bandwidth id 2 group-id 3
      flow limit-for-bandwidth id 100 group-id 100
      group-id 2 direction uplink peak-data-rate 256000 peak-burst-size 1000 violate-action discard
      group-id 2 direction downlink peak-data-rate 200000 peak-burst-size 1000 violate-action discard
      group-id 3 direction downlink peak-data-rate 256000 peak-burst-size 1000 violate-action discard
      group-id 4 direction uplink peak-data-rate 300000 peak-burst-size 1200 violate-action lower-ip-precedence
      group-id 100 direction downlink peak-data-rate-kbps 4294967295 peak-burst-size 4294967295 violate-action discard

    ruledef L3_SERVER
      ip server-ip-address = 209.165.202.150/27
      tcp either-port = 80
    #exit
    ruledef L4_PORT
      tcp either-port = 80
      udp either-port = 80
      multi-line-or all-lines
    #exit
    ruledef L7_HTTP
      http host contains 209.165.202.150
      multi-line-or all-lines
    #exit
    ruledef http-pkts
      http any-match = TRUE
    #exit
    ruledef http-port
      tcp either-port = 80
      rule-application routing
    #exit
    ruledef ip-any-rule
      ip any-match = TRUE
    #exit
    urr-list urrs
      rating-group 10 urr-id 5
    #exit
    charging-action starent
      content-id 10
      billing-action egcdr
    #exit
    rulebase default
    #exit
    credit-control group default
      pending-traffic-treatment noquota buffer
      pending-traffic-treatment quota-exhausted pass
      usage-reporting quotas-to-report based-on-grant
      
    rulebase starent
      billing-records egcdr
      dynamic-rule order first-if-tied
      action priority 5 ruledef http-pkts charging-action standard
      action priority 10 ruledef L7_HTTP charging-action starent
      action priority 20 ruledef L4_PORT charging-action starent
      action priority 100 ruledef L3_SERVER charging-action starent
      action priority 10000 ruledef ip-any-rule charging-action starent
      route priority 1 ruledef http-port analyzer http
      egcdr threshold interval 1000
      bandwidth default-policy BWP
    #exit
    traffic-optimization-policy default
    #exit
  #exit
  context ingress
    interface N3_interface
      ip address 209.165.201.4 209.165.201.5
      ipv6 address abc0:0:0:cb::1/64 secondary
    #exit
    interface N3_interface_LOGICAL loopback
      ip address 209.165.201.4 209.165.201.5
    #exit
    interface N3_interface_LOGICAL2 loopback
      ip address 209.165.201.4 209.165.201.5
    #exit
    interface N4U_interface
      ip address 209.165.201.4 209.165.201.5
      ipv6 address abc0:0:0:cd::1/64 secondary
      ipv6 address abc0:0:0:ca::1/64 secondary
    #exit
    interface N4U_interface_LOGICAL loopback
      ip address 209.165.201.4 209.165.201.5
    #exit
   interface N4_interface
      ip address 209.165.201.4 209.165.201.5
      ipv6 address abc0:0:0:cc::1/64 secondary
    #exit
    interface N4_interface_LOGICAL loopback
      ip address 209.165.201.4 209.165.201.5
    #exit
    subscriber default
    exit
    aaa group default
    #exit
    gtpp group default
    #exit
    gtpu-service N3-GNB1
      bind ipv4-address 209.165.200.225
    exit
    gtpu-service N3-GNB2
      bind ipv4-address 209.165.201.4
    exit
    gtpu-service control_gtpu
      bind ipv4-address 209.165.201.4
    exit
    sx-service N4
      instance-type userplane
      bind ipv4-address 209.165.201.4
      sx-protocol heartbeat interval 3600
      sx-protocol heartbeat max-retransmissions 1
      sx-protocol association reattempt-timeout 30
    exit
    user-plane-service user-plane-service
      associate gtpu-service N3-GNB1 upf-ingress
      associate gtpu-service control_gtpu cp-tunnel
      associate sx-service N4 
      associate fast-path service
      associate control-plane-group default 
      load-control capacity 900
    exit
    user-plane-service user-plane-service1
    exit
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N4_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N4_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N3_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N3_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N4_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N3_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N4_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N3_interface
  #exit
  context egress
    interface N6_interface
      ip address 209.165.201.4 209.165.201.5
      ipv6 address abc0:0:0:cf::1/64 secondary
    #exit
    subscriber default
    exit
    apn starent.com
      pdp-type ipv4 ipv6
      selection-mode subscribed sent-by-ms chosen-by-sgsn
      gtpp group default accounting-context egress
      ip context-name egress
      active-charging rulebase starent
    exit
    aaa group default
    #exit
    gtpp group default
      gtpp attribute local-record-sequence-number
      gtpp dictionary custom24
      gtpp egcdr service-data-flow threshold interval 60
      gtpp egcdr service-data-flow threshold volume downlink 13000
      gtpp egcdr service-data-flow threshold volume uplink 17000
      gtpp egcdr service-data-flow threshold volume total 22222
    #exit
    ipv6 route 2:2:2:2::/64 next-hop abc0::ab:1c:2ff:def9:1ad interface N6_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N6_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N6_interface
    ipv6 route 2:2:2:2::/64 next-hop abc0::ab:1c:2ff:def9:1ab interface N6_interface
    ip route 209.165.201.4 209.165.201.5 209.165.201.6 N6_interface
  #exit
  control-plane-group default
    sx-association initiated-by-cp
    peer-node-id ipv4-address 209.165.200.225 interface n4
  #exit
  user-plane-group default
  #exit
  port ethernet 1/11
    no shutdown
    vlan 203
      no shutdown
      bind interface N4U_interface ingress
    #exit
    vlan 204
      no shutdown
      bind interface N4_interface ingress
    #exit
    vlan 205
      no shutdown
      bind interface N3_interface ingress
    #exit
    vlan 206
      no shutdown
    #exit
    vlan 207
      no shutdown
      bind interface N6_interface egress
    #exit
  #exit
end