SRTE over Default VRF

About SRTE Over Default VRF

The SRTE Over Default VRF feature allows you to incorporate segment routing traffic engineering to achieve the traffic steering benefits in your network. The SRTE provides increased scalability while using BGP for routing in large-scale data centers (DC).

The SRTE Over Default VRF feature uses the route color that exists as an extended community attribute and is represented by a number as the base for traffic steering. Based on the color, plane separation is achieved, and an SR policy is created to carry the traffic. Furthermore, based on the color, the DC is divided into different planes. The applications are configured to use each plane to only route through a specific plane and steer traffic to appropriate destinations.

Plane separation has the following advantages:

  • One flow does not affect the other flow.

  • Large and small flows are separated into different planes.

  • Fault isolation for better debuggability: Fault in one plane does not affect the other planes. For example, if a network fault occurs in one plane, only the applications in that plane are affected, but the applications in the rest of the planes are not impacted. Additionally, the fault can be isolated and troubleshooted in isolation.

The following example explains the SRTE Over Default VRF feature with an illustration.

Figure 1. SRTE Over Default VRF Example
  • For BGP, node A is the ingress router and node D is the egress router. D is also the next-hop.

  • For SRTE, node A is the SRTE headend, node D is the endpoint for the policy.

  • Route prefix 1 is configured to use the blue plane, and route 2 is configured to use the red plane.

The blue traffic is appended with instructions to steer the traffic through node B and node C, and the red traffic is appended with instruction to steer traffic through node E and node F. In summary, the traffic is handled based on the color of the advertisement, that is, the prefix that was advertised earlier.

Guidelines and Limitations for Configuring SRTE Over Default VRF

  • Beginning with Cisco NX-OS Release 10.1(1), segment routing traffic engineering is supported over default VRF on Cisco Nexus 9300-FX3, N9K-C9316D-GX , N9K-C93180YC-FX, N9K-C93240YC-FX2, and N9K-C9364C platform switches. The limitations for this SR-TE feature are as follows:

    • UnderLay IPv6 is not supported. SRv6 is the alternate.

    • PCE using BGP underlay is not supported, due to PCE’s shortcoming on BGP only fabric.

    • OSPF-SRTE with PCE is not supported, due to NXOS’ inability to advertise LSA in BGP-LS.

    • Supports total SRTE policy scale of 1000, BGP Default VRF(v4) of 130K v4, and underlay SR prefixes of 1000.

  • Beginning with Cisco NX-OS Release 10.2(3)F, the option of color-only (CO) bits is added in route map. If the value of the CO bits change for a given prefix that is using an SRTE policy, BGP will delete the old policy and add a new policy. This feature is supported on Cisco Nexus 9300-EX, 9300-FX, 9300-FX2, 9300-GX, and 9300-GX2 platform switches./

Configuration Process: SRTE Over Default VRF

The configuration process is as follows:

  1. Set next-hop unchanged: The next-hop is used to calculate the SR policy at the ingress node. The next-hop in the SR domain on a prefix must be preserved as the prefix is advertised upstream. Hence, next-hop unchanged in needed on all upstream routers in the case for hop-by-hop ebgp.

  2. Set extended community color at the egress node, ingress node, network/redistribute, or default-originate.

  3. The ingress node, on receiving a color-extended community, matches it to an SR policy.

  4. The endpoint for the SR policy is derived from the next-hop of the prefix and color in the color-extended community.

This section includes the following topics on configuring SRTE over default VRF:

Configuring Next-hop Unchanged

To configure next-hop unchanged on the intermediate (spine) nodes for default VRF overlay, to ensure the next-hop is not changed, perform the following steps:

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

route-map map-name

Example:

switch(config)# route-map ABC 
switch(config-route-map)

Creates a route map or enters route-map configuration mode for an existing route map.

Step 3

[no] set ip next-hop unchanged

Example:

switch(config-route-map)# set ip next-hop unchanged
switch(config-route-map)#

Sets next-hop unchanged.

Step 4

exit

Example:

switch(config-route-map)# exit
switch(config)#

Exits route-map configuration mode.

Step 5

[no] router bgp autonomous-system-number

Example:

switch(config)# router bgp1
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 6

neighbor ip-address

Example:

switch(config-router)# neighbor 209.165.201.1
switch(config-router-neighbor)#

Adds an entry to the BGP or multiprotocol BGP neighbor table. The ip-address argument specifies the IP address of the neighbor in dotted decimal notation.

Step 7

address-family ipv4 unicast

Example:

switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)#

Enters router address-family configuration mode for the IPv4 address family type.

Step 8

route-map map-name out

Example:

switch(config-router-neighbor-af)# route-map ABC out
switch(config-router-neighbor-af)#

Applies the configured BGP policy to outgoing routes.

Configuring Extended Community Color

This section includes the following topics:

Configuring Extended Community Color at the Egress Node

To configure extended community color at the egress node when the prefix is announced by the egress node, perform the following steps:

Procedure
  Command or Action Purpose

Step 1

configure terminal

Example:
switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

route-map map-name

Example:
switch(config)# route-map ABC 
switch(config-route-map)

Creates a route map or enters route-map configuration mode for an existing route map.

Step 3

set extcommunity color color-num [co-flag co-flag]

Example:
switch(config-route-map)# set extcommunity color 20 [co-flag 00]
switch(config-route-map)#

Sets BGP extcommunity attribute for color extended community.

co-flag: Use the color-only flag to control whether traffic may be steered into an SR Policy based on color only, if no policy can be found for the exact color and endpoint. The default is 00.

Note

 

Select the co-flag 00 to specify the default Automated Steering function based on color and nexthop. When the co-flag is 00 or set to default, the binding sid of the policy with the requested color and endpoint is used for routing.

Select the co-flag 01 to steer traffic based on color only. When the co-flag is set to 01, and if the policy with requested color and endpoint exists, the binding sid of the policy is used for routing. If the policy does not exist, but the null endpoint policy with the same color exists, then the binding sid of the null endpoint policy is used for routing.

Step 4

exit

Example:
switch(config-route-map)# exit
switch(config)#

Exits route-map configuration mode.

Step 5

[no] router bgp autonomous-system-number

Example:
switch(config)# router bgp1
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 6

neighbor ip-address

Example:
switch(config-router)# neighbor 209.165.201.1
switch(config-router-neighbor)#

Adds an entry to the BGP or multiprotocol BGP neighbor table. The ip-address argument specifies the IP address of the neighbor in dotted decimal notation.

Step 7

address-family ipv4 unicast

Example:
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)#

Enters router address-family configuration mode for the IPv4 address family type.

Step 8

route-map map-name out

Example:
switch(config-router-neighbor-af)# route-map ABC out
switch(config-router-neighbor-af)#

Applies the configured BGP policy to outgoing routes.

The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Configuring Extended Community Color at the Ingress Node

To configure extended community color at the ingress node when the prefix is announced by the ingress node, where the SRTE policy is instantiated, perform the following steps:

Procedure
  Command or Action Purpose

Step 1

configure terminal

Example:
switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

route-map map-name

Example:
switch(config)# route-map ABC 
switch(config-route-map)

Creates a route map or enters route-map configuration mode for an existing route map.

Step 3

set extcommunity color color-num [co-flag co-flag]

Example:
switch(config-route-map)# set extcommunity color 20 [co-flag 00]
switch(config-route-map)#

Sets BGP extcommunity attribute for color extended community.

co-flag: Use the color-only flag to control whether traffic may be steered into an SR Policy based on color only, if no policy can be found for the exact color and endpoint. The default is 00.

Note

 

Select the co-flag 00 to specify the default Automated Steering function based on color and nexthop. When the co-flag is 00 or set to default, the binding sid of the policy with the requested color and endpoint is used for routing.

Select the co-flag 01 to steer traffic based on color only. When the co-flag is set to 01, and if the policy with requested color and endpoint exists, the binding sid of the policy is used for routing. If the policy does not exist, but the null endpoint policy with the same color exists, then the binding sid of the null endpoint policy is used for routing.

Step 4

exit

Example:
switch(config-route-map)# exit
switch(config)#

Exits route-map configuration mode.

Step 5

[no] router bgp autonomous-system-number

Example:
switch(config)# router bgp1
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 6

neighbor ip-address

Example:
switch(config-router)# neighbor 209.165.201.1
switch(config-router-neighbor)#

Adds an entry to the BGP or multiprotocol BGP neighbor table. The ip-address argument specifies the IP address of the neighbor in dotted decimal notation.

Step 7

address-family ipv4 unicast

Example:
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)#

Enters router address-family configuration mode for the IPv4 address family type.

Step 8

route-map map-name in

Example:
switch(config-router-neighbor-af)# route-map ABC in
switch(config-router-neighbor-af)#

Applies the configured BGP policy to incoming routes.

The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Configuring Extended Community Color for Network/Redistribute Command at the Egress Node

To configure extended community color for the network/redistribute command at the egress node when the prefix is announced by the egress node, perform the following steps:

Procedure
  Command or Action Purpose

Step 1

configure terminal

Example:
switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

route-map map-name

Example:
switch(config)# route-map ABC 
switch(config-route-map)

Creates a route map or enters route-map configuration mode for an existing route map.

Step 3

set extcommunity color color-num [co-flag co-flag]

Example:
switch(config-route-map)# set extcommunity color 20 [co-flag 00]
switch(config-route-map)#

Sets BGP extcommunity attribute for color extended community.

co-flag: Use the color-only flag to control whether traffic may be steered into an SR Policy based on color only, if no policy can be found for the exact color and endpoint. The default is 00.

Note

 

Select the co-flag 00 to specify the default Automated Steering function based on color and nexthop. When the co-flag is 00 or set to default, the binding sid of the policy with the requested color and endpoint is used for routing.

Select the co-flag 01 to steer traffic based on color only. When the co-flag is set to 01, and if the policy with requested color and endpoint exists, the binding sid of the policy is used for routing. If the policy does not exist, but the null endpoint policy with the same color exists, then the binding sid of the null endpoint policy is used for routing.

Step 4

exit

Example:
switch(config-route-map)# exit
switch(config)#

Exits route-map configuration mode.

Step 5

[no] router bgp autonomous-system-number

Example:
switch(config)# router bgp1
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 6

address-family ipv4 unicast

Example:
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#

Specifies the IPv4 address family for the VRF instance and enters the address family configuration mode.

Step 7

redistribute static route-map map-name out

Example:
switch(config-router-af)# redistribute static route-map ABC
switch(config-router-af)#

Redistributes static routes into BGP. The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Step 8

network ip-prefix [route-map map-name]

Example:
switch(config-router-af)# network 1.1.1.1/32 route-map ABC 
switch(config-router-af-network)#

Specifies a network as local to this autonomous system and adds it to the BGP routing table.

Configuring Extended Community Color for Default-Originate at the Egress Node

To configure extended community color for default-originate at the egress node when the default prefix is announced by the egress node, perform the following steps:

Procedure
  Command or Action Purpose

Step 1

configure terminal

Example:
switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

route-map map-name

Example:
switch(config)# route-map ABC 
switch(config-route-map)

Creates a route map or enters route-map configuration mode for an existing route map.

The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Step 3

set extcommunity color color-num [co-flag co-flag]

Example:
switch(config-route-map)# set extcommunity color 20 [co-flag 00]

Sets BGP extcommunity attribute for color extended community.

co-flag: Use the color-only flag to control whether traffic may be steered into an SR Policy based on color only, if no policy can be found for the exact color and endpoint. The default is 00.

Note

 

Select the co-flag 00 to specify the default Automated Steering function based on color and nexthop. When the co-flag is 00 or set to default, the binding sid of the policy with the requested color and endpoint is used for routing.

Select the co-flag 01 to steer traffic based on color only. When the co-flag is set to 01, and if the policy with requested color and endpoint exists, the binding sid of the policy is used for routing. If the policy does not exist, but the null endpoint policy with the same color exists, then the binding sid of the null endpoint policy is used for routing.

Step 4

exit

Example:
switch(config-route-map)# exit
switch(config)#

Exits route-map configuration mode.

Step 5

[no] router bgp autonomous-system-number

Example:
switch(config)# router bgp1
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 6

neighbor ip-address

Example:
switch(config-router)# neighbor 209.165.201.1
switch(config-router-neighbor)#

Adds an entry to the BGP or multiprotocol BGP neighbor table. The ip-address argument specifies the IP address of the neighbor in dotted decimal notation.

Step 7

address-family ipv4 unicast

Example:
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)#

Enters router address-family configuration mode for the IPv4 address family type.

Step 8

default-originate [ route-map map-name ]

Example:
switch(config-router-neighbor-af)# default-originate route-map ABC
switch(config-router-neighbor-af)#

Generates a default route to the BGP peer.

The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Configuring BGP for Ingress Peer (SRTE Headend)

To configure BGP for the ingress peer (SRTE headend), perform the following steps.

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

[no] feature bgp

Example:

switch(config)# feature bgp 
switch(config)

Enables BGP.

Use the no form of this command to disable this feature.

Step 3

[no] router bgp autonomous-system-number

Example:

switch(config)# router bgp 64496
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 4

address-family ipv4 unicast

Example:

switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#

Enters global address family configuration mode for the IPv4 address family.

Step 5

neighbor ip-address

Example:

switch(config-router-af)# neighbor 209.165.201.1
switch(config-router-af-neighbor)#

Configures the IPv4 address for a remote BGP peer. The ip-address format is x.x.x.x.

Step 6

remote-as as-number

Example:

switch(config-router-af-neighbor)# remote-as 64497

Configures the AS number for a remote BGP peer.

Step 7

update-source interface number

Example:

switch(config-router-af-neighbor)# update-source loopback 300

Specifies and updates the source of the BGP session.

Step 8

ebgp-multihop ttl-value

Example:

switch(config-router-af-neighbor)# ebgp-multihop 5

Configures the eBGP TTL value for eBGP multihop. The range is from 2 to 255. You must manually reset the BGP sessions after using this command.

Step 9

exit

Example:

switch(config-router-af-neighbor)# exit

Exits the neighbor configuration mode.

Step 10

address-family ipv4 unicast

Example:

switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#

Enters global address family configuration mode for the IPv4 address family.

Step 11

route-map map-name in

Example:

switch(config-router-af)# route-map color 401 in

Specifies the route map for the SRTE ingress peer.

The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Note

 

Only one extended community color can be applied to an NLRI, so any route-policy/route-map applied overrides the previous extended community color, if it exists.

Configuring BGP for Egress Peer (SRTE Endpoint)

To configure BGP for the egress peer (SRTE endpoint), perform the following steps.

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

[no] feature bgp

Example:

switch(config)# feature bgp 
switch(config)

Enables BGP.

Use the no form of this command to disable this feature.

Step 3

[no] router bgp autonomous-system-number

Example:

switch(config)# router bgp 64496
switch(config-router)#

Enables BGP and assigns the AS number to the local BGP speaker. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

Use the no option with this command to remove the BGP process and the associated configuration.

Step 4

neighbor ip-address

Example:

switch(config-router)# neighbor 209.165.201.1
switch(config-router-neighbor)#

Configures the IPv4 address for a remote BGP peer. The ip-address format is x.x.x.x.

Step 5

remote-as as-number

Example:

switch(config-router-neighbor)# remote-as 64497

Configures the AS number for a remote BGP peer.

Step 6

update-source interface-number

Example:

switch(config-router-neighbor)# update-source loopback 300

Specifies and updates the source of the BGP session.

Step 7

ebgp-multihop ttl-value

Example:

switch(config-router-neighbor)# ebgp-multihop 5

Configures the eBGP TTL value for eBGP multihop. The range is from 2 to 255. You must manually reset the BGP sessions after using this command.

Step 8

exit

Example:

switch(config-router-af-neighbor)# exit

Exits the neighbor configuration mode.

Step 9

address-family ipv4 unicast

Example:

switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#

Enters global address family configuration mode for the IPv4 address family.

Step 10

send-community

Example:

switch(config-router-af)# send-community
switch(config-router-af)#

Specifies that the BGP community attribute must be sent to a BGP neighbor.

Step 11

send-community extended

Example:

switch(config-router- af)#send-community extended
switch(config-router-af)#

Specifies that extended communities attribute should be sent to a BGP neighbor.

Step 12

route-map map-name out

Example:

switch(config-router-af)# route-map color 301 out
switch(config-router-af)#

Specifies the route map for the SRTE egress peer.

The map-name can be any case-sensitive, alphanumeric string up to 63 characters.

Note

 

Only one extended community color can be applied to an NLRI, so any route-policy/route-map applied overrides the previous extended community color, if it exists.

Configuring SRTE for Ingress Peer (SRTE Headend)

To configure the SRTE for ingress peer (SRTE headend), perform the following steps.

Procedure

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

[no] feature mpls segment-routing traffic-engineering

Example:

switch(config)# feature mpls segment-routing traffic-engineering
switch(config)

Enables MPLS SRTE.

Use the no form of this command to disable this feature.

Step 3

segment-routing

Example:

switch(config)#segment-routing
switch(config-sr)#

Enters the segment routing configuration mode.

Step 4

traffic-engineering

Example:

switch(config-sr)# traffic-engineering
switch(config-sr-te)#

Enters the traffic engineering mode.

Step 5

segment-list name path

Example:

switch(config-sr-te)# segment-list name path
switch(config-sr-te-exp-seg-list)#

Configures an explicit segment list.

Step 6

index 1 mpls label label-ID

Example:

switch(config-sr-te-exp-seg-list)# index 1 mpls label 16601
switch(config-sr-te-exp-seg-list)#

Create an MPLS label in the segment list.

Step 7

index 2 mpls label label-ID

Example:

switch(config-sr-te-exp-seg-list)# index 2 mpls label 16501
switch(config-sr-te-exp-seg-list)#

Creates MPLS label in the segment list.

Step 8

policy policy-name-bgp

Example:

switch(config-sr-te-exp-seg-list)# policy dci1-edge1-bgp
switch(config-sr-te-exp-seg-list)#

Specifies the SRTE policy name.

Step 9

color color-num endpoint endpoint ID

Example:

switch(config-sr-te)# color 13401 endpoint 1.0.3.1

Specifies the color and endpoint for the policy (SRTE Egress Node Loopback).

Step 10

candidate-paths

Example:

switch(config-sr-te-color)# candidate-paths

Specifies the candidate paths for the SRTE color policy.

Step 11

preference preference-number

Example:

switch(cfg-cndpath)# preference 100

Specifies the preference of the candidate path.

Step 12

explicit segment-list path

Example:

switch(cfg-pref)# explicit segment-list path

Specifies the explicit segment list.

Configuration Example for SRTE Over Default VRF

The following examples show the SRTE over default VRF configuration:

Configuration Example: Next-hop Unchanged

route-map ABC
  set ip next-hop unchanged

router bgp 1
  neighbor 1.2.3.4
    address-family ipv4 unicast
       route-map ABC out

Configuration Examples: Extended Community Color

This section includes the following configuration examples for extended community color:

Configuration Example: At the Egress Node

ip prefix-list pfx1 seq 5 permit 7.7.7.7/32
ip prefix-list pfx2 seq 5 permit 5.0.0.0/24
route-map ABC
  match ip address prefix-list pfx1 pfx2
    set extcommunity color 20

router bgp 1
  neighbor 1.2.3.4
    address-family ipv4 unicast
       route-map ABC out

Configuration Example: At the Ingress Node

ip prefix-list pfx1 seq 5 permit 7.7.7.7/32
ip prefix-list pfx2 seq 5 permit 5.0.0.0/24
route-map ABC
  match ip address prefix-list pfx1 pfx2
    set extcommunity color 20

router bgp 1
  neighbor 1.2.3.4
    address-family ipv4 unicast
       route-map ABC in

Configuration Example: For Network/Redistribute Command at the Egress Node

route-map ABC 
  set extcommunity color 20

router bgp 1
  address-family ipv4 unicast
    redistribute static route-map ABC
    network 1.1.1.1/32 route-map ABC

Configuration Example: For Default-Originate at the Egress Node

route-map ABC
  set extcommunity color 20

router bgp 1
    neighbor 1.2.3.4
       address-family ipv4 unicast
           default-originate route-map ABC

Configuration Example: BGP for Ingress Peer (SRTE Headend)

DCI-1(config)# show running-config bgp
feature bgp
router bgp 100
  address-family ipv4 unicast
  neighbor 1.0.3.1
    remote-as 101
    update-source loopback0
    ebgp-multihop 255
    address-family ipv4 unicast
       route-map color-3401 in

Configuration Example: BGP for Egress Peer (SRTE Endpoint)

This example shows the SRTE Explicit-Path Endpoint Substitution configuration:

Edge-1(config)# show running-config bgp
feature bgp
router bgp 101
neighbor 1.0.1.1
    remote-as 100
    update-source loopback0
    ebgp-multihop 255
    address-family ipv4 unicast
      send-community
      send-community extended
      route-map color-3401 out

Configuration Example: Ingress Peer for SRTE (SRTE Headend)

DCI-1# show running-config srte
feature mpls segment-routing traffic-engineering
segment-routing
  traffic-engineering
    segment-list name dci1-edge1
      index 1 mpls label 16601
      index 2 mpls label 16501
    policy dci1-edge1-bgp
      color 13401 endpoint 1.0.3.1
      candidate-paths
        preference 30
          explicit segment-list dci1-edge1

Verifying Configuration for SRTE Over Default VRF

To display the appropriate details about the SRTE over default VRF configuration, perform one of the following tasks:

Table 1. Verifying SRTE Over Default VRF Configuration

Command

Purpose

show running-config bgp

Displays information about the ingress peer or the SRTE headend.

show running-config bgp

Displays information about the egress peer or the SRTE endpoint.

show running-config srte

Displays information about the SRTE policy for ingress peer.

Additional References

Related Documents

Related Topic Document Title

BGP

Cisco Nexus 9000 Series Unicast Routing Configuration Guide