Configuring IEEE 802.3ad Link Bundling and Load Balancing

Last Updated: October 2, 2011

This document describes how the IEEE 802.3ad Link Bundling feature leverages the EtherChannel infrastructure within Cisco IOS software to manage the bundling of various links. Also described are network traffic load-balancing features to help minimize network disruption that results when a port is added or deleted from a link bundle.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for Configuring IEEE 802.3ad Link Bundling and Load Balancing

  • Knowledge of how EtherChannels and Link Aggregation Control Protocol (LACP) function in a network
  • Knowledge of load balancing to mitigate network traffic disruptions
  • Verification that both ends of the LACP link have the same baseline software version

Restrictions for Configuring IEEE 802.3ad Link Bundling and Load Balancing

  • The number of links supported per bundle is bound by the platform.
  • On the Cisco 7600 series router, the maximum number of links per bundle is eight.
  • On the Cisco 10000 series router, the maximum number of links per bundle is eight.
  • On the Cisco 10000 series router only, 1-gigabit-per-second (Gbps) ports are supported for Gigabit EtherChannels (GECs).
  • All links must operate at the same link speed and in full-duplex mode (LACP does not support half-duplex mode).
  • All links must be configured either as EtherChannel links or as LACP links.
  • Only physical interfaces can form aggregations. Aggregations of VLAN interfaces are not possible nor is an aggregation of aggregations.
  • If a router is connected to a switch, the bundle terminates on the switch.
  • An EtherChannel will not form if one of the LAN ports is a Switched Port Analyzer (SPAN) destination port.
  • All ports in an EtherChannel must use the same EtherChannel protocol.
  • LACP enhancements described in the LACP Enhancements Introduced in Cisco IOS Release 12.2(33)SB are available only on the Cisco 10000 series router.
  • The LACP Single Fault Direct Load Balance Swapping feature is limited to a single bundled port failure.
  • The LACP Single Fault Direct Load Balance Swapping feature cannot be used with the Port Aggregation Protocol (PagP).
  • LACP port priority cannot be configured with LACP single fault direct load balance swapping and vice versa.
  • The adaptive algorithm does not apply to service control engines (SCEs) when EtherChannel load distribution is used.
  • For the 802.3ad Link Aggregation with Weighted Load Balancing feature on the Cisco 7600 series router, the following maximum numbers of configurable service instances apply:
    • 8000 per port channel
    • 16,000 per line card
    • 64,000 per system
  • The Cisco 7600 series router supports a maximum of 256 port channels.

Information About Configuring IEEE 802.3ad Link Bundling and Load Balancing

Gigabit EtherChannel

Gigabit EtherChannel is high-performance Ethernet technology that provides Gbps transmission rates. A Gigabit EtherChannel bundles individual Gigabit Ethernet links into a single logical link that provides the aggregate bandwidth of up to eight physical links. All LAN ports in each EtherChannel must be the same speed and all must be configured either as Layer 2 or as Layer 3 LAN ports. Inbound broadcast and multicast packets on one link in an EtherChannel are blocked from returning on any other link in the EtherChannel.

When a link within an EtherChannel fails, traffic previously carried over the failed link switches to the remaining links within that EtherChannel. Also when a failure occurs, a trap is sent that identifies the device, the EtherChannel, and the failed link.

Port Channel and LACP-Enabled Interfaces

Each EtherChannel has a numbered port channel interface that, if not already created, is created automatically when the first physical interface is added to the channel group. The configuration of a port channel interface affects all LAN ports assigned to that port channel interface.

To change the parameters of all ports in an EtherChannel, change the configuration of the port channel interface: for example, if you want to configure Spanning Tree Protocol or configure a Layer 2 EtherChannel as a trunk. Any configuration or attribute changes you make to the port channel interface are propagated to all interfaces within the same channel group as the port channel; that is, configuration changes are propagated to the physical interfaces that are not part of the port channel but are part of the channel group.

The configuration of a LAN port affects only that LAN port.

IEEE 802.3ad Link Bundling

The IEEE 802.3ad Link Bundling feature provides a method for aggregating multiple Ethernet links into a single logical channel based on the IEEE 802.3ad standard. This feature helps improve the cost effectiveness of a device by increasing cumulative bandwidth without necessarily requiring hardware upgrades. In addition, IEEE 802.3ad Link Bundling provides a capability to dynamically provision, manage, and monitor various aggregated links and enables interoperability between various Cisco devices and devices of third-party vendors.

LACP supports the automatic creation of EtherChannels by exchanging LACP packets between LAN ports. LACP packets are exchanged only between ports in passive and active modes. The protocol "learns" the capabilities of LAN port groups dynamically and informs the other LAN ports. After LACP identifies correctly matched Ethernet links, it facilitates grouping the links into an EtherChannel. Then the EtherChannel is added to the spanning tree as a single bridge port.

Both the passive and active modes allow LACP to negotiate between LAN ports to determine if they can form an EtherChannel, based on criteria such as port speed and trunking state. (Layer 2 EtherChannels also use VLAN numbers.) LAN ports can form an EtherChannel when they are in compatible LACP modes, as in the following examples:

  • A LAN port in active mode can form an EtherChannel with another LAN port that is in active mode.
  • A LAN port in active mode can form an EtherChannel with another LAN port that is in passive mode.
  • A LAN port in passive mode cannot form an EtherChannel with another LAN port that is also in passive mode because neither port will initiate negotiation.

LACP uses the following parameters:

  • LACP system priority--You must configure an LACP system priority on each device running LACP. The system priority can be configured automatically or through the command-line interface (CLI). LACP uses the system priority with the device MAC address to form the system ID and also during negotiation with other systems.
  • LACP port priority--You must configure an LACP port priority on each port configured to use LACP. The port priority can be configured automatically or through the CLI. LACP uses the port priority to decide which ports should be put in standby mode when there is a hardware limitation that prevents all compatible ports from aggregating. LACP also uses the port priority with the port number to form the port identifier.
  • LACP administrative key--LACP automatically configures an administrative key value on each port configured to use LACP. The administrative key defines the ability of a port to aggregate with other ports. A port's ability to aggregate with other ports is determined by the following:
    • Port physical characteristics such as data rate, duplex capability, and point-to-point or shared medium
    • Configuration restrictions that you establish

LACP, on ports configured to use it, tries to configure the maximum number of compatible ports in an EtherChannel, up to the maximum allowed by the hardware. In Cisco IOS Release 12.2(31)SB2 on the Cisco 10000 series router, only four ports per bundle can be aggregated and the peer must be configured to support LACP. To use the hot standby feature in the event a channel port fails, both ends of the LACP bundle must support the lacp max-bundle command.

As a control protocol, LACP uses the Slow Protocol multicast address of 01-80-C2-00-00-02 to transmit LACP protocol data units (PDUs). Operations, administration, and maintenance (OAM) packets also use the Slow Protocol link type. Subsequently, a subtype field is defined per the IEEE 802.3ad standard [1] (Annex 43B, section 4) differentiating LACP PDUs from OAM PDUs.

Benefits of IEEE 802.3ad Link Bundling

  • Increased network capacity without changing physical connections or upgrading hardware
  • Cost savings resulting from use of existing hardware and software for additional functions
  • A standard solution that enables interoperability of network devices
  • Port redundancy without user intervention when an operational port fails

LACP Enhancements Introduced in Cisco IOS Release 12.2(33)SB

In Cisco IOS Release 12.2(33)SB on the Cisco 10000 series router, the following LACP enhancements are supported:

  • Eight member links per LACP bundle.
  • Stateful switchover (SSO), In Service Software Upgrade (ISSU), Cisco nonstop forwarding (NSF), and nonstop routing (NSR) on Gigabit EtherChannel bundles.
  • Point-to-Point Protocol over Ethernet over Ethernet (PPPoEoE), Point-to-Point Protocol over Ethernet over IEEE 802.1Q in 802.1Q (PPPoEoQinQ), and Point-to-Point Protocol over VLAN (PPPoVLAN) sessions are not forced to reestablish when a link switchover occurs. During the switchover, the port channel is maintained in the LINK_UP state, and both the active and standby links assume the same configured elements after the switchover.
  • Link failover time of 250 milliseconds or less and a maximum link failover time of 2 seconds; port channels remain in the LINK_UP state to eliminate reconvergence by the Spanning-Tree Protocol.
  • Shutting down a port channel when the number of active links falls below the minimum threshold. In the port channel interface, a configurable option is provided to bring down the port channel interface when the number of active links falls below the minimum threshold. For the port-channel state to be symmetric on both sides of the channel, the peer must also be running LACP and have the same lacp min-bundle command setting.
  • The IEEE LAG MIB.

EtherChannel Load Balancing

EtherChannel load balancing can use MAC addresses; IP addresses; Layer 4 port numbers; either source addresses, destination addresses, or both; or ports. The selected mode applies to all EtherChannels configured on the device. EtherChannel load balancing can also use Multiprotocol Label Switching (MPLS) Layer 2 information.

Traffic load across the links in an EtherChannel is balanced by reducing part of the binary pattern, formed from the addresses in the frame, to a numerical value that selects one of the links in the channel. When a port is added to an EtherChannel or an active port fails, the load balance bits are reset and reassigned for all ports within that EtherChannel and reprogrammed into the ASIC for each port. This reset causes packet loss during the time the reassignment and reprogramming is taking place. The greater the port bandwidth, the greater the packet loss.

LACP Single Fault Direct Load Balance Swapping

LACP supports hot standby ports, which are created when a platform's maximum number of ports that can be aggregated are bundled. On the Cisco 7600 router, eight is the maximum number of ports that can be bundled. A hot standby port is bundled in (swapped into) an aggregation when a previously active port fails.

The LACP Single Fault Direct Load Balance Swapping feature reassigns the load balance bits so that the swapped-in hot standby port is assigned the load balance bits of the failed port, and the load balance bits of the remaining ports in the aggregation remain unchanged. When the swapped-in port is bundled, the stored load share of the failed port is assigned to the swapped-in port. The remaining ports in the bundle are not affected.

The LACP Single Fault Direct Load Balance Swapping feature addresses a single bundled port failure. If a second failure occurs before the first failure recovers, the load share bits for member links are recomputed.

Following is an overview of the LACP single fault direct load balance swapping process:

  1. When a failed (unbundled) port is detected and is the first failure, its load share is stored.
  2. When a hot-standby port is identified and is bundled in, it takes the load share bits of the previously failed port.
  3. If the failed port comes back up, it replaces the hot-standby port in the bundle and the load share bits are transferred back to the original port.

The LACP Single Fault Direct Load Balance Swapping feature is enabled using the CLI command lacp direct-loadswap in port-channel configuration mode.

Load Distribution in an EtherChannel

Prior to Cisco IOS Release 12.(33)SRC, only a fixed load distribution algorithm was supported. With this fixed algorithm, the load share bits are assigned sequentially to each port in the bundle. Consequently, the load share bits for existing ports change when a member link joins or leaves the bundle. When these values are programmed in the ASIC, substantial traffic disruption and, in some cases, duplication of traffic can occur.

The Load Distribution in an EtherChannel feature enhances the load distribution mechanism with the adaptive load distribution algorithm. This algorithm uses a port reassignment scheme that enhances EtherChannel availability by limiting the load distribution reassignment to the port that is added or deleted. The new load on existing bundled ports does not conflict with the load programmed on those ports when a port is added or deleted.

You can enable this feature in either global configuration mode or interface configuration mode. The algorithm is applied at the next hash-distribution instance, which usually occurs when a link fails, is activated, added, or removed, or when shutdown or no shutdown is configured.

Because the selected algorithm is not applied until the next hash-distribution instance, the current and configured algorithms could be different. If the algorithms are different, a message is displayed alerting you to take appropriate action. For example:

Router(config-if)# port-channel port hash-distribution 
fixed
This command will take effect upon a member link UP/DOWN/ADDITION/DELETION event.
Please do a shut/no shut to take immediate effect

Also, the output of the show etherchannel command is enhanced to show the applied algorithm when the channel group number is specified. This output enhancement is not available, though, when the protocol is also specified because only protocol-specific information is included. Following is an example of output showing the applied algorithm:

Router# show etherchannel
 10 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
<snip>
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(RU)        LACP      Gi3/7(P)       Gi3/9(P)       
! The following line of output is added with support 
of the EtherChannel Load Distribution feature. !
Last applied Hash Distribution Algorithm: Fixed

802.3ad Link Aggregation with Weighted Load Balancing

Current mechanisms for load balancing Ethernet service instances over member links in a port channel do not account for the service instances' traffic loads, which can lead to unequal distribution of traffic over member links. The 802.3ad Link Aggregation with Weighted Load Balancing feature (802.3ad LAG with WLB) is an enhancement introduced in Cisco IOS Release 15.0(1)S that allows you to assign weights to service instances to efficiently distribute traffic flow across active member links in a port channel.

The LAG with WLB feature supports both LACP (active or passive mode) and manual (mode on) EtherChannel bundling. A weighted load balancing configuration does not affect the selection of active member links in the EtherChannel. As member links become active or inactive, a load-balancing algorithm adjusts the distribution of Ethernet service instances to use the currently active member links.

Load Balancing Coexistence

With the added support for weighted load balancing, three methods for load balancing Ethernet service instances over port-channel member links are available. The method used is selected in the following order (highest precedence first):

  1. Manual load balancing
  2. Weighted load balancing
  3. Platform default load balancing

If an Ethernet service instance is configured to be manually assigned to a member link and that member link is an active member of the port channel, that manual assignment is applied. If the Ethernet service instance is not manually load balanced and weighted load balancing is enabled with the port-channel load-balance weighted link command, the service instance is load balanced based on its configured or default weight. If neither the manual nor weighted method is applied to the service instance, the platform default load-balancing mechanism is used.

When both manual and weighted methods are load balancing Ethernet service instances over the same member link or links, the weights of the manually load-balanced service instances are included in determining weight distributions. As with every other Ethernet service instance, if a weight is not specifically configured on a manually load-balanced Ethernet service instance, the default weight is used.

The weighted load balancing method can be configured to use only a specific number of member links. This configuration option allows one or more member links to be dedicated to the manually load-balanced Ethernet service instances.

Service Group Support

An Ethernet service group is a logical collection of Ethernet service instances, subinterfaces, or both. Traffic for all Ethernet service instances that are members of a service group must egress the same member link. This restriction is necessary for quality of service (QoS) configured for the service group to perform accurate computations but could lead to unequal weight distributions across the available member links. For example, consider 100 Ethernet service instances in a service group, each configured with a weight of 1, and one other Ethernet service instance configured with a weight of 2 that is not in a service group. In this case, one member link will have a total weight of 100 and another member link will have a total weight of 2. This example is not a typical scenario but illustrates the traffic imbalance that could result.

How to Configure IEEE 802.3ad Link Bundling and Load Balancing

Enabling LACP

Perform this task to enable LACP.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface port-channel channel-number

4.    channel-group channel-group-number mode {active | passive}

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface port-channel channel-number


Example:

Router(config)# interface port-channel 10

 

Identifies the interface port channel and enters interface configuration mode.

 
Step 4
channel-group channel-group-number mode {active | passive}


Example:

Router(config-if)# channel-group 25 mode active

 

Configures the interface in a channel group and sets it as active.

  • In active mode, the port will initiate negotiations with other ports by sending LACP packets.
 
Step 5
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 

Configuring a Port Channel

You must manually create a port channel logical interface. Perform this task to configure a port channel.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface port-channel channel-number

4.    ip address ip-address mask

5.    end

6.    show running-config interface port-channel group-number

7.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface port-channel channel-number


Example:

Router(config)# interface port-channel 10

 

Identifies the interface port channel and enters interface configuration mode.

 
Step 4
ip address ip-address mask


Example:

Router(config-if)# ip address 172.31.52.10 255.255.255.0

 

Assigns an IP address and subnet mask to the EtherChannel.

 
Step 5
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 
Step 6
show running-config interface port-channel group-number


Example:

Router# show running-config interface port-channel 10

 

Displays the port channel configuration.

 
Step 7
end


Example:

Router# end

 

Ends the current configuration session.

 

Example

This example shows how to verify the configuration:

Router# show running-config interface port-channel10
 
Building configuration...
Current configuration:
!
interface Port-channel10
 ip address 172.31.52.10 255.255.255.0
 no ip directed-broadcast
end

Associating a Channel Group with a Port Channel

Perform this task to associate a channel group with a port channel.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface port-channel channel -number

4.    interface type number

5.    channel-group channel-group-number mode {active | passive}

6.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface port-channel channel -number


Example:

Router(config)# interface port-channel 5

 

Creates a port channel.

 
Step 4
interface type number


Example:

Router(config)# interface gigabitethernet 7/0/0

 

Configures an interface and enters interface configuration mode.

 
Step 5
channel-group channel-group-number mode {active | passive}


Example:

Router(config-if)# channel-group 5 mode active

 

Includes the interface as part of the port channel bundle.

 
Step 6
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 

Setting LACP System Priority

Perform this task to set the LACP system priority. The system ID is the combination of the LACP system priority and the MAC address of a device.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    lacp system-priority priority

4.    end

5.    show lacp sys-id

6.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
lacp system-priority priority


Example:

Router(config)# lacp system-priority 200

 

Sets the system priority.

 
Step 4
end


Example:

Router(config)# end

 

Returns to privileged EXEC mode.

 
Step 5
show lacp sys-id


Example:

Router# show lacp

 

Displays the system ID, which is a combination of the system priority and the MAC address of the device.

 
Step 6
end


Example:

Router# end

 

Ends the current configuration session.

 

Example

This example shows how to verify the LACP configuration:

Router# show lacp
20369,01b2.05ab.ccd0

Adding and Removing Interfaces from a Bundle

Perform this task to add and remove an interface from a link bundle.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    channel-group channel-group-number mode {active | passive}

5.    no channel-group

6.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface gigabitethernet 5/0/0

 

Configures an interface and enters interface configuration mode.

 
Step 4
channel-group channel-group-number mode {active | passive}


Example:

Router(config-if)# channel-group 5 mode active

 

Adds an interface to a channel group.

 
Step 5
no channel-group


Example:

Router(config-if)# no channel-group

 

Removes the interface from the channel group.

 
Step 6
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 

Setting a Minimum Number of Active Links

Perform this task to set the minimum number of active links allowed in an LACP bundle.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    lacp min-bundle min-bundle

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface port-channel 1

 

Creates a port-channel virtual interface and enters interface configuration mode.

 
Step 4
lacp min-bundle min-bundle


Example:

Router(config-if)# lacp min-bundle 5

 

Sets the minimum threshold of active links.

 
Step 5
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 

Monitoring LACP Status

Perform this task to monitor LACP activity in the network.

SUMMARY STEPS

1.    enable

2.    show lacp {number | counters | internal | neighbor | sys-id}

3.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
show lacp {number | counters | internal | neighbor | sys-id}


Example:

Router# show lacp internal

 

Displays internal device information.

 
Step 3
end


Example:

Router# end

 

Ends the current configuration session.

 

Troubleshooting Tips

Use the debug lacp command to display LACP configuration and activity details.

The following sample output from a debug lacp all command shows that a remote device is removing a link and also adding a link:

Router# debug lacp all
Link Aggregation Control Protocol all debugging is on
Router#
*Aug 20 17:21:51.685: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi5/0/0
*Aug 20 17:21:51.685: LACP : packet size: 124
*Aug 20 17:21:51.685: LACP: pdu: subtype: 1, version: 1
*Aug 20 17:21:51.685: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x14, p-state:0x3C,
s-pri:0xFFFF, s-mac:0011.2026.7300
*Aug 20 17:21:51.685: LACP: Part: tlv:2, tlv-len:20, key:0x5, p-pri:0x8000, p:0x42, p-state:0x3D,
s-pri:0x8000, s-mac:0014.a93d.4a00
*Aug 20 17:21:51.685: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000 
*Aug 20 17:21:51.685: LACP: term-tlv:0 termr-tlv-len:0
*Aug 20 17:21:51.685: LACP: Gi5/0/0 LACP packet received, processing 
*Aug 20 17:21:51.685:     lacp_rx Gi5: during state CURRENT, got event 5(recv_lacpdu)
*Aug 20 17:21:59.869: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:21:59.869: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:21:59.869:     lacp_ptx Gi5: during state SLOW_PERIODIC, got event 3(pt_expired)
*Aug 20 17:21:59.869: @@@ lacp_ptx Gi5: SLOW_PERIODIC -> PERIODIC_TX
*Aug 20 17:21:59.869: LACP: Gi5/0/0 lacp_action_ptx_slow_periodic_exit entered
*Aug 20 17:21:59.869: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:00.869: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:22:00.869: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:22:19.089: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi5/0/0
*Aug 20 17:22:19.089: LACP : packet size: 124
*Aug 20 17:22:19.089: LACP: pdu: subtype: 1, version: 1
*Aug 20 17:22:19.089: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x14, p-state:0x4,
s-pri:0xFFFF, s-mac:0011.2026.7300
*Aug 20 17:22:19.089: LACP: Part: tlv:2, tlv-len:20, key:0x5, p-pri:0x8000, p:0x42, p-state:0x34,
s-pri:0x8000, s-mac:0014.a93d.4a00
*Aug 20 17:22:19.089: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000 
*Aug 20 17:22:19.089: LACP: term-tlv:0 termr-tlv-len:0
*Aug 20 17:22:19.089: LACP: Gi5/0/0 LACP packet received, processing 
*Aug 20 17:22:19.089:     lacp_rx Gi5: during state CURRENT, got event 5(recv_lacpdu)
*Aug 20 17:22:19.989: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:22:19.989: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:22:19.989: LACP: timer lacp_t(Gi5/0/0) started with interval 1000.
*Aug 20 17:22:19.989: LACP: lacp_send_lacpdu: (Gi5/0/0) About to send the 110 LACPDU
*Aug 20 17:22:19.989: LACP :lacp_bugpak: Send LACP-PDU packet via Gi5/0/0
*Aug 20 17:22:19.989: LACP : packet size: 124
*Aug 20 17:22:20.957: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:22:20.957: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:22:21.205: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to down
*Aug 20 17:22:21.205: LACP: lacp_hw_off: Gi5/0/0 is going down
*Aug 20 17:22:21.205: LACP: if_down: Gi5/0/0
*Aug 20 17:22:21.205:     lacp_ptx Gi5: during state SLOW_PERIODIC, got event 0(no_periodic)
*Aug 20 17:22:22.089: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to down
*Aug 20 17:22:22.153: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:22:23.413: LACP: Gi5/0/0 oper-key: 0x0
*Aug 20 17:22:23.413: LACP: lacp_hw_on: Gi5/0/0 is coming up
*Aug 20 17:22:23.413:     lacp_ptx Gi5: during state NO_PERIODIC, got event 0(no_periodic)
*Aug 20 17:22:23.413: @@@ lacp_ptx Gi5: NO_PERIODIC -> NO_PERIODIC
*Aug 20 17:22:23.413: LACP: Gi5/0/0 lacp_action_ptx_no_periodic entered
*Aug 20 17:22:23.413: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:24.153: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to up
*Aug 20 17:22:24.153: LACP: lacp_hw_on: Gi5/0/0 is coming up
*Aug 20 17:22:24.153:     lacp_ptx Gi5: during state FAST_PERIODIC, got event 0(no_periodic)
*Aug 20 17:22:24.153: @@@ lacp_ptx Gi5: FAST_PERIODIC -> NO_PERIODIC
*Aug 20 17:22:24.153: LACP: Gi5/0/0 lacp_action_ptx_fast_periodic_exit entered
*Aug 20 17:22:24.153: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:24.153: LACP: 
*Aug 20 17:22:25.021: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:25.021: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:22:25.021:     lacp_ptx Gi5: during state FAST_PERIODIC, got event 3(pt_expired)
*Aug 20 17:22:25.021: @@@ lacp_ptx Gi5: FAST_PERIODIC -> PERIODIC_TX
*Aug 20 17:22:25.021: LACP: Gi5/0/0 lacp_action_ptx_fast_periodic_exit entered
*Aug 20 17:22:25.021: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:25.917: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:25.917: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:22:25.917:     lacp_ptx Gi5: during state FAST_PERIODIC, got event 3(pt_expired)
*Aug 20 17:22:25.917: @@@ lacp_ptx Gi5: FAST_PERIODIC -> PERIODIC_TX
*Aug 20 17:22:25.917: LACP: Gi5/0/0 lacp_action_ptx_fast_periodic_exit entered
*Aug 20 17:22:25.917: LACP: lacp_p(Gi5/0/0) timer stopped

The following sample output shows a remote device adding a link:

Router#
*Aug 20 17:23:54.005: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:23:54.005: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:23:55.789: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:23:56.497: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:24:19.085: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:24:19.085: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:24:19.085:     lacp_ptx Gi5: during state SLOW_PERIODIC, got event 3(pt_expired)
*Aug 20 17:24:19.085: @@@ lacp_ptx Gi5: SLOW_PERIODIC -> PERIODIC_TX
*Aug 20 17:24:19.085: LACP: Gi5/0/0 lacp_action_ptx_slow_periodic_exit entered
*Aug 20 17:24:19.085: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:24:19.957: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:19.957: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:21.073: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi5/0/0
*Aug 20 17:24:21.073: LACP : packet size: 124
*Aug 20 17:24:21.073: LACP: pdu: subtype: 1, version: 1
*Aug 20 17:24:21.073: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x14, p-state:0xC,
s-pri:0xFFFF, s-mac:0011.2026.7300
*Aug 20 17:24:21.073: LACP: Part: tlv:2, tlv-len:20, key:0x0, p-pri:0x8000, p:0x42, p-state:0x75,
s-pri:0x8000, s-mac:0014.a93d.4a00
*Aug 20 17:24:21.073: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000 
*Aug 20 17:24:21.073: LACP: term-tlv:0 termr-tlv-len:0
*Aug 20 17:24:21.073: LACP: Gi5/0/0 LACP packet received, processing 
*Aug 20 17:24:21.073:     lacp_rx Gi5: during state DEFAULTED, got event 5(recv_lacpdu)
*Aug 20 17:24:21.929: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:21.929: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:21.929: LACP: timer lacp_t(Gi5/0/0) started with interval 1000.
*Aug 20 17:24:21.929: LACP: lacp_send_lacpdu: (Gi5/0/0) About to send the 110 LACPDU
*Aug 20 17:24:21.929: LACP :lacp_bugpak: Send LACP-PDU packet via Gi5/0/0
*Aug 20 17:24:21.929: LACP : packet size: 124
*Aug 20 17:24:22.805: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:22.805: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:23.025: LACP: lacp_w(Gi5/0/0) timer stopped
*Aug 20 17:24:23.025: LACP: lacp_w(Gi5/0/0) expired
*Aug 20 17:24:23.025:     lacp_mux Gi5: during state WAITING, got event 4(ready)
*Aug 20 17:24:23.025: @@@ lacp_mux Gi5: WAITING -> ATTACHED
*Aug 20 17:24:23.921: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:23.921: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:26.025: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to up

Enabling LACP Single Fault Load Balance Swapping

Perform this task to enable LACP single fault load balance swapping in EtherChannels.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    lacp direct-loadswap

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface port-channel 1

 

Creates a port-channel virtual interface and enters interface configuration mode.

 
Step 4
lacp direct-loadswap


Example:

Router(config-if)# lacp direct-loadswap

 

Enables LACP single fault direct load balancing.

 
Step 5
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 

Selecting an EtherChannel Load Distribution Algorithm

You can select the EtherChannel load distribution algorithm from either global configuration mode or interface configuration mode. Perform this task to select either the adaptive or fixed algorithm from global configuration mode. To select the algorithm from interface configuration mode, issue the interface command before the port-channel hash-distribution command.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    port-channel hash-distribution {adaptive | fixed}

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface port-channel1

 

(Optional) Creates a port-channel virtual interface and enters interface configuration mode.

 
Step 4
port-channel hash-distribution {adaptive | fixed}


Example:

Router(config)# port-channel hash-distribution adaptive

 

Selects the type of algorithm.

Note    If an algorithm is not specified in interface configuration mode, the global configuration is applied. Otherwise, the algorithm specified in interface configuration mode overrides the algorithm specified in global configuration mode.
 
Step 5
end


Example:

Router(config)# end

 

Returns to privileged EXEC mode.

 

Enabling 802.3ad Weighted Load Balancing

Perform this task to enable 802.3ad weighted load balancing.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    port-channel load-balance {link link-id | weighted {default weight weight | link {all | link-id} | rebalance{disable | weight}}}

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface portchannel10

 

Configures a port-channel interface and enters interface configuration mode.

 
Step 4
port-channel load-balance {link link-id | weighted {default weight weight | link {all | link-id} | rebalance{disable | weight}}}


Example:

Router(config-if)# port-channel load-balance weighted link all

 

Configures weighted load balancing on port-channel member links.

 
Step 5
end


Example:

Router(config-if)# end

 

Returns to privileged EXEC mode.

 

Configuration Examples for Configuring IEEE 802.3ad Link Bundling and Load Balancing

Example Associating a Channel Group with a Port Channel

This example shows how to configure channel group number 5 and include it in the channel group:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface port-channel5
Router(config-if)#
*Aug 20 17:06:14.417: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to down
*Aug 20 17:06:25.413: %LINK-3-UPDOWN: Interface Port-channel5, changed state to down
Router(config-if)#
Router(config-if)# interface gigabitethernet 7/0/0
Router(config-if)# channel-group 5 mode active
Router(config-if)#
*Aug 20 17:07:43.713: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to down
*Aug 20 17:07:44.713: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to down
*Aug 20 17:07:45.093: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 7/0/0 Physical Port Link Down 
*Aug 20 17:07:45.093: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 7/0/0 Physical Port Link Down 
*Aug 20 17:07:47.093: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to up
*Aug 20 17:07:48.093: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to up
*Aug 20 17:07:48.957: GigabitEthernet7/0/0 added as member-1 to port-channel5
 
*Aug 20 17:07:51.957: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to up
Router(config-if)# end
Router#
*Aug 20 17:08:00.933: %SYS-5-CONFIG_I: Configured from console by console
Router# show lacp internal
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi7/0/0   SA      bndl      32768         0x5       0x5     0x43        0x3D  
Router# show interface port-channel5
Port-channel5 is up, line protocol is up 
  Hardware is GEChannel, address is 0014.a93d.4aa8 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this channel: 1 
        Member 0 : GigabitEthernet7/0/0 , Full-duplex, 1000Mb/s
  Last input 00:00:05, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Interface Port-channel5 queueing strategy: PXF First-In-First-Out
  Output queue 0/8192, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     9 packets output, 924 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Example Adding and Removing Interfaces from a Bundle

The following example shows how to add an interface to a bundle:

Router# show lacp internal
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi7/0/0   SA      bndl      32768         0x5       0x5     0x43        0x3D  
Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface gigabitethernet 5/0/0
Router(config-if)# channel-group 5 mode active
Router(config-if)#
*Aug 20 17:10:19.057: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to down
*Aug 20 17:10:19.469: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:10:19.473: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:10:21.473: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to up
*Aug 20 17:10:21.473: GigabitEthernet7/0/0 taken out of port-channel5
*Aug 20 17:10:23.413: GigabitEthernet5/0/0 added as member-1 to port-channel5
 
*Aug 20 17:10:23.473: %LINK-3-UPDOWN: Interface Port-channel5, changed state to up
Router(config-if)# end
Router#
*Aug 20 17:10:27.653: %SYS-5-CONFIG_I: Configured from console by console
*Aug 20 17:11:40.717: GigabitEthernet7/0/0 added as member-2 to port-channel5
 
Router# show lacp internal
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi7/0/0   SA      bndl      32768         0x5       0x5     0x43        0x3D  
Gi5/0/0   SA      bndl      32768         0x5       0x5     0x42        0x3D  
Router# show interface port-channel5
Port-channel5 is up, line protocol is up 
  Hardware is GEChannel, address is 0014.a93d.4aa8 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this channel: 2 
        Member 0 : GigabitEthernet5/0/0 , Full-duplex, 1000Mb/s  <---- added to port channel bundle
        Member 1 : GigabitEthernet7/0/0 , Full-duplex, 1000Mb/s  
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
  Interface Port-channel5 queueing strategy: PXF First-In-First-Out
  Output queue 0/8192, 0 drops; input queue 0/150, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     104 packets output, 8544 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

The following example shows how to remove an interface from a bundle:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface gigabitethernet 7/0/0
Router(config-if)# no channel-group
Router(config-if)#
*Aug 20 17:15:49.433: GigabitEthernet7/0/0 taken out of port-channel5
*Aug 20 17:15:49.557: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:15:50.161: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down 
*Aug 20 17:15:51.433: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to down
*Aug 20 17:15:52.433: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to down
Router(config-if)# end
Router#
*Aug 20 17:15:58.209: %SYS-5-CONFIG_I: Configured from console by console
Router#
*Aug 20 17:15:59.257: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 7/0/0 Physical Port Link Down 
*Aug 20 17:15:59.257: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 7/0/0 Physical Port Link Down   
Router#
*Aug 20 17:16:01.257: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to up
*Aug 20 17:16:02.257: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to up
Router# show lacp internal
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi5/0/0   SA      bndl      32768         0x5       0x5     0x42        0x3D  

Example Monitoring LACP Status

The following example shows LACP activity that you can monitor by using the show lacp command.

Router# show lacp internal
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi5/0/0   SA      bndl      32768         0x5       0x5     0x42        0x3D  
Router# show lacp 5 counters
             LACPDUs         Marker      Marker Response    LACPDUs
Port       Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err
---------------------------------------------------------------------
Channel group: 5
Gi5/0/0     21     18       0      0        0      0         0     
Router# show lacp 5 internal
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi5/0/0   SA      bndl      32768         0x5       0x5     0x42        0x3D  
Router# show lacp 5 neighbor
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
Channel group 5 neighbors
Partner's information:
          Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Gi5/0/0   SP      32768     0011.2026.7300  11s    0x1     0x14     0x3C  
Router# show lacp counters
             LACPDUs         Marker      Marker Response    LACPDUs
Port       Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err
---------------------------------------------------------------------
Channel group: 5
Gi5/0/0     23     20       0      0        0      0         0     
Router# s
how lacp sys-id
32768,0014.a93d.4a00

Example Configuring Weighted Service Instances

In this example traffic on service instances 100, 101, and 200 is load balanced over Gigabit Ethernet interfaces 5/0/2 and 5/0/3. Based on the configured weights, traffic from service instances 100 and 101 egress one member link, and traffic from service instance 200 egress the other member link.

Router# configure terminal
Router(config)# interface GigabitEthernet5/0/2
Router(config-if)# channel-group 10 mode on
Router(config-if)# exit
Router(config)# interface GigabitEthernet5/0/3
Router(config-if)# channel-group 10 mode on
Router(config-if)# exit
Router(config)# interface Port-channel10
Router(config-if)# port-channel load-balance weighted link all
Router(config-if)# service instance 100 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# weight 2
Router(config-if-srv)# exit
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# weight 2
Router(config-if-srv)# exit
Router(config-if)# service instance 200 ethernet
Router(config-if-srv)# encapsulation dot1q 200
Router(config-if-srv)# weight 10
Router(config-if-srv)# end

Example Configuring Weighted and Manual Load Balancing

In this example a combination of manual load balancing and weighted load balancing is configured. Service instances 100 and 101 are manually assigned to link 1 on Gigabit Ethernet interface 5/0/2. Both link 2 on Gigabit Ethernet interface 5/0/3 and link 3 on Gigabit Ethernet interface 5/0/4 are configured for weighted load balancing. Because service instances 200 and 201 are not configured with explicit weights, they inherit the configured default of 2. Service instances 200, 201, and 300 are distributed across Gigabit Ethernet interfaces 5/0/3 and 5/0/4.

Router(config)# interface GigabitEthernet5/0/2
Router(config-if)# channel-group 10 mode on link 1
Router(config-if)# exit
Router(config)# interface GigabitEthernet5/0/3
Router(config-if)# channel-group 10 mode on link 2
Router(config-if)# exit
Router(config)# interface GigabitEthernet5/0/4
Router(config-if)# channel-group 10 mode on link 3
Router(config-if)# exit
!
Router(config)# interface Port-channel10
Router(config-if)# port-channel load-balance link 1
Router(config-if)# service-instance 100-150
Router(config-if)# port-channel load-balance weighted link 2,3
Router(config-if)# port-channel load-balance weighted default weight 2
Router(config-if)# port-channel load-balance weighted rebalance disable
Router(config-if)# service instance 100 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# exit
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# exit
Router(config-if)# service instance 200 ethernet
Router(config-if-srv)# encapsulation dot1q 200
Router(config-if-srv)# exit
Router(config-if)# service instance 201 ethernet
Router(config-if-srv)# encapsulation dot1q 201
Router(config-if-srv)# exit
Router(config-if)# service instance 300 ethernet
Router(config-if-srv)# encapsulation dot1q 300
Router(config-if-srv)# weight 5
Router(config-if-srv)# end

Additional References

Related Documents

Related Topic

Document Title

Configuring EtherChannels

"Configuring Layer 3 and Layer 2 EtherChannel" chapter of the Catalyst 6500 Release 12.2SXF Software Configuration Guide

Configuring Carrier Ethernet

Cisco IOS Carrier Ethernet Configuration Guide

Cisco IOS LACP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

Cisco IOS Carrier Ethernet Command Reference

Cisco IOS commands: master list of commands with complete command syntax, command mode, command history, defaults, usage guidelines, and examples

Cisco IOS Master Commands List, All Releases

Standards

Standard

Title

IEEE 802.3ad-2000

IEEE 802.3ad-2000 Link Aggregation

MIBs

MIB

MIBs Link

802.3ad MIB

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

--

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for Configuring IEEE 802.3ad Link Bundling and Load Balancing

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for Configuring IEEE 802.3ad Link Bundling and Load Balancing

Feature Name

Releases

Feature Information

802.3ad Link Aggregation with Weighted Load Balancing

15.0(1)S

The 802.3ad LAG with WLB feature is an enhancement to current load-balancing mechanisms that allows you to assign weights to service instances to efficiently distribute traffic flow across active member links in a port channel.

The following commands were introduced or modified: debug port-channel load-balance, port-channel load-balance (interface), port-channel load-balance weighted rebalance, show ethernet service instance, weight(srvs instance).

EtherChannel Load Distribution

12.2(33)SRC

The EtherChannel Load Distribution feature uses a port reassignment scheme that enhances EtherChannel availability by limiting the load distribution reassignment to the port that is added or deleted. The new load on existing bundled ports does not conflict with the load programmed on those ports when a port is added or deleted.

The following commands were introduced or modified: port-channel port hash-distribution, show etherchannel.

EtherChannel Min-Links

12.2(33)SB 15.0(1)S

The EtherChannel Min-Links feature allows a port channel to be shut down when the number of active links falls below the minimum threshold. Using the lacp min-bundle command, you can configure the minimum threshold.

The following command was introduced or modified: lacp min-bundle.

IEEE 802.3ad Faster Link Switchover Time

12.2(33)SB

The IEEE 802.3ad Faster Link Switchover Time feature provides a link failover time of 250 milliseconds or less and a maximum link failover time of 2 seconds. Also, port channels remain in the LINK_UP state to eliminate reconvergence by the Spanning-Tree Protocol.

The following command was introduced or modified: lacp fast-switchover.

IEEE 802.3ad Link Aggregation (LACP)

12.2(31)SB212.2(33)SRB 12.2(33)SRC 15.0(1)S

The IEEE 802.3ad Link Bundling feature provides a method for aggregating multiple Ethernet links into a single logical channel based on the IEEE 802.3ad standard. In addition, this feature provides a capability to dynamically provision, manage, and monitor various aggregated links and enables interoperability between various Cisco devices and devices of third-party vendors.

In 12.2(31)SB2, this feature was implemented on the Cisco 10000 series router.

In 12.2(33)SRB, this feature was implemented on the Cisco 7600 router.

In 12.2(33)SRC, the lacp rate command was added.

The following commands were introduced or modified: channel-group (interface), debug lacp, lacp max-bundle, lacp port-priority, lacp rate, lacp system-priority, show lacp.

IEEE 802.3ad Maximum Number of Links Increased

12.2(33)SB

The IEEE 802.3ad Maximum Number of Links Increased feature supports eight member links per LACP bundle, an increase from four in previous software releases.

This feature uses no new or modified commands.

LACP Single Fault Direct Load Balance Swapping

12.2(33)SRC 15.0(1)S

The LACP Single Fault Direct Load Balance Swapping feature reassigns the load balance bits so that the swapped-in hot standby port is assigned the load balance bits of the failed port, and the load balance bits of the remaining ports in the aggregation remain unchanged. When the swapped-in port is bundled, the load share is recalculated and the stored load share of the failed port is assigned to the swapped-in port. The remaining ports in the bundle are not affected.

The following commands were introduced or modified: lacp direct-loadswap, show etherchannel.

PPPoX Hitless Failover

12.2(33)SB

The PPPoX Hitless Failover feature allows a port channel to remain in the LINK_UP state during a link switchover. In PPPoEoE, PPPoEoQinQ, and PPPoVLAN sessions, both the active and standby links assume the same configured elements after a switchover; the sessions are not forced to reestablish.

This feature uses no new or modified commands.

SSO - LACP

12.2(33)SB

The SSO - LACP feature supports stateful switchover (SSO), In Service Software Upgrade (ISSU), Cisco nonstop forwarding (NSF), and nonstop routing (NSR) on Gigabit EtherChannel bundles.

This feature uses no new or modified commands.

Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/go/trademarks. Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2011 Cisco Systems, Inc. All rights reserved.