この製品のマニュアルセットは、偏向のない言語を使用するように配慮されています。このマニュアルセットでの偏向のない言語とは、年齢、障害、性別、人種的アイデンティティ、民族的アイデンティティ、性的指向、社会経済的地位、およびインターセクショナリティに基づく差別を意味しない言語として定義されています。製品ソフトウェアのユーザーインターフェイスにハードコードされている言語、RFP のドキュメントに基づいて使用されている言語、または参照されているサードパーティ製品で使用されている言語によりドキュメントに例外が存在する場合があります。シスコのインクルーシブランゲージに対する取り組みの詳細は、こちらをご覧ください。
このドキュメントは、米国シスコ発行ドキュメントの参考和訳です。リンク情報につきましては、日本語版掲載時点で、英語版にアップデートがあり、リンク先のページが移動/変更されている場合がありますことをご了承ください。あくまでも参考和訳となりますので、正式な内容については米国サイトのドキュメントを参照ください。
目次
ここでは、ルータの基本設定について説明します。次の項で構成されています。
ルータを初めて起動すると、一部の基本設定がすでに完了していることがわかります。 初期設定を表示するには、次の例に示すように show running-config コマンドを使用します。
Router# show running-config Building configuration... Current configuration : 977 bytes ! version 15.3 service timestamps debug datetime msec service timestamps log datetime msec no platform punt-keepalive disable-kernel-core ! hostname Router ! boot-start-marker boot-end-marker ! ! vrf definition Mgmt-intf ! address-family ipv4 exit-address-family ! address-family ipv6 exit-address-family ! ! no aaa new-model ! ipv6 multicast rpf use-bgp ! ! multilink bundle-name authenticated ! ! redundancy mode none ! interface GigabitEthernet0/0/0 no ip address negotiation auto ! interface GigabitEthernet0/0/1 no ip address negotiation auto ! interface GigabitEthernet0/0/2 no ip address negotiation auto ! interface GigabitEthernet0/0/3 no ip address negotiation auto ! interface GigabitEthernet0 vrf forwarding Mgmt-intf no ip address negotiation auto ! ip forward-protocol nd ! no ip http server no ip http secure-server ! ! control-plane ! ! line con 0 stopbits 1 line vty 0 4 login ! ! end
ルータのグローバル パラメータを設定するには、次の手順を実行します。
1. configure terminal
2. hostname name
3. enable secret password
4. no ip domain-lookup
コマンドまたはアクション | 目的 | |
---|---|---|
ステップ 1 | configure terminal 例: Router> enable Router# configure terminal Router(config)# |
グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。 次のコマンドを使用して、ルータとリモート ターミナルを接続します。 telnet router-name or address Login: login-id Password: ********* Router> enable |
ステップ 2 | hostname name 例: Router(config)# hostname Router |
ルータ名を指定します。 |
ステップ 3 | enable secret password 例: Router(config)# enable secret cr1ny5ho |
ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。 |
ステップ 4 | no ip domain-lookup 例: Router(config)# no ip domain-lookup |
ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。 グローバル パラメータ コマンドの詳細については、『Cisco IOS Release Configuration Guide』マニュアル セットを参照してください。 |
オンボードのギガビット イーサネットインターフェイスを手動で定義するには、グローバル コンフィギュレーション モードから開始して、次の手順を実行します。
1. interface gigabitethernet slot/bay/port
2. ip address ip-address mask
3. ipv6 address ipv6-address/prefix
4. no shutdown
5. exit
ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。
ループバック インターフェイスを設定するには、次の手順を実行します。
1. interface type number
2. (オプション 1)ip address ip-address mask
3. (オプション 2) ipv6 address ipv6-address/prefix
4. exit
このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。 この設定例は、スタティック IP アドレスとして機能する IP アドレス 192.0.2.0/24 のギガビット イーサネット インターフェイス上に設定されるループバック インターフェイスを示しています。 ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。
!
interface loopback 0
ip address 192.0.2.0 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
show interface loopback コマンドを入力します。 次の例のような出力が表示されます。
Router# show interface loopback 0 Loopback0 is up, line protocol is up Hardware is Loopback Internet address is 200.200.100.1/24 MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, reliability 255/255, txload 1/255, rxload 1/255 Encapsulation LOOPBACK, loopback not set Last input never, output never, output hang never Last clearing of "show interface" counters never Queueing strategy: fifo Output queue 0/0, 0 drops; input queue 0/75, 0 drops 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 0 packets input, 0 bytes, 0 no buffer Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 0 packets output, 0 bytes, 0 underruns 0 output errors, 0 collisions, 0 interface resets 0 output buffer failures, 0 output buffers swapped out
または、次の例に示すように、ping コマンドを使用してループバック インターフェイスを確認します。
Router# ping 192.0.2.0 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.0.2.0, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
サービス モジュールの設定の詳細については、『Cisco SM-1T3/E3 Service Module Configuration Guide』の「Service Module Management」の項の「Service Modules」を参照してください。
ルータでは、Cisco Discovery Protocol(CDP)がデフォルトでイネーブルに設定されています。
(注) |
Cisco アグリゲーション サービス ルータまたは Cisco CSR 1000v では、CDP はデフォルトでイネーブルに設定されていません。 |
CDP の使用法の詳細については、『Cisco Discovery Protocol Configuration Guide, Cisco IOS XE Release 3S』を参照してください。
ルータへのアクセスを制御するパラメータを設定するには、次の手順を実行します。
1. line [aux | console | tty | vty] line-number
2. password password
3. login
4. exec-timeout minutes [seconds]
5. exit
6. line [aux | console | tty | vty] line-number
7. password password
8. login
9. end
次の設定は、コマンドライン アクセス コマンドを示します。
default と示されているコマンドは、入力する必要はありません。 これらのコマンドは、show running-config コマンドの使用時に、生成されたコンフィギュレーション ファイルに自動的に示されます。
! line console 0 exec-timeout 10 0 password 4youreyesonly login transport input none (default) stopbits 1 (default) line vty 0 4 password secret login !
スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。 これらは、ルータ上で手動で設定されます。 ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。 スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。
スタティック ルートを設定するには、次の手順を実行します。
1. (オプション 1) ip route prefix mask {ip-address | interface-type interface-number [ip-address]}
2. (オプション 2) ipv6 route prefix/mask {ipv6-address | interface-type interface-number [ipv6-address]}
3. end
次の設定例は、宛先 IP アドレスが 192.168.1.0、サブネット マスクが 255.255.255.0 のすべての IP パケットを、IP アドレス 10.10.10.2 の他の装置に対して、ギガビット インターフェイス上からスタティック ルートで送信します。 具体的には、パケットが設定済みの PVC に送信されます。
default と示されているコマンドは、入力する必要はありません。 このコマンドは、running-config コマンドの使用時に、生成されたコンフィギュレーション ファイルに自動的に示されます。
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0
スタティック ルートが正しく設定されていることを確認するには、show ip route コマンド(または show ipv6 route コマンド)を入力し、文字 S で示されるスタティック ルートを見つけます。
IPv4 アドレスを使用する場合は、次のような確認用の出力が表示されます。
Router# show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 1 subnets C 10.108.1.0 is directly connected, Loopback0 S* 0.0.0.0/0 is directly connected, FastEthernet0
IPv6 アドレスを使用する場合は、次のような確認用の出力が表示されます。
Router# show ipv6 route IPv6 Routing Table - default - 5 entries Codes: C - Connected, L - Local, S - Static, U - Per-user Static route B - BGP, R - RIP, H - NHRP, I1 - ISIS L1 I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1 OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2 ls - LISP site, ld - LISP dyn-EID, a - Application C 2001:DB8:3::/64 [0/0] via GigabitEthernet0/0/2, directly connected S 2001:DB8:2::/64 [1/0] via 2001:DB8:3::1
ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。 ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。
ルータは、ルーティング情報プロトコル(RIP)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、ルートを動的に学習できます。
ルータの RIP を設定するには、次の手順を実行します。
1. router rip
2. version {1 | 2}
3. network ip-address
4. no auto-summary
5. end
次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。 設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。
! Router# show running-config Building configuration... Current configuration : 1616 bytes ! ! Last configuration change at 03:17:14 EST Thu Sep 6 2012 ! version 15.3 service timestamps debug datetime msec service timestamps log datetime msec no platform punt-keepalive disable-kernel-core ! hostname Router ! boot-start-marker boot-end-marker ! ! vrf definition Mgmt-intf ! address-family ipv4 exit-address-family ! address-family ipv6 exit-address-family ! enable password cisco ! no aaa new-model ! transport-map type console consolehandler banner wait ^C Waiting for IOS vty line ^C banner diagnostic ^C Welcome to diag mode ^C ! clock timezone EST -4 0 ! ! ip domain name cisco.com ip name-server vrf Mgmt-intf 203.0.113.1 ip name-server vrf Mgmt-intf 203.0.113.129 ! ipv6 multicast rpf use-bgp ! ! multilink bundle-name authenticated ! redundancy mode none ! ip ftp source-interface GigabitEthernet0 ip tftp source-interface GigabitEthernet0 ! ! interface GigabitEthernet0/0/0 no ip address negotiation auto ! interface GigabitEthernet0/0/1 no ip address negotiation auto ! interface GigabitEthernet0/0/2 no ip address negotiation auto ! interface GigabitEthernet0/0/3 no ip address negotiation auto ! interface GigabitEthernet0 vrf forwarding Mgmt-intf ip address 172.18.77.212 255.255.255.240 negotiation auto ! ip forward-protocol nd ! no ip http server no ip http secure-server ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 172.18.77.209 ! control-plane ! ! line con 0 stopbits 1 line aux 0 stopbits 1 line vty 0 4 password cisco login ! transport type console 0 input consolehandler ! ntp server vrf Mgmt-intf 10.81.254.131 ! end
RIP が正しく設定されていることを確認するには、show ip route コマンドを入力し、文字 R で示される RIP ルートを見つけます。 次の例のような出力が表示されます。
Router# show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 1 subnets C 10.108.1.0 is directly connected, Loopback0 R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0/0
拡張インテリア ゲートウェイ ルーティング プロトコル(EIGRP)を設定するには、次の手順を実行します。
1. router eigrp as-number
2. network ip-address
3. end
次の設定例は、IP ネットワーク 192.168.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。 EIGRP の自律システム番号として、109 が割り当てられています。 この設定を表示するには、show running-config コマンドを使用します。
Router# show running-config . . . ! router eigrp 109 network 192.168.1.0 network 10.10.12.115 ! . . .
IP EIGRP を正しく設定したことを確認するには、show ip route コマンドを入力し、文字 D のマークが付いている EIGRP ルートを見つけます。 次のような確認用の出力が表示されます。
Router# show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 1 subnets C 10.108.1.0 is directly connected, Loopback0 D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0
目次
ここでは、ルータの基本設定について説明します。次の項で構成されています。
ルータを初めて起動すると、一部の基本設定がすでに完了していることがわかります。 初期設定を表示するには、次の例に示すように show running-config コマンドを使用します。
Router# show running-config Building configuration... Current configuration : 977 bytes ! version 15.3 service timestamps debug datetime msec service timestamps log datetime msec no platform punt-keepalive disable-kernel-core ! hostname Router ! boot-start-marker boot-end-marker ! ! vrf definition Mgmt-intf ! address-family ipv4 exit-address-family ! address-family ipv6 exit-address-family ! ! no aaa new-model ! ipv6 multicast rpf use-bgp ! ! multilink bundle-name authenticated ! ! redundancy mode none ! interface GigabitEthernet0/0/0 no ip address negotiation auto ! interface GigabitEthernet0/0/1 no ip address negotiation auto ! interface GigabitEthernet0/0/2 no ip address negotiation auto ! interface GigabitEthernet0/0/3 no ip address negotiation auto ! interface GigabitEthernet0 vrf forwarding Mgmt-intf no ip address negotiation auto ! ip forward-protocol nd ! no ip http server no ip http secure-server ! ! control-plane ! ! line con 0 stopbits 1 line vty 0 4 login ! ! end
1. configure terminal
2. hostname name
3. enable secret password
4. no ip domain-lookup
コマンドまたはアクション | 目的 | |
---|---|---|
ステップ 1 | configure terminal 例: Router> enable Router# configure terminal Router(config)# |
グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。 次のコマンドを使用して、ルータとリモート ターミナルを接続します。 telnet router-name or address Login: login-id Password: ********* Router> enable |
ステップ 2 | hostname name 例: Router(config)# hostname Router |
ルータ名を指定します。 |
ステップ 3 | enable secret password 例: Router(config)# enable secret cr1ny5ho |
ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。 |
ステップ 4 | no ip domain-lookup 例: Router(config)# no ip domain-lookup |
ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。 グローバル パラメータ コマンドの詳細については、『Cisco IOS Release Configuration Guide』マニュアル セットを参照してください。 |
1. interface gigabitethernet slot/bay/port
2. ip address ip-address mask
3. ipv6 address ipv6-address/prefix
4. no shutdown
5. exit
ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。
ループバック インターフェイスを設定するには、次の手順を実行します。
1. interface type number
2. (オプション 1)ip address ip-address mask
3. (オプション 2) ipv6 address ipv6-address/prefix
4. exit
このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。 この設定例は、スタティック IP アドレスとして機能する IP アドレス 192.0.2.0/24 のギガビット イーサネット インターフェイス上に設定されるループバック インターフェイスを示しています。 ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。
!
interface loopback 0
ip address 192.0.2.0 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
show interface loopback コマンドを入力します。 次の例のような出力が表示されます。
Router# show interface loopback 0 Loopback0 is up, line protocol is up Hardware is Loopback Internet address is 200.200.100.1/24 MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, reliability 255/255, txload 1/255, rxload 1/255 Encapsulation LOOPBACK, loopback not set Last input never, output never, output hang never Last clearing of "show interface" counters never Queueing strategy: fifo Output queue 0/0, 0 drops; input queue 0/75, 0 drops 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 0 packets input, 0 bytes, 0 no buffer Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 0 packets output, 0 bytes, 0 underruns 0 output errors, 0 collisions, 0 interface resets 0 output buffer failures, 0 output buffers swapped out
または、次の例に示すように、ping コマンドを使用してループバック インターフェイスを確認します。
Router# ping 192.0.2.0 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.0.2.0, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
サービス モジュールの設定の詳細については、『Cisco SM-1T3/E3 Service Module Configuration Guide』の「Service Module Management」の項の「Service Modules」を参照してください。
ルータでは、Cisco Discovery Protocol(CDP)がデフォルトでイネーブルに設定されています。
(注) |
Cisco アグリゲーション サービス ルータまたは Cisco CSR 1000v では、CDP はデフォルトでイネーブルに設定されていません。 |
CDP の使用法の詳細については、『Cisco Discovery Protocol Configuration Guide, Cisco IOS XE Release 3S』を参照してください。
1. line [aux | console | tty | vty] line-number
2. password password
3. login
4. exec-timeout minutes [seconds]
5. exit
6. line [aux | console | tty | vty] line-number
7. password password
8. login
9. end
スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。 これらは、ルータ上で手動で設定されます。 ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。 スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。
スタティック ルートを設定するには、次の手順を実行します。
1. (オプション 1) ip route prefix mask {ip-address | interface-type interface-number [ip-address]}
2. (オプション 2) ipv6 route prefix/mask {ipv6-address | interface-type interface-number [ipv6-address]}
3. end
次の設定例は、宛先 IP アドレスが 192.168.1.0、サブネット マスクが 255.255.255.0 のすべての IP パケットを、IP アドレス 10.10.10.2 の他の装置に対して、ギガビット インターフェイス上からスタティック ルートで送信します。 具体的には、パケットが設定済みの PVC に送信されます。
default と示されているコマンドは、入力する必要はありません。 このコマンドは、running-config コマンドの使用時に、生成されたコンフィギュレーション ファイルに自動的に示されます。
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0
スタティック ルートが正しく設定されていることを確認するには、show ip route コマンド(または show ipv6 route コマンド)を入力し、文字 S で示されるスタティック ルートを見つけます。
IPv4 アドレスを使用する場合は、次のような確認用の出力が表示されます。
Router# show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 1 subnets C 10.108.1.0 is directly connected, Loopback0 S* 0.0.0.0/0 is directly connected, FastEthernet0
IPv6 アドレスを使用する場合は、次のような確認用の出力が表示されます。
Router# show ipv6 route IPv6 Routing Table - default - 5 entries Codes: C - Connected, L - Local, S - Static, U - Per-user Static route B - BGP, R - RIP, H - NHRP, I1 - ISIS L1 I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1 OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2 ls - LISP site, ld - LISP dyn-EID, a - Application C 2001:DB8:3::/64 [0/0] via GigabitEthernet0/0/2, directly connected S 2001:DB8:2::/64 [1/0] via 2001:DB8:3::1
ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。 ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。
ルータは、ルーティング情報プロトコル(RIP)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、ルートを動的に学習できます。
1. router rip
2. version {1 | 2}
3. network ip-address
4. no auto-summary
5. end
次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。 設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。
! Router# show running-config Building configuration... Current configuration : 1616 bytes ! ! Last configuration change at 03:17:14 EST Thu Sep 6 2012 ! version 15.3 service timestamps debug datetime msec service timestamps log datetime msec no platform punt-keepalive disable-kernel-core ! hostname Router ! boot-start-marker boot-end-marker ! ! vrf definition Mgmt-intf ! address-family ipv4 exit-address-family ! address-family ipv6 exit-address-family ! enable password cisco ! no aaa new-model ! transport-map type console consolehandler banner wait ^C Waiting for IOS vty line ^C banner diagnostic ^C Welcome to diag mode ^C ! clock timezone EST -4 0 ! ! ip domain name cisco.com ip name-server vrf Mgmt-intf 203.0.113.1 ip name-server vrf Mgmt-intf 203.0.113.129 ! ipv6 multicast rpf use-bgp ! ! multilink bundle-name authenticated ! redundancy mode none ! ip ftp source-interface GigabitEthernet0 ip tftp source-interface GigabitEthernet0 ! ! interface GigabitEthernet0/0/0 no ip address negotiation auto ! interface GigabitEthernet0/0/1 no ip address negotiation auto ! interface GigabitEthernet0/0/2 no ip address negotiation auto ! interface GigabitEthernet0/0/3 no ip address negotiation auto ! interface GigabitEthernet0 vrf forwarding Mgmt-intf ip address 172.18.77.212 255.255.255.240 negotiation auto ! ip forward-protocol nd ! no ip http server no ip http secure-server ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 172.18.77.209 ! control-plane ! ! line con 0 stopbits 1 line aux 0 stopbits 1 line vty 0 4 password cisco login ! transport type console 0 input consolehandler ! ntp server vrf Mgmt-intf 10.81.254.131 ! end
RIP が正しく設定されていることを確認するには、show ip route コマンドを入力し、文字 R で示される RIP ルートを見つけます。 次の例のような出力が表示されます。
Router# show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 1 subnets C 10.108.1.0 is directly connected, Loopback0 R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0/0
1. router eigrp as-number
2. network ip-address
3. end
次の設定例は、IP ネットワーク 192.168.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。 EIGRP の自律システム番号として、109 が割り当てられています。 この設定を表示するには、show running-config コマンドを使用します。
Router# show running-config . . . ! router eigrp 109 network 192.168.1.0 network 10.10.12.115 ! . . .
IP EIGRP を正しく設定したことを確認するには、show ip route コマンドを入力し、文字 D のマークが付いている EIGRP ルートを見つけます。 次のような確認用の出力が表示されます。
Router# show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 1 subnets C 10.108.1.0 is directly connected, Loopback0 D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0