New Features

New Features for Cisco IOS XE 17.8.1

Cellular Serviceability Enhancements

Enhancements have been made for cellular and GPS features as follows:

Trigger points and debug code can be enabled via controller cellular CLIs for generating and trap the debug data automatically without manual intervention. The following CLI options are available:

(config-controller)#lte modem serviceability ?
  gps               GPS debugging
  interface-resets  Interface resets/Bearer deletion
  modem-crash       Modem-crash debugging
  modem-resets      IOS initiated unknown modem-resets

The debug data includes the following:

  • Context Based debug logs (tracebacks, and GPS locations).

  • Well formatted debug messages.

  • Vendor specific debug data at a broader range.

The debug logs are located in the following location of flash:

router#dir flash:servelogs
Directory of bootflash:/servelogs/

259340  -rw-              122   Sep 7 2021 17:40:44 +00:00  gpslog-slot5-20210907-174044
259339  -rw-             1734   Sep 7 2021 12:14:07 +00:00  celllog-slot5-20210905-164628

GPS and cellular log files are created separately with file names using the timestamp at the time of the creation. These files are created as follows:

  • If the existing file has reached 10Mb, a new file will be created.

  • A new file will be created if the feature (GPS, or cellular) is completely disabled, and then re-enabled.

New Features for Cisco IOS-XE 17.5.1

VXLAN

VXLAN is a MAC in IP/UDP (MAC-in-UDP) encapsulation technique with a 24-bit segment identifier in the form of a VXLAN ID. The larger VXLAN ID allows LAN segments to scale to 16 million in a cloud network. In addition, the IP/UDP encapsulation allows each LAN segment to be extended across existing Layer 3 networks, making use of Layer 3 Equal-Cost Multi-Path (ECMP).

The configuration for the two devices is shown in the following table:

Router-1

Router-2


bridge-domain 1
 member vni 6001
 member Vlan100 service-instance 1
!
interface Loopback1
 ip address 200.200.200.200 255.255.255.255
!
interface GigabitEthernet0/0/0
 ip address 192.168.1.2 255.255.255.0
 media-type rj45
!
interface FastEthernet0/0/1
 switchport access vlan 100
!
interface Vlan100
 no ip address
 service instance 1 ethernet
  encapsulation dot1q 100 //untag
!
interface nve1
 no ip address
 source-interface Loopback1
 member vni 6001
  ingress-replication 100.100.100.100
 !
ip forward-protocol nd
ip pim rp-address 200.200.200.200
ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.1.3
!

bridge-domain 1
 member vni 6001
 member Vlan100 service-instance 1
!
interface Loopback1
 ip address 100.100.100.100 255.255.255.255
!
interface GigabitEthernet0/0/0
 ip address 192.168.1.3 255.255.255.0
 media-type rj45
!
interface FastEthernet0/0/1
 switchport access vlan 100
!
interface Vlan100
 no ip address
 service instance 1 ethernet
 encapsulation dot1q 100 //untag
!
interface nve1
 no ip address
 source-interface Loopback1
 member vni 6001
  ingress-replication 200.200.200.200
 !
ip forward-protocol nd
ip pim rp-address 100.100.100.100
no ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.1.2
!

ERSPAN Support Cellular Interface as Source Interface

Encapsulated Remote Switched Port Analyzer (ERSPAN) allows traffic from Cellular interfaces to be monitored. ERSPAN sends monitored traffic to a network analyzer.

The following is a sample configuration:


Router(config)#monitor session 1 type erspan-source
Router(config-mon-erspan-src)#no shut
Router(config-mon-erspan-src)#source interface Cellular0/1/0
Router(config-mon-erspan-src)#destination
Router(config-mon-erspan-src-dst)#erspan-id 1
Router(config-mon-erspan-src-dst)#mtu 146
Router(config-mon-erspan-src-dst)#ip address 169.254.1.2
Router(config-mon-erspan-src-dst)#origin ip address 169.254.1.1
Router#show monitor session erspan-source
Session 1
---------
Type : ERSPAN Source Session
Status : Admin Enabled
Source Ports :
Both : Ce0/1/0
Destination IP Address : 169.254.1.2
MTU : 1464
Destination ERSPAN ID : 1
Origin IP Address : 169.254.1.1

For detailed information on configuring ERSPAN, see Configuring ERSPAN.