Overview of Dynamic Link Exchange Protocol

The Dynamic Link Exchange Protocol (DLEP) is a radio aware routing (RAR) protocol. DLEP provides a bidirectional, event-driven communication channel between the router and the radio to facilitate communication of changing link characteristics. In large mobile networks, connections to the routing neighbors are interrupted due to distance and radio obstructions. DLEP addresses the challenges faced when merging IP routing and radio frequency (RF) communications.

Benefits of DLEP

DLEP provides capabilities that enable:

  • Optimal route selection based on feedback from radios

  • Faster convergence when nodes join and leave the network

  • Efficient integration of point-to-point, point-to-multipoint and broadcast multi-access radio topologies with multi-hop routing

  • Flow-controlled communications between the radio and its partner router using rate-based Quality of Service (QoS) policies

  • Dynamic shaping of fluctuating RF bandwidth in near real time to provide optimized use of actual RF bandwidth

This chapter contains the following sections:

Feature Information for Dynamic Link Exchange Protocol

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1. Feature Information for Dynamic Link Exchange Protocol

Feature Name

Releases

Feature Information

Dynamic Link Exchange Protocol

Cisco IOS XE Release 17.8.1a

This feature was introduced for the following platforms:

  • Cisco Catalyst 8000V Edge Software

Cisco IOS XE Release 17.11.1a

This feature was introduced for the the following platforms:

  • Cisco Catalyst 8200 Series Edge Platforms

  • Cisco Catalyst 8300 Series Edge Platforms

  • Cisco Catalyst 8500 Series Edge Platforms

IPv6 Unicast Support with DLEP

Cisco IOS XE Release 17.12.1a

The IPv6 Unicast Support feature introduces support for IPv6 data plane to RAR DLEP. This feature was introduced for the following platforms:

  • Cisco Catalyst 8000V Edge Software

  • Cisco Catalyst 8300 Series Edge Platforms

  • Cisco Catalyst 8500 and 8500L Series Edge Platforms

DLEP Topology

DLEP is a control protocol between a router and a DLEP-enabled radio modem. The DLEP message exchange between the router and radio allows the radio to communicate the router about the link quality. This is analogous to the way the bar icon on your cell phone indicates your Wi-Fi or LTE signal quality.

Figure 1. Network with DLEP

Using DLEP, we can make use of routing distances with equal cost, where metrics are updated in real time, based on the best path.

Figure 2. Network without DLEP

Without DLEP, there are two equal cost paths to any unadjusted routing protocol. With DLEP, routing metrics can be adjusted in real-time to favor the best path.


Note


The final selection of a band is dependent on atmospheric conditions and interference.

Note


in DLEP topology,
  • the radio is the DLEP client,

  • the router is the DLEP server, and

  • the remote router is the DLEP neighbor.


Interfaces in IOS-XE Platforms

  • Virtual Multipoint Interface (VMI)

    • The VMI interface acts as an umbrella interface for all virtual access interfaces, per physical interface. VMI is used for routing protocols such as OSPFv3 and EIGRP, which will see a single VMI interface instead of all VA interfaces. This helps reduce routing table size without impacting the integrity of network.

  • Virtual Template (VT)

    • Virtual Template serves as the template for every Virtual Access interface.

  • Virtual Access (VA) interface

    • One VA is created for each DLEP Neighbor that is discovered on the network.

  • Underlaying physical Layer 3 WAN interface (Gi 0/0/0 and Gi 0/0/1), or even sub-interface (Gi 0/0/0.2 or Gi0/0/1.2

Packet Flow Diagram with Flow Types

The following diagram describes the packet flow:

Figure 3. Packet Flow with Flow Types

Item

Description

1

Packet sent from IOS-XE to DLEP neighbor (to Radio): packet with DST MAC of neighbor MAC, neighbor IP sent out from DLEP Physical interface.

2

DLEP Packet (from radio) received thru DLEP Physical interface to IOS-XE: packet needs to be delivered to IOS routing protocol marked as from VMI interface.

3

End to End user data.

Prerequisites for DLEP

  • DLEP requires the Network Advantage license.

Restrictions and Limitations

DLEP has the following restrictions and limitations:

  • Multicast traffic is not supported with DLEP, but is supported with PPPOE.

  • DLEP cannot be deployed with High Availability (HA) configuration.

  • You must configure the VMI and Virtual-Template before attaching the Virtual-Template to a physical interface.

  • Routers are connected over DLEP radio links, and only 1 radio per interface (VLAN or physical) is supported. The same interface cannot be used for connecting any other router (including remote DLEP peer router).

  • You must remove all configurations for the virtual-template individually using the no form of the respective configuration commands, before removing the virtual-template using the no interface virtual-template command.

  • You cannot change the configurations on the virtual-template and VMI interfaces while DLEP is enabled on the physical interface. To make such changes, disable DLEP by removing the DLEP configuration from the physical interface, make the changes, and re-configure DLEP on the physical interface.

  • DLEP interface does not support jumbo frames (frames > 1500 bytes in size).

  • Routing of internally generated application traffic (e.g. pingv6) with source as DLEP VMI / physical interface is not supported.

  • You cannot use the show ipv6 neighbor command to view the information about DLEP neighbors.

Configuring DLEP

This section provides the following major sections for initiating, verifying, and managing all aspects of Dynamic Link Exchange Protocol (DLEP) on an interface. DLEP uses following interfaces that need to be configured:

  • Physical interface

  • VMI interface

  • Virtual Templates


Important


You must configure the VMI and Virtual-Template before attaching the Virtual-Template to a physical interface.

Note


Routers are connected over DLEP radio links and only 1 radio per interface (VLAN or physical) is supported. The same interface cannot be used for connecting any other router (including remote DLEP peer router).


Configuring the Virtual Multipoint Interface

By default, virtual multipoint interfaces (VMIs) operate in aggregate mode, which means that all the virtual access interfaces created by DLEP sessions are aggregated logically under the configured VMI. Packets sent to the VMI are forwarded to the correct virtual access interface.

To configure the VMI, perform the following procedure:

Procedure

  Command or Action Purpose

Step 1

enable

Example:


Router> enable 
Router#

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Router# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#

Enters global configuration mode.

Step 3

interface vmi number

Example:

Router(config)# interface vmi 1 
Router(config-if)#

Creates a VMI and enters interface configuration mode.

This example creates VMI1.

Step 4

ip unnumbered interface

Example:

Router(config-if)#ip unnumbered gigabitEthernet 0/0/1  

Enables the IP on the VMI and bring it up without assigning a unique IP address to it.

Step 5

physical-interface interface

Example:

Router(config-if)#physical-interface gigabitEthernet 0/0/0  

Binds the physical interface to VMI interface, for packet flow.

Step 6

ipv6 enable

Example:


Router(config-if)# ipv6 enable 

Enable ipv6 support under VMI interface.

Step 7

Configure routing protocols.

Example:

Router(config-if)#ospfv3 1 ipv4 area 0 

Enable VMI interface to participate in OSPFv3 or EIGRP routing.

Step 8

exit

Example:

Router(config-if)# exit 
Router(config)#

Exits the current mode.

Step 9

router ospfv3 1

Example:

Router(config)# router ospfv3 1 

Global configuration for OSPFv3

Step 10

address-family ipv4 unicast

Example:

Router(config-router)# address-family ipv4 unicast 
Router(config-router-af)#

Adding address family for IPv4 unicast routing under global OSPFv3 configuration.

Configuring the Virtual Template

Configuring DLEP requires a virtual template to be defined. Perform this task to create the DLEP virtual template:

Procedure

  Command or Action Purpose

Step 1

enable

Example:


Router> enable 
Router#

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Router# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#

Enters global configuration mode.

Step 3

interface Virtual-Template number

Example:

Router(config)# interface Virtual-Template 1 
Router(config-if)#

Creates Virtual-Template interface and enters interface configuration mode.

Note

 
You need to use the same virtual-template interface for configuring DLEP on physical interface.

Step 4

ip unnumbered interface

Example:

Router(config-if)#ip unnumbered gigabitEthernet 0/0/0  

Enables the IP on the VMI and bring it up without assigning a unique IP address to it.

Step 5

ipv6 enable

Example:

Router(config-if)# ipv6 enable 
Router(config)#

Enables IPv6 support under Virtual-Template interface.

Step 6

exit

Example:

Router(config-if)# exit 
Router(config)#

Exits the current mode.

Configuring the Physical Interface

DLEP configuration is currently supported on the WAN interface of routing platforms. As described above, you need to configure both the VMI and Virtual-Template interface before configuring the physical interface. There are various ways that DLEP configuration can be attached to WAN interface:

  • DLEP template with well-known ip address [Recommended]

  • DLEP template with TCP/UDP port based between server (Router) and client (Radio)

  • DLEP template with dynamic port on server (Router)

  • DLEP template attach in discovery mode

For each of the four modes mentioned above, the user also has the option to enable Generalized TTL Security Mechanism (GTSM).

To configure DLEP on an interface, perform the following procedure:

Procedure

  Command or Action Purpose

Step 1

enable

Example:

Router> enable 
Router#

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Router# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#

Enters global configuration mode.

Step 3

interface gi0/0/0 or gi0/0/1

Example:

Router(config)# interface gigabitEthernet 0/0/0 
Router(config-if)#

Enters interface configuration mode.

Step 4

ipv6 enable

Example:

Router(config-if)#ipv6 enable 

Enables IPv6 support under interface level.

Step 5

Assigning IP address to physical interface

Example:

Router(config-if)# ip address 10.0.0.1 255.255.255.0 

Assigns physical IP address to the WAN interface.

Step 6

ip dlep vtemplate port number

Example:


Router(config-if)#ip dlep vtemplate number 1 

Attaches DLEP Template to WAN interface, for discovery mode.

Step 7

no shutdown

Example:

Router(config-if)# no shutdown 

Brings up the interface.

Step 8

exit

Example:

Router(config-if)# exit 
Router(config)#

Exits the current mode.

Configuring IPv6 with DLEP

From Cisco IOS XE 17.12.1a, DLEP can be configured with IPv6 dataplane.


Note


When you configure DLEP for IPv6 traffic, enable IPv6 on the physical interface using the ipv6 enable command before associating the VMI interface with the physical interface using the physical-interface <interface_name> command.


Procedure


Step 1

Enable IPv6 unicast routing:

Router# configure terminal
Router(config)# ipv6 unicast-routing
Router(config)#end
Router#

Step 2

Enable IPv6 on the physical interface:

Router#configure terminal
Router(config)# interface GigabitEthernet0/0/0
Router(config-if)# ipv6 enable
Router(config-if)#end
Router#

Step 3

Configure the Virtual Template Interface:

Router#configure terminal
Router(config)# interface virtual-template1
Router(config-if)# ip unnumbered GigabitEthernet0/0/0
Router(config-if)# ipv6 enable
Router(config-if)# ipv6 nd dad attempts 0
Router(config-if)#end
Router#

Step 4

Configure the Virtual Multipoint Interface:

Router#configure terminal
Router(config)# interface vmi1
Router(config-if)# ip unnumbered GigabitEthernet0/0/0
Router(config-if)# physical-interface GigabitEthernet0/0/0
Router(config-if)# ipv6 enable
Router(config-if)#end
Router#

Step 5

Configure the physical interface:

Router#configure terminal
Router(config)# interface GigabitEthernet0/0/0
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config-if)# ipv6 address 1000::1/64
Router(config-if)# ip dlep vtemplate 1
Router(config-if)#end
Router#

Attaching DLEP Virtual Templates

DLEP virtual templates can be attached in different modes to the WAN or sub-interface of the router.

Configuring DLEP Client/Server Based On Port Number

In this example, you are configuring the DLEP server, and client UDP and TCP ports.

Command or Action

Purpose

Router(config)#interface gi0/0/0
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# ipv6 enable
Router(config-if)# ip dlep vtemplate 1 port 11113 tcp port 11114 
client ip 10.0.0.3 port 11115
Router(config-if)# no shutdown

DLEP configuration where the server (router) is listening on UDP port 11113 and TCP port 11114, and the client (radio) is listening to TCP port 11115. The UDP port of the client is by default on 854.

Configuring DLEP with Dynamic Port on Server

In this example, you are configuring the DLEP server, and the UDP and TCP ports on the client.

Command or Action

Purpose

Router(config)#interface gi0/0/0
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# ipv6 enable
Router(config-if)# ip dlep vtemplate 1 client ip 10.0.0.3 port 11115
Router(config-if)# no shutdown

The DLEP configuration where the server (router) is listening to the default UDP or TCP ports, and the client (radio) is listening to TCP port 11115. The UDP port of the client is by default on 854.

Attaching DLEP Template in Discovery Mode

When in discovery mode, the DLEP server sends out Peer Discovery signals, and waits for a Peer Offer signal from the radio.

Command or Action

Purpose

Router(config)#interface gi0/0/0
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# ipv6 enable
Router(config-if)# ip dlep vtemplate 1
Router(config-if)# no shutdown

The DLEP configuration where the server (router) is listening to the default UDP or TCP ports.

Using a DLEP Template with a Well-Known IP Address

DLEP works based on RFC 8175, and uses the well-known IP address 224.0.0.117 on the server to communicate with radios.

Procedure

  Command or Action Purpose

Step 1

ip multicast-routing distributed

Example:

ip multicast-routing distributed

Enables multicast routing on the router.

Step 2

interface interface

Example:

Router(config)# interface gi0/0/0
Router(config-if)# ip address 10.1.2.3 255.255.255.0
Router(config-if)# no shutdown

Configures IPv4 address of the server.

Step 3

ip pim sparse-dense-mode

Example:

Router(config-if)# ip pim sparse-dense-mode

Enables the PIM to operate in sparse or dense mode, depending on the multicast group.

Step 4

Configure forwarding

Example:

Router(config-if)# ip mfib cef in
Router(config-if)# ip mfib cef out
Router(config-if)# ip mfib forwarding in
Router(config-if)# ip mfib forwarding out

Enables the router to forward multicast traffic.

Step 5

ip dlep vtemplate <Number> well-known ip <ip-address>

Example:

Router(config-if)# ip dlep vtemplate 1 well-known ip 224.0.0.117

Enable sDLEP vTemplate to listen to multi-cast traffic.

Note

 
Under the command show running-configuration the output will display as “ip dlep vtemplate 1” which means “well-known ip 224.0.0.117” is hidden.

DLEP Quality of Service Configuration

Quality of Service (QoS) for DLEP can be configured on the Virtual-Template which is associated with the physical interface. The data packets for DLEP flow through the Virtual Access interfaces that are created when DLEP neighbors come up.

Before proceeding, it is recommended to familiarize yourself with the Quality of Service (QoS) Configuration Guide for IOS-XE.

DLEP QoS Topology

The following figure shows a sample topology for DLEP with QoS.

Figure 4. QoS for DLEP

Based on above figure, the QoS policy is applied to egress of Virtual-Template attached to WAN interface Gi0/0/0.

Sample Configuration

Router# show running-config
Building configuration...

Current configuration : 7773 bytes
!
!
version 17.8
service timestamps debug datetime msec
service timestamps log datetime msec
service call-home
platform qfp utilization monitor load 80
platform punt-keepalive disable-kernel-core
!
hostname UUT1
!
boot-start-marker
boot system bootflash:/c6300-universalk9.SSA.bin
!
ipv6 unicast-routing
!
class-map match-any CMAP_VIDEO
 match dscp 33 
 match dscp 35 
 match dscp 37 
 match dscp 39 
 match dscp af41 
class-map match-any CMAP_VOICE
 match dscp 41 
 match dscp 43 
 match dscp 45 
 match dscp 47 
 match dscp 49 
class-map match-any CMAP_DATA
 match dscp 9 
 match dscp 11 
 match dscp 13 
 match dscp 15 
 match dscp af11 
!
policy-map Queue_Map
 class CMAP_VOICE
  bandwidth percent 40 
  set dscp af11
 class CMAP_VIDEO
  bandwidth percent 50 
 class CMAP_DATA
  bandwidth percent 10 
  set dscp af23
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 ipv6 enable
 ospfv3 1 ipv4 area 0
!
interface GigabitEthernet0/0/0
 ip address 10.0.0.1 255.255.255.0
 ip dlep vtemplate 1 port 11113 tcp port 11114 client ip 10.0.0.3 port 11115
 negotiation auto
 ipv6 address 1000::1/64
 ipv6 enable
!
interface GigabitEthernet0/0/1
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/1/0
 switchport access vlan 30
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0/0/0
 ipv6 enable
 service-policy output Queue_Map
!
interface Vlan1
 no ip address
!
interface Vlan30
 ip address 192.168.10.1 255.255.255.0
 ipv6 address 1010::1/64
 ipv6 enable
 ospfv3 1 ipv6 area 0
!
interface Async0/2/0
 no ip address
 encapsulation scada
!
interface vmi1
 ip unnumbered GigabitEthernet0/0/0
 ipv6 address FE80::7E31:EFF:FE85:1E78 link-local
 ipv6 enable
 ospfv3 1 ipv4 area 0
 physical-interface GigabitEthernet0/0/0
!
router ospfv3 1
 !
 router-id 1.1.1.1 
 address-family ipv4 unicast
 exit-address-family
!
end
Router#

Edit the Virtual-Template

Before you begin

To edit the Virtual-Template, you need to remove the configuration for ip dlep vtemplate on the WAN interface.

Procedure

  Command or Action Purpose

Step 1

enable

Example:

Router> enable
Router#

Enables privileged EXEC mode.

Step 2

configure terminal

Example:

Router# configure terminal
Router(config)#

Enters global configuration mode.

Step 3

interface Virtual-Template number

Example:

Router(config)# interface Virtual-Template 1
Router(config-if)#

Creates VMI interface and enters interface configuration mode.

Step 4

Service-policy [input|output] <policy-map>

Example:

Router(config-if)# service-policy output Queue_Map

Applies the policy-map to egress and ingress interfaces of the Virtual-Template.

Configuring DLEP on a Sub-Interface

DLEP can also be configured on a sub-interface. The following is an example:

Procedure

  Command or Action Purpose

Step 1

enable

Example:

Router> enable
Router#

Enables privileged EXEC mode.

Step 2

configure terminal

Example:

Router# configure terminal
Router(config)#

Enters global configuration mode.

Step 3

interface interface

Example:

Router(config)# interface gi0/0/0
Router(config-int)# no shut

Specifies an interface to configure.

Note

 

WAN interface must be in active state.

Step 4

interface sub-interface

Example:

Router(config-if)# interface gi0/0/0.2

Creates sub-interface gi0/0/0.2

Step 5

Encapsulation dot1q <VLAN> native

Example:

Router(config-subif)# encapsulation dot1q 2 native

Configures encapsulation dot1q over VLAN 2, and makes it native.

Step 6

ip address <IP> <SUBNET>

Example:

Router(config-subif)# ip address 10.0.0.1 255.255.255.0

Adds the IPv4 address for sub-interface.

Step 7

ipv6 enable

Example:

Router(config-subif)# ipv6 enable

Adds the IPv6 address for sub-interface. OSPFv3 IPv4 needs to have ipv6 support enabled on the interface level.

Step 8

interface vmi number

Example:

Router(config-subif)# interface vmi 1
Router(config-if)#

Creates VMI interface and enters interface configuration mode.

Step 9

ip unnumbered interface

Example:

Router(config-if)# ip unnumbered gigibitEthernet 0/0/0.2

Specifies VMI interface to use physical interface IP address.

Step 10

physical-interface interface

Example:

Router(config-if)# physical-interface gigibitEthernet 0/0/0.2

Binds the physical interface to VMI interface, for packet flow.

Step 11

ipv6 enable

Example:

Router(config-if)# ipv6 enable

Enables IPv6 support under VMI interface.

Step 12

interface sub-interface

Example:

Router(config-if)# interface gi0/0/0.2

Configures the sub-interface for the DLEP template.

Step 13

ip dlep vtemplate <number> [gtsm] client {ipv4 | ipv6}<ip-address> port port

Example:

Router(config-subif)# ip dlep vtemplate 1 gtsm client 10.0.0

OR

Router(config-subif)# ip dlep vtemplate 1 port 11113 tcp port 11114 gtsm client ip 10.0.0.3 port

Attaches the DLEP Template to the sub-interface

Note

 

DLEP can be configured either in auto-discovery mode or manual configuration mode. Use the first example to configure DLEP in auto-discovery mode, or the second example to configure DLEP in manual mode.

Step 14

exit

Example:

Router(config-if)# exit
Router(config)#

Exits the current mode.

Step 15

router eigrp <AS-NO>

Example:

Router(config)# router eigrp 1
Router(config-router)#router-id 1.1.1.1
Router(config-router)# network 10.0.0.0 0.0.0.255

Enables global configuration for EIGRP.

Configuring DLEP with OSPFv3

This section describes configuring DLEP with OSPFv3.


Note


By default, OSPFv3 considers only the following DLEP metrics in route cost calculation:

  • CDR

  • RLQ

  • MDR

  • Resource


Procedure


Step 1

Configure DLEP with IPv6:

See section Configuring IPv6 with DLEP.

Step 2

Configure the OSPF router:

Router#configure terminal
Router(config)#router ospfv3 1
Router(config-router)#router-id 200.200.200.200
Router(config-router)#address-family ipv4 unicast
Router(config-router-af)#end
Router#

Step 3

Configure OSPF on the VMI:

Router#configure terminal
Router(config)#interface vmi1
Router(config-if)#ospfv3 1 ipv4 area 0
Router(config-if)#ospfv3 1 ipv4 cost dynamic
Router(config-if)#ospfv3 1 ipv4 network manet
Router(config-if)#end
Router#

Configuring OSPFv3 for DLEP IPv6 unicast

From Cisco IOS XE 17.12.1, OSPFv3 for DLEP can be configured with IPv6 unicast.

Procedure


Step 1

Configure DLEP with IPv6:

See section Configuring IPv6 with DLEP.

Step 2

Configure the OSPF router:

Router#configure terminal
Router(config)# router ospfv3 1
Router(config-router)# router-id 200.200.200.200
Router(config-router)# address-family ipv6 unicast
Router(config-router-af)#end
Router#

Step 3

Configure OSPF on the VMI:

Router#configure terminal
Router(config)# interface vmi1
Router(config-if)# ospfv3 1 ipv6 area 0
Router(config-if)# ospfv3 1 ipv6 cost dynamic              -> enables dynamic route cost.
Router(config-if)# ospfv3 1 ipv6 network manet             -> sets OSPF network type to MANET.
Router(config-if)#end
Router#

Configuring DLEP EIGRP

This section describes configuring DLEP with EIGRP.


Note


By default, EIGRP considers only the following DLEP metrics in route cost calculation:

  • CDR

  • RLQ

  • MDR


Procedure

  Command or Action Purpose

Step 1

enable

Example:

Router> enable
Router#

Enables privileged EXEC mode.

Step 2

configure terminal

Example:

Router# configure terminal
Router(config)#

Enters global configuration mode.

Step 3

interface vmi number

Example:

Router(config)# interface vmi 1
Router(config-if)#

Creates VMI interface and enters interface configuration mode.

Step 4

ip unnumbered interface

Example:

Router(config-if)# ip unnumbered gigibitEthernet 0/0/0 

Attaches the VMI interface with the physical interface IP address.

Step 5

physical-interface interface

Example:

Router(config-if)# physical-interface gigibitEthernet 0/0/0 

Binds the physical interface to the VMI interface, for packet flow.

Step 6

ipv6 enable

Example:

Router(config-if)# ipv6 enable

Enables IPv6 support under VMI interface.

Step 7

no ip split-horizon eigrp number

Example:

Router(config-if)# no ip split-horizon eigrp 1

Disables split-horizon mechanism.

Step 8

exit

Example:

Router(config-if)# exit
Router(config)#

Exits the current mode.

Step 9

router eigrp autonomous-system-number

Example:

Router(config)# router eigrp 1
Router(config-router)# router-id 1.1.1.1
Router(config-router)# network 10.0.0.0 0.0.0.255
Router(config-router)# passive-interface GigabitEthernet0/0/0

Enables EIGRP configuration with autonomous system number that identifies the services to the other EIGRP address-family routers.

Configuring EIGRP for DLEP IPv6 unicast

From Cisco IOS XE 17.12.1a, EIGRP for DLEP can be configured with IPv6 unicast.

Procedure


Step 1

Configure the EIGRP router:

Router#configure terminal
Router(config)# ipv6 router eigrp 2
Router(config-rtr)# eigrp router-id 2.2.2.2
Router(config-rtr)#end
Router#

Step 2

Configure EIGRPv6 on VMI:

Router#configure terminal
Router(config)# interface vmi1
Router(config-if)# ipv6 eigrp 2
Router(config-if)# no ipv6 split-horizon eigrp 2
Router(config-if)#end
Router#

Optional Configurations for DLEP

There are a set of optional commands that are available to configure DLEP with a WAN or sub-interface. Using these commands, you can define the set of timeout intervals between peers, neighbors, and the heart-beat intervals for radios.

Command

Purpose

ip dlep set heartbeat-threshold ?
  <2-8>  Threshold of missed heartbeat messages

Sets the heartbeat-threshold, between Server and Client.

ip dlep set peer-description ? 
  LINE  Peer Description Name

Defines the description with Peer.

ip dlep set peer-heartbeat-interval ? 
  <1-60>  Peer Heartbeat Interval timer duration in seconds

Sets the heartbeat interval between Server and client.

ip dlep set peer-discovery-interval ? 
  <1-60>  Peer Discovery Interval timer duration in seconds

Sets the peer discovery interval timer.

Removing the DLEP Configuration

Before you begin

You must remove all configurations for the virtual-template individually using the no form of the respective configuration commands, before removing the virtual-template using the no interface virtual-template command.

Procedure

  Command or Action Purpose

Step 1

enable

Example:

Router> enable
Router#

Enables privileged EXEC mode.

Step 2

configure terminal

Example:

Router# configure terminal
Router(config)#

Enters global configuration mode.

Step 3

interface interface

Example:

Router(config)# interface gi0/0/0

Specifies the interface.

Step 4

no ip dlep vtemplate 1

Example:

Router(config-if)# no ip dlep vtemplate 1

Clears the DLEP configuration.

Note

 

Disabling DLEP on the physical interface also removes all optional DLEP configurations indicated in section Optional Configurations for DLEP.

Step 5

no int vmi <number>

Example:

Router(config-if)# no int vmi 1

Removes the VMI interface on the router.

Step 6

no int Virtual-Template <number>

Example:

Router(config-if)# no ip unnumbered gigabitEthernet 0/0/0
Router(config-if)# no ipv6 enable
Router(config-if)# no int Virtual-Template 1

Removing Virtual template on Router.

With the above configuration, DLEP will be removed from router. However, Virtual-Access interfaces that are created while bringing up DLEP neighbors, will still show up in the output of the show ip interface brief command until the system is rebooted.

Clearing DLEP Clients and Neighbors

This section describes how to clear DLEP configuration, using the clear dlep client <interface> <peer id> command, and possible ramifications.

The clear dlep client command clears the peer session.

The following shows an example:


Note


First obtain the Peer ID from the output of the show dlep client command. Then, use that as the input to the clear dlep client command.
Router#show dlep client gi0/0/1

DLEP Clients for Interface GigabitEthernet0/0/1
DLEP Local IP=15.0.0.10:55555 Sock=0


DLEP Local Radio IP=15.0.0.2:856 TCP Socket fd=1
 Peer ID=20, Virtual template=2
 Description: DLEP_Radio_2042
 Peer Timers (all values in milliseconds):
  Heartbeat=60000, Dead Interval=120000, Terminate ACK=240000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps
Router#

Router#clear dlep client gi0/0/1 20
DLEP: Clear Client (peer) peer_id=20 from 15.0.0.10 

There is another command that can be used to clear DLEP configuration. The clear dlep neighbor <interface> <session id> command clears DLEP neighbors. The session ID can be obtained using the show dlep neighbor command.

Router#clear dlep neighbor gi0/0/1 2215
DLEP: Clear neighbor sid=2215 from 195.0.0.2 

DLEP Validation Commands

This section contains examples of how to verify the DLEP configuration on the router.

DLEP Configuration

Command

Information

Router# show dlep config ?
  GigabitEthernet  GigabitEthernet IEEE 802.3z
  |                Output modifiers
  <cr>             <cr>

DLEP configuration is supported only on WAN or sub-interface.

Router# show dlep config g0/0/1
DLEP Configuration for GigabitEthernet0/0/1

DLEP Peer Description - 
DLEP Version = RFC 8175
DLEP Server IP=10.0.0.1:11117
DLEPv27 TCP Port = 11118
Virtual template=2
Timers (all values are in seconds):
Missed heartbeat threshold=2, Peer Terminate ACK timeout=10
Dlepv27 Applicable configs(in seconds):
Heartbeat interval=5, Discovery interval =5, Session Ack timeout=10
Neighbor activity timeout=0, Neighbor Down ACK timeout=10

DLEP Clients

Command

Information

Router# show dlep clients ?
  GigabitEthernet  GigabitEthernet IEEE 802.3z
  |                Output modifiers
  <cr>             <cr>

DLEP clients is supported only on WAN or sub-interface.

Router# show dlep clients
DLEP Clients for all interfaces:



DLEP Clients for Interface GigabitEthernet0/0/1
DLEP Server IP=10.0.0.1:11117 Sock=0 --> Local Router IP address


DLEP Client IP=10.0.0.2:859 TCP Socket fd=1 --> Directly connected Radio to the router
Peer ID=2, Virtual template=2
Description: DLEP_RadioSIM2
Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps
Router#

DLEP Neighbor

Command

Information

Router# show dlep neighbor ?
  GigabitEthernet  GigabitEthernet IEEE 802.3z
  |                Output modifiers
  <cr>             <cr>

DLEP neighbors is supported only on WAN or sub-interface.

Router# show dlep neighbor
DLEP Neighbors for all interfaces:

DLEP Neighbors for Interface GigabitEthernet0/0/1
DLEP Server IP=10.0.0.1:11117 Sock=0   ---> Local Router IP address

SID=2151  MAC_Address=a453.0e94.f861 
  Addresses:
  IPv4 : 16.0.0.1           ---> Mac-Address and IPv4 address of neighbor's end-point device
Supported Metrics:
  RLQ RX Metric : 100
  RLQ TX Metric : 100
  Resources Metric : 100
  MTU Metric : 1500
  Latency Metric : 250 microseconds
  CDR RX Metric : 100000000 bps
  CDR TX Metric : 100000000 bps
  MDR RX Metric : 100000000 bps
  MDR TX Metric : 100000000 bps

DLEP Counters

Command

Information

Router# show dlep counters ?
  GigabitEthernet  GigabitEthernet IEEE 802.3z
  |                Output modifiers
  <cr>             <cr>

DLEP Counters is supported only on WAN or sub-interface, which will summarize port information, counters for peer, and neighbors.

UUT1# show dlep counters
DLEP Counters for GigabitEthernet0/0/1

Last Clear Time = 

DLEP Version = RFC 8175
DLEP Server IP=10.0.0.1:11117
DLEPv5 TCP Port = 11118

Peer Counters:
RX Peer Discovery     0      TX Peer Offer             0     
 RX Peer Offer         0      TX Peer Discovery         0     
 RX Peer Init          0      TX Peer Init Ack          0     
 RX Peer Init Ack      1      TX Peer Init              1     
 RX Heartbeat          41     TX Heartbeat              41    
 RX Peer Terminate     0      TX Peer Terminate Ack     0     
 RX Peer Terminate Ack 0      TX Peer Terminate         0     

Neighbor Counters:
RX Neighbor Up        1      TX Neighbor Up Ack        1     
 RX Metric             0     
 RX Neighbor Down      0      TX Neighbor Down Ack      0     
 RX Neighbor Down Ack  0      TX Neighbor Down          1     

Exception Counters:
RX Invalid Message    0      RX Unknown Message        0     
 Pre-Existing Neighbor 0      Neighbor Resource Error   1     
 Neighbor Not Found    0      Neighbor Msg Peer Not Up  0     

Timer Counters:
Peer Heartbeat Timer         41    
 Peer Terminate Ack Timer     0     
 Neighbor Terminate Ack Timer 0     
 Neighbor Activity Timer      0     
 Radio Connect Timer          5     

Single Timer Wheel "Manet Infra Wheel"
  Granularity      = 250 msec
  Wheel size       = 4096
  Spoke index      = 3730
  Tick count       = 3423890
  Flags            = 0x00
  Active timers    = 1
  High water mark  = 1
  Started timers   = 171177
  Restarted timers = 2
  Cancelled timers = 5
  Expired timers   = 171169
  Long timers      = 0
  Long timer revs  = 0
  Timer suspends   = 0

Verifying DLEP Configuration

Use the following show commands to verify DLEP configuration.

Use the show dlep clients command to verify the DLEP client configuration based on port number:

Router# show dlep clients 
DLEP Clients for all interfaces:

DLEP Clients for Interface GigabitEthernet0/0/0
DLEP Server IP=10.0.0.1:11113 Sock=0

DLEP Client IP=10.0.0.3:11115 TCP Socket fd=1
Peer ID=1, Virtual template=1
 Description: DLEP-Radio1-Path-1
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps

Use the show dlep clients and show dlep counters commands to verify DLEP configuration with dynamic port on server:

Router# show dlep clients
DLEP Clients for all interfaces:

DLEP Clients for Interface GigabitEthernet0/0/0
DLEP Server IP=10.0.0.1:55555 Sock=0

DLEP Client IP=10.0.0.3:11115 TCP Socket fd=1
 Peer ID=1, Virtual template=1
 Description: DLEP-Radio1-Path-1
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps
Router# show dlep counters
DLEP Counters for GigabitEthernet0/0/0

Last Clear Time = 

DLEP Version = RFC 8175
DLEP Server IP=10.0.0.1:55555
DLEPv5 TCP Port = 55556

Peer Counters:
 RX Peer Discovery     0      TX Peer Offer             0     
 RX Peer Offer         0      TX Peer Discovery         0     
 RX Peer Init          0      TX Peer Init Ack          0     
 RX Peer Init Ack      1      TX Peer Init              1     
 RX Heartbeat          58     TX Heartbeat              58    
 RX Peer Terminate     0      TX Peer Terminate Ack     0     
 RX Peer Terminate Ack 0      TX Peer Terminate         0     

Neighbor Counters:
 RX Neighbor Up        0      TX Neighbor Up Ack        0     
 RX Metric             0     
 RX Neighbor Down      0      TX Neighbor Down Ack      0     
 RX Neighbor Down Ack  0      TX Neighbor Down          0     

Exception Counters:
 RX Invalid Message    0      RX Unknown Message        0     
 Pre-Existing Neighbor 0      Neighbor Resource Error   0     
 Neighbor Not Found    0      Neighbor Msg Peer Not Up  0     

Timer Counters:
 Peer Heartbeat Timer         58    
 Peer Terminate Ack Timer     0     
 Neighbor Terminate Ack Timer 0     
 Neighbor Activity Timer      0     
 Radio Connect Timer          5     

Single Timer Wheel "Manet Infra Wheel"
  Granularity      = 250 msec
  Wheel size       = 4096
  Spoke index      = 3592
  Tick count       = 3592
  Flags            = 0x00
  Active timers    = 1
  High water mark  = 2
  Started timers   = 164
  Restarted timers = 2
  Cancelled timers = 3
  Expired timers   = 158
  Long timers      = 0
  Long timer revs  = 0
  Timer suspends   = 0

Use the show dlep clients and show dlep counters commands to verify DLEP template attached in dscovery mode:

Router# show dlep clients 
DLEP Clients for all interfaces:

DLEP Clients for Interface GigabitEthernet0/0/0
DLEP Server IP=10.0.0.1:55555 Sock=0

DLEP Client IP=10.0.0.3:11115 TCP Socket fd=1
 Peer ID=1, Virtual template=1
 Description: DLEP-Radio1-Path-1
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps
Router# show dlep counters 
DLEP Counters for GigabitEthernet0/0/0

Last Clear Time = 

DLEP Version = RFC 8175
DLEP Server IP=10.0.0.1:55555
DLEPv5 TCP Port = 55556

Peer Counters:
 RX Peer Discovery     0      TX Peer Offer             0     
 RX Peer Offer         3      TX Peer Discovery         194   
 RX Peer Init          0      TX Peer Init Ack          0     
 RX Peer Init Ack      3      TX Peer Init              3     
 RX Heartbeat          710    TX Heartbeat              707   
 RX Peer Terminate     0      TX Peer Terminate Ack     0     
 RX Peer Terminate Ack 0      TX Peer Terminate         2     

Neighbor Counters:
 RX Neighbor Up        0      TX Neighbor Up Ack        0     
 RX Metric             0     
 RX Neighbor Down      0      TX Neighbor Down Ack      0     
 RX Neighbor Down Ack  0      TX Neighbor Down          0     

Exception Counters:
 RX Invalid Message    0      RX Unknown Message        0     
Pre-Existing Neighbor 0      Neighbor Resource Error   0     
 Neighbor Not Found    0      Neighbor Msg Peer Not Up  0     

Timer Counters:
 Peer Heartbeat Timer         709   
 Peer Terminate Ack Timer     2     
 Neighbor Terminate Ack Timer 0     
 Neighbor Activity Timer      0     
 Radio Connect Timer          3     

Single Timer Wheel "Manet Infra Wheel"
  Granularity      = 250 msec
  Wheel size       = 4096
  Spoke index      = 8
  Tick count       = 24584
  Flags            = 0x00
  Active timers    = 1
  High water mark  = 2
  Started timers   = 1209
  Restarted timers = 4
  Cancelled timers = 14
  Expired timers   = 1190
  Long timers      = 0
  Long timer revs  = 0
  Timer suspends   = 0

Use the show dlep clients command to verify DLEP template configuration with well-known IP address:

Router# show dlep clients
DLEP Clients for all interfaces:
DLEP Clients for Interface GigabitEthernet0/0/0
DLEP Server IP=10.1.2.3:55555 Sock=2

DLEP Client IP=10.1.2.4:854 TCP Socket fd=3
 Peer ID=1, Virtual template=1
 Description: OONF DLEP Radio
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link Latency Metric : 1000 microseconds
  Link CDR RX Metric : 104857600 bps
  Link CDR TX Metric : 104857600 bps
  Link MDR RX Metric : 104857600 bps
  Link MDR TX Metric : 104857600 bps

Use the show policy-map interface Virtual-Access command to verify QoS policy. In the following example, QoS policy is applied to Virtual-Template1, and data packets are flowing through Virtual-Access2 interface which is created when DLEP neighbors came up:

Router#show policy-map interface Virtual-Access 2
 Virtual-Access2 
  Service-policy output: Queue_Map

    Class-map: CMAP_VOICE (match-any)  
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match:  dscp 41 
      Match:  dscp 43 
      Match:  dscp 45 
      Match:  dscp 47 
      Match:  dscp 49 
      Queueing
      queue limit 208 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      bandwidth 40% (400000 kbps)
      QoS Set
        dscp af11
          Marker statistics: Disabled

    Class-map: CMAP_VIDEO (match-any)  
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match:  dscp 33 
      Match:  dscp 35 
      Match:  dscp 37 
      Match:  dscp 39 
      Match:  dscp af41 (34)
      Queueing
      queue limit 208 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      bandwidth 50% (500000 kbps)

    Class-map: CMAP_DATA (match-any)  
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match:  dscp 9 
      Match:  dscp 11 
      Match:  dscp 13 
      Match:  dscp 15 
      Match:  dscp af11 (10)
      Queueing
      queue limit 208 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 1024337/34827458
      bandwidth 10% (100000 kbps)
      QoS Set
        dscp af23
          Marker statistics: Disabled

    Class-map: class-default (match-any)  
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: any 
      
      queue limit 208 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0

Use the show running-config command to verify DLEP configuration on a sub-interface:

Router# show running-config
Building configuration...
Current configuration : 7726 bytes
!
!
version 17.8
hostname Router
!
boot-start-marker
boot system bootflash:/c6300-universalk9.SSA.bin
boot-end-marker
!
ipv6 unicast-routing
subscriber templating
! 
license udi pid ESR-6300-CON-K9 sn FOC234304H3
license boot level network-advantage
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 ipv6 enable
 ospfv3 1 ipv4 area 0
!
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/0.10
 encapsulation dot1Q 10
 ip address 10.0.0.1 255.255.255.0
 ip dlep vtemplate 1 port 11113 tcp port 11114 client ip 10.0.0.2 port 11115
 ipv6 enable
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0/0/0.10
!
interface vmi1
 ip unnumbered GigabitEthernet0/0/0.10
 ipv6 address FE80::7E31:EFF:FE85:1E78 link-local
 ipv6 enable
 ospfv3 1 network manet
 ospfv3 1 ipv4 area 0
 physical-interface GigabitEthernet0/0/0.10
!
router ospfv3 1
 !
 address-family ipv4 unicast
 exit-address-family
 !
 address-family ipv6 unicast
 exit-address-family
!
end

Router#

Use the show dlep neighbors command to verify IPv6 configuration with DLEP:

router# show dlep neighbors

DLEP Neighbors for all interfaces:
  DLEP Neighbors for Interface GigabitEthernet0/0/0.10
  DLEP Local IP=10.0.0.12:55555 Sock=0

SID=3323 Remote End-point MAC_Address=d478.9b5d.3800
Addresses:
  DLEP Remote IP : 10.0.0.2 
  DLEP Remote IPv6 LL : FE80::D678:9BFF:FE5D:3800 

Troubleshooting DLEP Configuration with show Commands

The following figure illustrates the sample topography that the various show commands in this section use.

Figure 5. Sample Installation

show DLEP Configuration

Router#    show dlep config Te0/0/0
DLEP Configuration for TenGigabitEthernet0/0/0

DLEP Peer Description - 
DLEP Version = RFC 8175
DLEP Local IP=19.19.19.151:55113----> Local Router IP address
DLEPv27 TCP Port = 55114
 Virtual template=1
 Timers (all values are in seconds):
 Missed heartbeat threshold=2, Peer Terminate ACK timeout=10
 Dlepv27 Applicable configs(in seconds):
 Heartbeat interval=5, Discovery interval =5, Session Ack timeout=10
 Neighbor activity timeout=0, Neighbor Down ACK timeout=10

show DLEP Clients

Router# show dlep clients

DLEP Clients for all interfaces:

DLEP Clients for Interface TenGigabitEthernet0/0/0
DLEP Local IP=19.19.19.151:55113 Sock=2----> Local Router IP address


DLEP Local Radio IP=19.19.19.121:9121 TCP Socket fd=3----> Directly connected Radio IP address
 Peer ID=42, Virtual template=1 ----> Attached virtual template for directly connected Radio from the router
Description: radio_9
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:----> Metrics from directly connected radio
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps

DLEP Clients for Interface TenGigabitEthernet0/0/1
DLEP Local IP=18.18.18.111:21115 Sock=0


DLEP Local Radio IP=18.18.18.112:8111 TCP Socket fd=1
 Peer ID=43, Virtual template=2
 Description: radio_7_8nw
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps

=====================================================

show DLEP Neighbors

Router#   show dlep neighbors

DLEP Neighbors for all interfaces:



DLEP Neighbors for Interface TenGigabitEthernet0/0/0
DLEP Local IP=19.19.19.151:55113 Sock=2----> Local Router IP address


SID=2187  Remote End-point MAC_Address=000c.2915.d4f8 ----> MAC address of end-point router interface
  Addresses:
  DLEP Remote IP : 19.19.19.161  DLEP Remote IPv6 LL : FE80::20C:29FF:FE15:D4F8
  Associated virtual access interface : Virtual-Access4----> DLEP Remote address and link-local of end-point router
Supported Metrics:----> Supported Metrics to reach end point router directly connected radio, based on the routing distance metrics will update apprropriately 
  RLQ RX Metric : 100
  RLQ TX Metric : 100
  Resources Metric : 100
  MTU Metric : 1500
  Latency Metric : 250 microseconds
  CDR RX Metric : 100000000 bps
  CDR TX Metric : 100000000 bps
  MDR RX Metric : 100000000 bps
  MDR TX Metric : 100000000 bps

DLEP Neighbors for Interface TenGigabitEthernet0/0/1
DLEP Local IP=18.18.18.111:21115 Sock=0


SID=2188  Remote End-point MAC_Address=000c.2915.d402 
  Addresses:
  DLEP Remote IP : 18.18.18.119  DLEP Remote IPv6 LL : FE80::20C:29FF:FE15:D402
  Associated virtual access interface : Virtual-Access3
 Supported Metrics:
  RLQ RX Metric : 100
  RLQ TX Metric : 100
  Resources Metric : 100
  MTU Metric : 1500
  Latency Metric : 250 microseconds
  CDR RX Metric : 100000000 bps
  CDR TX Metric : 100000000 bps
  MDR RX Metric : 100000000 bps
  MDR TX Metric : 100000000 bps

show DLEP Counters

Router# show dlep counters
DLEP Counters for TenGigabitEthernet0/0/0

Last Clear Time = 

DLEP Version = RFC 8175
DLEP Local IP=19.19.19.151:55113----> Local Router IP address
DLEPv5 TCP Port = 55114

Peer Counters:
 RX Peer Discovery     0      TX Peer Offer             0     
 RX Peer Offer         0      TX Peer Discovery         0     
 RX Peer Init          0      TX Peer Init Ack          0     
 RX Peer Init Ack      1      TX Peer Init              1     
 RX Heartbeat          23     TX Heartbeat              23    
 RX Peer Terminate     0      TX Peer Terminate Ack     0     
 RX Peer Terminate Ack 0      TX Peer Terminate         0     

Neighbor Counters:
 RX Neighbor Up        1      TX Neighbor Up Ack        1     
 RX Metric             0     
 RX Neighbor Down      0      TX Neighbor Down Ack      0     
 RX Neighbor Down Ack  0      TX Neighbor Down          0     

Exception Counters:
 RX Invalid Message    0      RX Unknown Message        0     
 Pre-Existing Neighbor 0      Neighbor Resource Error   0     
 Neighbor Not Found    0      Neighbor Msg Peer Not Up  0     

Timer Counters:
 Peer Heartbeat Timer         23    
 Peer Terminate Ack Timer     0     
 Neighbor Terminate Ack Timer 0     
 Neighbor Activity Timer      0     
 Radio Connect Timer          0     


DLEP Counters for TenGigabitEthernet0/0/1

Last Clear Time = 

DLEP Version = RFC 8175
DLEP Local IP=18.18.18.111:21115
DLEPv5 TCP Port = 21116

Peer Counters:
 RX Peer Discovery     0      TX Peer Offer             0     
 RX Peer Offer         0      TX Peer Discovery         0     
 RX Peer Init          0      TX Peer Init Ack          0     
 RX Peer Init Ack      1      TX Peer Init              1     
 RX Heartbeat          16     TX Heartbeat              16    
 RX Peer Terminate     0      TX Peer Terminate Ack     0     
 RX Peer Terminate Ack 0      TX Peer Terminate         0     

Neighbor Counters:
 RX Neighbor Up        1      TX Neighbor Up Ack        1     
 RX Metric             0     
 RX Neighbor Down      0      TX Neighbor Down Ack      0     
 RX Neighbor Down Ack  0      TX Neighbor Down          0     

Exception Counters:
 RX Invalid Message    0      RX Unknown Message        0     
 Pre-Existing Neighbor 0      Neighbor Resource Error   0     
 Neighbor Not Found    0      Neighbor Msg Peer Not Up  0     

Timer Counters:
 Peer Heartbeat Timer         16    
 Peer Terminate Ack Timer     0     
 Neighbor Terminate Ack Timer 0     
 Neighbor Activity Timer      0     
 Radio Connect Timer          0     

Single Timer Wheel "Manet Infra Wheel"
  Granularity      = 250 msec
  Wheel size       = 4096
  Spoke index      = 3078
  Tick count       = 470022
  Flags            = 0x00
  Active timers    = 2
  High water mark  = 3
  Started timers   = 4900
  Restarted timers = 10
  Cancelled timers = 105
  Expired timers   = 4783
  Long timers      = 0
  Long timer revs  = 0
  Timer suspends   = 0

Troubleshooting DLEP Configuration with debug Commands

This section shows two different troubleshooting scenarios.


Note


It is recommended to use debug commands only under the guidance of Cisco TAC.

Scenario 1 : DLEP client is not reachable

In this senario, the router is not running in discovery mode, and the client/radio attributes have been explicitly configured.

Step 1: The output of show dlep clients indicates that there is no active client:
Router# show dlep clients

DLEP Clients for all interfaces:


DLEP Clients for Interface GigabitEthernet0/0/1
DLEP Server IP=14.0.0.3:11117 Sock=-1
Step 2: Check the DLEP configuration:
Router#show dlep config
DLEP Configuration for GigabitEthernet0/0/1

DLEP Peer Description - 
DLEP Version = RFC 8175
DLEP Server IP=14.0.0.3:11117
DLEPv27 TCP Port = 11118
 Virtual template=2
 Timers (all values are in seconds):
 Missed heartbeat threshold=2, Peer Terminate ACK timeout=10
 Dlepv27 Applicable configs(in seconds):
 Heartbeat interval=60, Discovery interval =5, Session Ack timeout=10
 Neighbor activity timeout=0, Neighbor Down ACK timeout=10

Router#show run int g0/0/1
Building configuration...

Current configuration : 245 bytes
!
interface GigabitEthernet0/0/1
 ip address 14.0.0.3 255.255.255.0
 ip dlep set peer-heartbeat-interval 60
 ip dlep vtemplate 2 port 11117 tcp port 11118 client ip 14.0.0.6 port 859
 negotiation auto
 ipv6 address 1111::1/120
 ipv6 enable
end
Step 3: Verify that the configuration on the radio (client) matches the configuration on the router (server) and that the router can reach the radio.
Router#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.199.184.2            9   0013.5f22.0b4a  ARPA   GigabitEthernet0/0/0
Internet  10.199.184.3            8   0018.7414.4e80  ARPA   GigabitEthernet0/0/0
Internet  10.199.184.19           -   a453.0e94.f638  ARPA   GigabitEthernet0/0/0
Internet  14.0.0.2                4   000c.297a.6b3d  ARPA   GigabitEthernet0/0/1
Internet  14.0.0.3                -   a453.0e94.f639  ARPA   GigabitEthernet0/0/1
Internet  14.0.0.6                0   Incomplete      ARPA   

Router#ping 14.0.0.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 14.0.0.6, timeout is 2 seconds:
...
Success rate is 0 percent (0/3)
Step 4: The client ’14.0.0.6’ cannot be pinged. A quick check of the radio configuration revealed that the client IP address was actually 14.0.0.2.
Router#show run int g0/0/1
Building configuration...

Current configuration : 245 bytes
!
interface GigabitEthernet0/0/1
 ip address 14.0.0.3 255.255.255.0
 ip dlep set peer-heartbeat-interval 60
 ip dlep vtemplate 2 port 11117 tcp port 11118 client ip 14.0.0.6 port 859
 negotiation auto
 ipv6 address 1111::1/120
 ipv6 enable
end
Step 5: Correct the client IP address.
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int g0/0/1
Router(config-if)#no ip dlep vtemplate 2 port 11117 tcp port 11118 client ip 14.0.0.6 port 859
Router(config-if)# ip dlep set peer-heartbeat-interval 60
Router(config-if)#ip dlep vtemplate 2 port 11117 tcp port 11118 client ip 14.0.0.6 port 859
Router(config-if)#^Z
Router#
*Feb 18 19:43:48.951: %SYS-5-CONFIG_I: Configured from console by console
Step 6: Verify the fix.
Router#show dlep counters
DLEP Counters for GigabitEthernet0/0/1

Last Clear Time = 

DLEP Version = RFC 8175
DLEP Server IP=14.0.0.3:11117
DLEPv5 TCP Port = 11118

Peer Counters:
 RX Peer Discovery     0      TX Peer Offer             0     
 RX Peer Offer         0      TX Peer Discovery         0     
 RX Peer Init          0      TX Peer Init Ack          0     
 RX Peer Init Ack      1      TX Peer Init              1     
 RX Heartbeat          0      TX Heartbeat              0     
 RX Peer Terminate     0      TX Peer Terminate Ack     0     
 RX Peer Terminate Ack 0      TX Peer Terminate         0     

Neighbor Counters:
 RX Neighbor Up        0      TX Neighbor Up Ack        0     
 RX Metric             0     
 RX Neighbor Down      0      TX Neighbor Down Ack      0     
 RX Neighbor Down Ack  0      TX Neighbor Down          0     

Exception Counters:
 RX Invalid Message    0      RX Unknown Message        0     
 Pre-Existing Neighbor 0      Neighbor Resource Error   0     
 Neighbor Not Found    0      Neighbor Msg Peer Not Up  0     

Timer Counters:
 Peer Heartbeat Timer         0     
 Peer Terminate Ack Timer     0     
 Neighbor Terminate Ack Timer 0     
 Neighbor Activity Timer      0     
 Radio Connect Timer          1     

Single Timer Wheel "Manet Infra Wheel"
  Granularity      = 250 msec
  Wheel size       = 4096
  Spoke index      = 1710
  Tick count       = 9902
  Flags            = 0x00
  Active timers    = 1
  High water mark  = 1
  Started timers   = 95
  Restarted timers = 4
  Cancelled timers = 4
  Expired timers   = 86
  Long timers      = 0
  Long timer revs  = 0
  Timer suspends   = 0

Router#
Router#show dlep clients 

DLEP Clients for all interfaces:

DLEP Clients for Interface GigabitEthernet0/0/1
DLEP Server IP=14.0.0.3:11117 Sock=0


DLEP Client IP=14.0.0.2:859 TCP Socket fd=1
 Peer ID=3, Virtual template=2
 Description: DLEP_RadioSIM2
 Peer Timers (all values in milliseconds):
  Heartbeat=60000, Dead Interval=120000, Terminate ACK=240000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps

Scenario 2: DLEP session keeps timing out

In this scenario, the router is running in discovery mode.

Step 1: The DLEP session keeps flapping as indicated by the output of show dlep client sometimes shows an active client and sometimes it does not. Also, the VMI and virtual-access interfaces keep going up and down.
Router#show dlep clients 

DLEP Clients for all interfaces:



DLEP Clients for Interface GigabitEthernet0/0/1
DLEP Server IP=14.0.0.3:55555 Sock=0


DLEP Client IP=14.0.0.2:859 TCP Socket fd=1
 Peer ID=13, Virtual template=2
 Description: DLEP_RadioSIM2
 Peer Timers (all values in milliseconds):
  Heartbeat=5000, Dead Interval=10000, Terminate ACK=20000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps
Router#

*Feb 18 20:01:32.577: %SYS-5-CONFIG_P: Configured programmatically by process Manet Infra Background from console as console
*Feb 18 20:01:32.580: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
*Feb 18 20:01:32.584: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
*Feb 18 20:01:32.625: %LINEPROTO-5-UPDOWN: Line protocol on Interface vmi2, changed state to up
Router#
Router#
*Feb 18 20:01:44.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface vmi2, changed state to down
*Feb 18 20:01:44.873: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
*Feb 18 20:01:44.878: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
*Feb 18 20:01:44.889: %SYS-5-CONFIG_P: Configured programmatically by process VTEMPLATE Background Mgr from console as console
Step 2: Turn on the following debug commands to troubleshoot:
debug dlep server
debug dlep timer detail
debug dlep client error
debug dlep client infra
debug dlep client packet detail
debug dlep client state
Step 3: The debug logs indicate that the router/server sent a peer discovery signal and received a peer offer in return.
*Feb 18 20:14:59.553: dlepv27_encoder_signal_packet_start DLEP_SIGNAL_PEER_DISCOVERY(1)
*Feb 18 20:14:59.553: dlepv27_encoder_signal_packet_end tlv block size=0 packet length=8
*Feb 18 20:15:04.609: dlepv27_encoder_signal_packet_start DLEP_SIGNAL_PEER_DISCOVERY(1)
*Feb 18 20:15:04.609: dlepv27_encoder_signal_packet_end tlv block size=0 packet length=8
*Feb 18 20:15:04.611: dlepv27_decoder_signal_packet DLEP_SIGNAL_PEER_OFFER(2) data length 30
*Feb 18 20:15:04.611: dlepv27_decoder_peer_type_tlv DLEP_TLV_PEER_TYPE   flag - 0
dlepv27_decoder_parse_tlv_block last tlv 4; current block_len 11; next tlv 2 
IPv4 Addr 14.0.0.2dlepv27_decoder_ipv4_conn_point_tlv DLEP_TLV_IPv4_CONN_POINT 
dlepv27_decoder_parse_tlv_block last tlv 2; current block_len 0; 
*Feb 18 20:15:04.611: 
*Feb 18 20:15:04.611: dlepv27_decoder_packet rc(RC_DLEP_OK-0) state 0 signal 1 packet_len 38
*Feb 18 20:15:09.648: %DLEP_MSG-4-CONNECT_ERROR: TCP connect to Radio 14.0.0.2 failed via Gi0/0/1. Error code: Resource temporarily unavailable 
Step 4: The router/server sends a session initialization message, and receives an acknowledgement in return. The acknowledgement also carries the attributes of the radio/client. An examination of those attributes reveals that the heartbeat interval on the radio is set to 60 seconds.
*Feb 18 20:15:09.648: dlepv27_encoder_msg_packet_start DLEP_MSG_SESSION_INITIALIZATION(1)
*Feb 18 20:15:09.648: dlepv27_encoder_msg_packet_end tlv block size=13 packet length=17
*Feb 18 20:15:09.649:   Adding Peer for address 14.0.0.2(859), peer_id=22
*Feb 18 20:15:09.649: MANET_Infra: insert s=FFFF771137A8, type=2 (client insert)
*Feb 18 20:15:09.650: MANET Infra: Insert=FFFF745209B0 successful (client insert)
*Feb 18 20:15:09.650: MANET_Infra: insert s=FFFF771137A8, type=1 (client insert)
*Feb 18 20:15:09.650: MANET Infra: Insert=FFFF64C3CEE8 successful (client insert)
*Feb 18 20:15:09.650:  -0 Allocated peer context at 0xFFFF771137A8
*Feb 18 20:15:09.650: dlepv27_decoder_msg_packet DLEP_MSG_SESSION_INITIALIZATION_ACK(2) data length 132 
dlepv27_decoder_status_tlv DLEP_TLV_STATUS  status_code=0 desc ()
dlepv27_decoder_parse_tlv_block last tlv 1; current block_len 127; next tlv 4 

*Feb 18 20:15:09.650: dlepv27_decoder_peer_type_tlv DLEP_TLV_PEER_TYPE   flag - 0
dlepv27_decoder_parse_tlv_block last tlv 4; current block_len 108; next tlv 5 
dlepv27_decoder_heartbeat_interval_tlv DLEP_TLV_HEARTBEAT_INTERVAL  heartbeat=60000 
dlepv27_decoder_parse_tlv_block last tlv 5; current block_len 100; next tlv 12 

*Feb 18 20:15:09.650: dlepv27_decoder_latency_data_rate_value DLEP_TLV_LINK_MDR_METRIC_RX  value=100000000 
dlepv27_decoder_parse_tlv_block last tlv 12; current block_len 88; next tlv 13 

*Feb 18 20:15:09.650: dlepv27_decoder_latency_data_rate_value DLEP_TLV_LINK_MDR_METRIC_TX  value=100000000 
dlepv27_decoder_parse_tlv_block last tlv 13; current block_len 76; next tlv 14 

*Feb 18 20:15:09.650: dlepv27_decoder_latency_data_rate_value DLEP_TLV_LINK_CDR_METRIC_RX  value=100000000 
dlepv27_decoder_parse_tlv_block last tlv 14; current block_len 64; next tlv 15 

*Feb 18 20:15:09.650: dlepv27_decoder_latency_data_rate_value DLEP_TLV_LINK_CDR_METRIC_TX  value=100000000 
dlepv27_decoder_parse_tlv_block last tlv 15; current block_len 52; next tlv 16 

*Feb 18 20:15:09.650: dlepv27_decoder_latency_data_rate_value DLEP_TLV_LINK_LATENCY_METRIC  value=250 
dlepv27_decoder_parse_tlv_block last tlv 16; current block_len 40; next tlv 18 
dlepv27_decoder_rlq_resource_value DLEP_TLV_LINK_RLQ_METRIC_RX  value=100 
dlepv27_decoder_parse_tlv_block last tlv 18; current block_len 35; next tlv 19 
dlepv27_decoder_rlq_resource_value DLEP_TLV_LINK_RLQ_METRIC_TX  value=100 
dlepv27_decoder_parse_tlv_block last tlv 19; current block_len 30; next tlv 17 
dlepv27_decoder_rlq_resource_value DLEP_TLV_LINK_RESOURCES  value=100 
dlepv27_decoder_parse_tlv_block last tlv 17; current block_len 25; next tlv 20 
dlepv27_decoder_mtu_tlv DLEP_TLV_LINK_MTU  mtu=100 
dlepv27_decoder_parse_tlv_block last tlv 20; current block_len 19; next tlv 8 
IPv4 Addr 14.0.0.2dlepv27_decoder_ipv4_address_tlv DLEP_TLV_IPV4_ADDRESS  operation=1 
dlepv27_decoder_parse_tlv_block last tlv 8; current block_len 10; next tlv 10 
IPv4 Subnet Addr 255.255.255.0dlepv27_decoder_ipv4_address_subnet_tlv DLEP_TLV_IPV4_ATTACHED_SUBNET  operation=1 mask=24 
dlepv27_decoder_parse_tlv_block last tlv 10; current block_len 0; 
*Feb 18 20:15:09.651: 
*Feb 18 20:15:09.651: dlepv27_decoder_packet rc(RC_DLEP_OK-0) state 1 signal 0 packet_len 136
Router#
Step 5: The router appears to be sending heartbeats 5 seconds apart:
*Feb 18 20:15:14.569: dlepv27_decoder_msg_packet DLEP_MSG_PEER_HEARTBEAT(16) data length 0 

*Feb 18 20:15:14.569:  -curr_state Dlep In-Session State normalized_event=Dlep Peer Heartbeat Event  p2peer=0xFFFF771137A8  peer_id=22  p2neighbor=0x0
*Feb 18 20:15:14.569: dlepv27_decoder_packet rc(RC_DLEP_OK-0) state 2 signal 0 packet_len 4
Router#
*Feb 18 20:15:19.569: dlepv27_decoder_msg_packet DLEP_MSG_PEER_HEARTBEAT(16) data length 0 

*Feb 18 20:15:19.569:  -curr_state Dlep In-Session State normalized_event=Dlep Peer Heartbeat Event  p2peer=0xFFFF771137A8  peer_id=22  p2neighbor=0x0
*Feb 18 20:15:19.569: dlepv27_decoder_packet rc(RC_DLEP_OK-0) state 2 signal 0 packet_len 4
Router#
Step6: The router is terminating the session, and receiving an acknowledgement of the same:
*Feb 18 20:15:24.569: dlepv27_decoder_msg_packet DLEP_MSG_SESSION_TERM(5) data length 5 
dlepv27_decoder_status_tlv DLEP_TLV_STATUS  status_code=0 desc ()
dlepv27_decoder_parse_tlv_block last tlv 1; current block_len 0; 
*Feb 18 20:15:24.569: 
*Feb 18 20:15:24.569:  -curr_state Dlep In-Session State normalized_event=Dlep Peer Term Event  p2peer=0xFFFF771137A8  peer_id=22  p2neighbor=0x0
*Feb 18 20:15:24.569:  -curr_state Dlep Terminating State normalized_event=Dlep Peer Term ACK Event  p2peer=0xFFFF771137A8  peer_id=22  p2neighbor=0x0
*Feb 18 20:15:24.569: dlepv27_encoder_msg_packet_start DLEP_MSG_SESSION_TERM_ACK(6)
*Feb 18 20:15:24.569: dlepv27_encoder_msg_packet_end tlv block size=12 packet length=16
*Feb 18 20:15:24.570:  -curr_state Dlep Session Reset State normalized_event=Dlep Peer sessoin reset Event  p2peer=0xFFFF771137A8  peer_id=22  p2neighbor=0x0
*Feb 18 20:15:24.570:  -0 Restart all peers on IDB GigabitEthernet0/0/1
*Feb 18 20:15:24.570: dlepv27_decoder_packet rc(RC_DLEP_OK-0) state 2 signal 0 packet_len 9
Step 7: An examination of the DLEP config reveals that the heartbeat on the router is set to 5 seconds:
Router#show dlep config 
DLEP Configuration for GigabitEthernet0/0/1

DLEP Peer Description - 
DLEP Version = RFC 8175
DLEP Server IP=14.0.0.3:55555
DLEPv27 TCP Port = 55556
 Virtual template=2
 Timers (all values are in seconds):
 Missed heartbeat threshold=2, Peer Terminate ACK timeout=10
 Dlepv27 Applicable configs(in seconds):
 Heartbeat interval=5, Discovery interval =5, Session Ack timeout=10
 Neighbor activity timeout=0, Neighbor Down ACK timeout=10
Step 8: Change the heartbeat to 60 seconds:
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int g0/0/1
Router(config-if)#no ip dlep
Router(config-if)#no ip dlep vtemplate
Router(config-if)#no ip dlep vtemplate 2
Router(config-if)#ip dlep set peer-heartbeat-interval 60
Router(config-if)# ip dlep vtemplate 2
Router(config-if)#^Z
Step 9: Verify the change fixed the problem:
Router#show dlep clients

DLEP Clients for all interfaces:


DLEP Clients for Interface GigabitEthernet0/0/1
DLEP Server IP=14.0.0.3:55555 Sock=0


DLEP Client IP=14.0.0.2:859 TCP Socket fd=1
 Peer ID=51, Virtual template=2
 Description: DLEP_RadioSIM2
 Peer Timers (all values in milliseconds):
  Heartbeat=60000, Dead Interval=120000, Terminate ACK=240000
 Neighbor Timers (all values in seconds):
  Activity timeout=0, Neighbor Down ACK=10

 Supported Metrics:
  Link RLQ RX Metric : 100
  Link RLQ TX Metric : 100
  Link Resources Metric : 100
  Link MTU Metric : 100
  Link Latency Metric : 250 microseconds
  Link CDR RX Metric : 100000000 bps
  Link CDR TX Metric : 100000000 bps
  Link MDR RX Metric : 100000000 bps
  Link MDR TX Metric : 100000000 bps
Router#
*Feb 18 20:38:03.708: %SYS-5-CONFIG_P: Configured programmatically by process Manet Infra Background from console as console
*Feb 18 20:38:03.712: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
*Feb 18 20:38:03.716: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
*Feb 18 20:38:03.722: %LINEPROTO-5-UPDOWN: Line protocol on Interface vmi2, changed state to up

Additional Debug Commands


Note


It is recommended to use debug commands only under the guidance of Cisco TAC.

The following commands are available.

DLEP

debug dlep server detail
debug dlep timer detail
debug dlep neighbor error
debug dlep neighbor infrastructure detail
debug dlep neighbor infrastructure error
debug dlep neighbor metrics
debug dlep neighbor state
debug dlep neighbor all
debug dlep client error
debug dlep client infrastructure
debug dlep client packet dump
debug dlep client packet detail
debug dlep client state

VMI

debug vmi bma
debug vmi packet
debug vmi error
debug vmi multicast 
debug vmi neighbor
debug vmi registries 

Virtual Template

debug vtemplate cloning
debug vtemplate error
debug vtemplate  event
debug vtemplate subinterface

PPPOE

debug pppoe errors
debug pppoe events
debug pppoe packets
debug pppoe data

SSS

debug sss error
debug sss event