Prerequisites for BGP PA Output Interface Accounting
Before using the BGP Policy Accounting Output Interface Accounting feature, you must enable BGP and Cisco Express Forwarding or distributed CEF on the router.
The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
Border Gateway Protocol (BGP) policy accounting (PA) measures and classifies IP traffic that is sent to, or received from, different peers. Policy accounting was previously available on an input interface only. The BGP Policy Accounting Output Interface Accounting feature introduces several extensions to enable BGP PA on an output interface and to include accounting based on a source address for both input and output traffic on an interface. Counters based on parameters such as community list, autonomous system number, or autonomous system path are assigned to identify the IP traffic.
Before using the BGP Policy Accounting Output Interface Accounting feature, you must enable BGP and Cisco Express Forwarding or distributed CEF on the router.
Information About BGP PA Output Interface Accounting
Policy accounting using BGP measures and classifies IP traffic that is sent to, or received from, different peers. Originally, BGP PA was available on an input interface only. BGP PA output interface accounting introduces several extensions to enable BGP PA on an output interface and to include accounting based on a source address for both input and output traffic on an interface. Counters based on parameters such as community list, autonomous system number, or autonomous system path are assigned to identify the IP traffic.
Using the BGP table-map command, prefixes added to the routing table are classified by BGP attribute, autonomous system number, or autonomous system path. Packet and byte counters are incremented per input or output interface. A Cisco policy-based classifier maps the traffic into one of eight possible buckets that represent different traffic classes.
Using BGP PA, you can account for traffic according to its origin or the route it traverses. Service providers (SPs) can identify and account for all traffic by customer and can bill accordingly. In the figure below, BGP PA can be implemented in Router A to measure packet and byte volumes in autonomous system buckets. Customers are billed appropriately for traffic that is routed from a domestic, international, or satellite source.
BGP policy accounting using autonomous system numbers can be used to improve the design of network circuit peering and transit agreements between Internet service providers (ISPs).
BGP policy accounting classifies IP traffic by autonomous system number, autonomous system path, or community list string, and increments packet and byte counters. Policy accounting can also be based on the source address. Service providers can account for traffic and apply billing according to the origin of the traffic or the route that specific traffic traverses.
Implementing BGP policy accounting on an edge router can highlight potential design improvements for peering and transit agreements.
How to Configure BGP PA Output Interface Accounting
The first task in configuring BGP PA is to specify the criteria that must be matched. Community lists, autonomous system paths, or autonomous system numbers are examples of BGP attributes that can be specified and subsequently matched using a route map. Perform this task to specify the BGP attribute to use for BGP PA and to create the match criteria in a route map.
Command or Action | Purpose | |
---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode.
|
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
Step 3 |
ip community-list {standard-list-number | expanded-list-number [regular-expression ] | {standard | expanded } community-list-name } {permit | deny } {community-number | regular-expression } Example:
|
Creates a community list for BGP and controls access to it.
|
Step 4 |
route-map map-name [permit | deny ] [sequence-number ] Example:
|
Enters route-map configuration mode and defines the conditions for policy routing.
|
Step 5 |
match community-list community-list-number [exact ] Example:
|
Matches a BGP community. |
Step 6 |
set traffic-index bucket-number Example:
|
Indicates where to output packets that pass a match clause of a route map for BGP policy accounting. |
Step 7 |
exit Example:
|
Exits route-map configuration mode and returns to global configuration mode. |
After a route map has been defined to specify match criteria, you must configure a way to classify the IP traffic before enabling BGP policy accounting.
Using the table-map command, BGP classifies each prefix that it adds to the routing table according to the match criteria. When the bgp-policy accounting command is configured on an interface, BGP policy accounting is enabled.
Perform this task to classify the IP traffic and enable BGP policy accounting.
Command or Action | Purpose | |
---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode.
|
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
Step 3 |
router bgp as-number Example:
|
Configures a BGP routing process and enters router configuration mode for the specified routing process.
|
Step 4 |
table-map route-map-name Example:
|
Classifies BGP prefixes entered in the routing table. |
Step 5 |
network network-number [mask network-mask ] Example:
|
Specifies a network to be advertised by the BGP routing process. |
Step 6 |
neighbor ip-address remote-as as-number Example:
|
Specifies a BGP peer by adding an entry to the BGP routing table. |
Step 7 |
exit Example:
|
Exits router configuration mode and returns to global configuration mode. |
Step 8 |
interface type number Example:
|
Specifies the interface type and number and enters interface configuration mode.
|
Step 9 |
ip address ip-address mask Example:
|
Configures the interface with an IP address. |
Step 10 |
bgp-policy accounting [input | output ] [source ] Example:
|
Enables BGP policy accounting for the interface.
|
Step 11 |
exit Example:
|
Exits interface configuration mode and returns to global configuration mode. |
Perform this task to verify that BGP policy accounting is operating.
Step 1 |
show ip cef [network [mask ]] [detail ] Enter the show ip cef command with the detail keyword to learn which accounting bucket is assigned to a specified prefix. In this example, the output is displayed for the prefix 192.168.5.0. It shows that accounting bucket number 4 (traffic_index 4) is assigned to this prefix. Example:
|
Step 2 |
show ip bgp [network ] [network-mask ] [longer-prefixes ] Enter the show ip bgp command for the same prefix used in Step 1--192.168.5.0--to learn which community is assigned to this prefix. In this example, the output is displayed for the prefix 192.168.5.0. It shows that the community of 100:197 is assigned to this prefix. Example:
|
Step 3 |
show cef interface [type number ] policy-statistics [input | output ] Displays the per-interface traffic statistics. In this example, the output shows the number of packets and bytes that have been assigned to each accounting bucket: Example:
|
Step 4 |
show cef interface [type number ] [statistics ] [detail ] Displays the state of BGP policy accounting on a specified interface. In this example, the output shows that BGP policy accounting has been configured to be based on input traffic at Fast Ethernet interface 1/0/0: Example:
|
Configuration Examples for BGP PA Output Interface Accounting
In the following example, BGP communities are specified in community lists, and a route map named set_bucket is configured to match each of the community lists to a specific accounting bucket using the set traffic-index command:
ip community-list 30 permit 100:190
ip community-list 40 permit 100:198
ip community-list 50 permit 100:197
ip community-list 60 permit 100:296
!
route-map set_bucket permit 10
match community-list 30
set traffic-index 2
!
route-map set_bucket permit 20
match community-list 40
set traffic-index 3
!
route-map set_bucket permit 30
match community-list 50
set traffic-index 4
!
route-map set_bucket permit 40
match community-list 60
set traffic-index 5
In the following example, BGP policy accounting is enabled on POS interface 2/0/0. The policy accounting criteria is based on the source address of the input traffic, and the table-map command is used to modify the bucket number when the IP routing table is updated with routes learned from BGP.
router bgp 65000
table-map set_bucket
network 10.15.1.0 mask 255.255.255.0
neighbor 10.14.1.1 remote-as 65100
!
ip classless
ip bgp-community new-format
!
interface POS2/0/0
ip address 10.15.1.2 255.255.255.0
bgp-policy accounting input source
no keepalive
crc 32
clock source internal
The following sections provide references related to the BGP policy accounting output interface accounting feature.
Related Topic |
Document Title |
---|---|
BGP commands: complete command syntax, command mode, defaults, usage guidelines, and examples |
Cisco IOS IP Routing: BGP Command Reference |
Switching commands: complete command syntax, command mode, defaults, usage guidelines, and examples |
Cisco IOS IP Switching Command Reference |
Cisco IOS master command list, all releases |
Standards |
Title |
---|---|
No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature. |
-- |
MIBs |
MIBs Link |
---|---|
CISCO-BGP-POLICY-ACCOUNTING-MIB |
To locate and download MIBs for selected platforms, Cisco IOS XE software releases, and feature sets, use Cisco MIB Locator found at the following URL: |
RFCs |
Title |
---|---|
No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature. |
-- |
Description |
Link |
---|---|
The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. |
The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.
Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.
Feature Name |
Releases |
Feature Information |
---|---|---|
BGP Policy Accounting |
Cisco IOS XE Release 2.1 |
BGP policy accounting measures and classifies IP traffic that is sent to, or received from, different peers. This feature was introduced on the Cisco ASR 1000 Series Aggregation Services Routers. |
BGP Policy Accounting Output Interface Accounting |
Cisco IOS XE Release 2.1 |
This feature introduces several extensions to enable BGP PA on an output interface and to include accounting based on a source address for both input and output traffic on an interface. This feature was introduced on the Cisco ASR 1000 Series Routers. The following commands were introduced or modified for this feature: bgp-policy , set traffic-index , show cef interface , show cef interface policy-statistics |
SNMP Support for BGP Policy Accounting |
Cisco IOS XE Release 2.1 |
The CISCO-BGP-POLICY-ACCOUNTING-MIB was introduced. This feature was introduced on the Cisco ASR 1000 Series Routers. |
AS --autonomous system. An IP term to describe a routing domain that has its own independent routing policy and is administered by a single authority.
BGP --Border Gateway Protocol. Interdomain routing protocol that exchanges reachability information with other BGP systems.
CEF --Cisco Express Forwarding.
dCEF --distributed Cisco Express Forwarding.