Prerequisites for BGP Event-Based VPN Import
Cisco Express Forwarding or distributed Cisco Express Forwarding must be enabled on all participating routers.
The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
The BGP Event-Based VPN Import feature introduces a modification to the existing Border Gateway Protocol (BGP) path import process. The enhanced BGP path import is driven by events; when a BGP path changes, all of its imported copies are updated as soon as processing is available. Convergence times are significantly reduced because there is no longer any delay in the propagation of routes due to the software waiting for a periodic scanner time interval before processing the updates. To implement the new processing, new command-line interface (CLI) commands are introduced.
Cisco Express Forwarding or distributed Cisco Express Forwarding must be enabled on all participating routers.
Information About BGP Event-Based VPN Import
The BGP Event-Based VPN Import feature introduces a modification to the existing BGP path import process. BGP Virtual Private Network (VPN) import provides importing functionality for BGP paths where BGP paths are imported from the BGP VPN table into a BGP virtual routing and forwarding (VRF) topology. In the existing path import process, when path updates occur, the import updates are processed during the next scan time which is a configurable interval of 5 to 15 seconds. The scan time adds a delay in the propagation of routes. The enhanced BGP path import is driven by events; when a BGP path changes, all of its imported copies are updated as soon as processing is available.
Using the BGP Event-Based VPN Import feature, convergence times are significantly reduced because provider edge (PE) routers can propagate VPN paths to customer edge (CE) routers without the scan time delay. Configuration changes such as adding imported route-targets to a VRF are not processed immediately, and are still handled during the 60-second periodic scanner pass.
Event-based VPN import introduces three path selection policies:
All—Import all available paths from the exporting net that match any route target (RT) associated with the importing VRF instance.
Best path—Import the best available path that matches the RT of the VRF instance. If the best path in the exporting net does not match the RT of the VRF instance, a best available path that matches the RT of the VRF instance is imported.
Multipath—Import the best path and all paths marked as multipaths that match the RT of the VRF instance. If there are no best path or multipath matches, then the best available path is selected.
Multipath and best path options can be restricted using an optional keyword to ensure that the selection is made only on the configured option. If the strict keyword is configured in the import path selection command, the software disables the fall back safety option of choosing the best available path. If no paths appropriate to the configured option (best path or multipath) in the exporting net match the RT of the VRF instance, then no paths are imported. This behavior matches the behavior of the software before the BGP Event-Based VPN Import feature was introduced.
When the restriction is not set, paths that are imported as the best available path are tagged. In show command output these paths are identified with the wording, “imported safety path.”
The paths existing in an exporting net that are considered for import into a VRF instance may have been received from another peer router and were not subject to the VPN importing rules. These paths may contain the same route-distinguisher (RD) information because the RD information is local to a router, but some of these paths do not match the RT of the importing VRF instance and are marked as “not-in-vrf” in the show command output. Any path that is marked as “not-in-vrf” is not considered as a best path because paths not in the VRF appear less attractive than paths in the VRF.
To control the memory utilization, a maximum limit of the number of paths imported from an exporting net can be specified per importing net. When a selection is made of paths to be imported from one or more exporting net, the first selection priority is a best path, the next selection priority is for multipaths, and the lowest selection priority is for nonmultipaths.
How to Configure BGP Event-Based VPN Import
Perform this task to configure a multiprotocol VRF that allows you to share route-target policies (import and export) between IPv4 and IPv6 or to configure separate route-target policies for IPv4 and IPv6 VPNs. In this task, only the IPv4 address family is configured, but we recommend using the multiprotocol VRF configuration for all new VRF configurations.
Note |
This task is not specific to the BGP Event-Based VPN Import feature. |
Command or Action | Purpose | |
---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode.
|
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
Step 3 |
vrf definition vrf-name Example:
|
Configures a VRF routing table and enters VRF configuration mode.
|
Step 4 |
rd route-distinguisher Example:
|
Creates routing and forwarding tables and specifies the default route distinguisher for a VPN.
|
Step 5 |
route-target {import | export | both } route-target-ext-community Example:
|
Creates a route target extended community for a VRF.
|
Step 6 |
address-family ipv4 [unicast ] Example:
|
Specifies the IPv4 address family and enters VRF address family configuration mode.
|
Step 7 |
exit-address-family Example:
|
Exits VRF address family configuration mode and returns to VRF configuration mode. |
Step 8 |
exit Example:
|
Exits VRF configuration mode and enters global configuration mode. |
Step 9 |
interface type number Example:
|
Enters interface configuration mode. |
Step 10 |
vrf forwarding vrf-name Example:
|
Associates a VRF instance with the interface configured in Step 9.
|
Step 11 |
ip address ip-address mask Example:
|
Configures an IP address for the interface. |
Step 12 |
no shutdown Example:
|
Restarts a disabled interface. |
Step 13 |
exit Example:
|
Exits interface configuration mode and enters global configuration mode. |
Step 14 |
Repeat Step 3 through Step 13 to bind other VRF instances with an interface. |
-- |
Step 15 |
end Example:
|
Exits global configuration mode and returns to privileged EXEC mode. |
Perform this task to reduce convergence times when BGP paths change by configuring event-based processing for importing BGP paths into a VRF table. Two new CLI commands allow the configuration of a maximum number of import paths per importing net and the configuration of a path selection policy.
This task assumes that you have previously configured the VRF to be used with the VRF address family syntax. To configure a VRF, see the “Configuring a Multiprotocol VRF” section earlier in this module.
Complete BGP neighbor configuration is also assumed. For an example configuration, see the “Example: Configuring Event-Based VPN Import Processing for BGP Paths” section in this module.
Command or Action | Purpose | |
---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode.
|
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
Step 3 |
router bgp autonomous-system-number Example:
|
Enters router configuration mode for the specified routing process. |
Step 4 |
address-family ipv4 vrf vrf-name Example:
|
Specifies the IPv4 address family and enters address family configuration mode.
|
Step 5 |
import path selection {all | bestpath [strict ] | multipath [strict ]} Example:
|
Specifies the BGP path selection policy for importing routes into a VRF table.
|
Step 6 |
import path limit number-of-import-paths Example:
|
Specifies, per importing net, a maximum number of BGP paths that can be imported from an exporting net. |
Step 7 |
end Example:
|
Exits address family configuration mode and returns to privileged EXEC mode. |
Perform the steps in this task as required to monitor and troubleshoot the BGP event-based VPN import processing.
Only partial command syntax for the show commands used in this task is displayed. For more details, see the Cisco IOS IP Routing: BGP Command Reference.
Step 1 |
enable Enables privileged EXEC mode. Enter your password if prompted. Example:
|
||
Step 2 |
show ip bgp vpnv4 {all | rd route-distinguisher | vrf vrf-name } [network-address [mask ]] In this example output, a safe import path selection policy is in effect because the strict keyword is not configured using the import path selection command. When a path is imported as the best available path (when the bestpath or multipaths are not eligible for import), the path is marked with "imported safety path," as shown in the output. Example:
The paths existing in an exporting net that are considered for import into a VRF instance may have been received from another peer router and were not subject to the VPN importing rules. These paths may contain the same route-distinguisher (RD) information because the RD information is local to a router, but some of these paths do not match the RT of the importing VRF instance and are marked as "not-in-vrf" in the show command output. In the following example output, a path was received from another peer router and was not subject to the VPN importing rules. This path, 10.0.101.2, was added to the VPNv4 table and associated with the vrf-A net because it contains a match of the RD information although the RD information was from the original router. This path is not, however, an RT match for vrf-A and is marked as "not-in-vrf." Note that on the net for vrf-A, this path is not the bestpath because any paths that are not in the VRF appear less attractive than paths in the VRF. Example:
|
||
Step 3 |
show ip route [vrf vrf-name ] [ip-address [mask ]] In this example output, information about the routing table for VRF vrf-A is displayed: Example:
|
||
Step 4 |
debug ip bgp vpnv4 unicast import {events | updates [access-list ]} Use this command to display debugging information related to the importing of BGP paths into a VRF instance table. The actual output depends on the commands that are subsequently entered.
Example:
|
Configuration Examples for BGP Event-Based VPN Import
In this example, a VRF (vrf-A) is configured and VRF forwarding is applied to Fast Ethernet interface 1/1. In address family mode, the import path selection is set to all and the number of import paths is set to 3. Two BGP neighbors are configured under the IPv4 address family and activated under the VPNv4 address family.
vrf definition vrf-A
rd 45000:1
route-target import 45000:100
address-family ipv4
exit-address-family
!
interface FastEthernet1/1
no ip address
vrf forwarding vrf-A
ip address 10.4.8.149 255.255.255.0
no shut
exit
!
router bgp 45000
network 172.17.1.0 mask 255.255.255.0
neighbor 192.168.1.2 remote-as 40000
neighbor 192.168.3.2 remote-as 50000
address-family ipv4 vrf vrf-A
import path selection all
import path limit 3
exit-address-family
address-family vpnv4
neighbor 192.168.1.2 activate
neighbor 192.168.3.2 activate
end
Related Topic |
Document Title |
---|---|
Cisco IOS commands |
|
BGP commands |
Standard |
Title |
---|---|
No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature. |
— |
MIB |
MIBs Link |
---|---|
No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature. |
To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL: |
RFC |
Title |
---|---|
No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature. |
— |
Description |
Link |
---|---|
The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password. |
The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.
Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.
Feature Name |
Releases |
Feature Information |
---|---|---|
BGP Event-Based VPN Import |
Cisco IOS XE Release 2.6 Cisco IOS XE Release 3.3SG |
The BGP Event-Based VPN Import feature introduces a modification to the existing Border Gateway Protocol (BGP) path import process. The enhanced BGP path import is driven by events; when a BGP path changes, all of its imported copies are updated as soon as processing is available. Convergence times are significantly reduced because there is no longer any delay in the propagation of routes due to the software waiting for a periodic scanner time interval before processing the updates. To implement the new processing, new command-line interface (CLI) commands are introduced. The following commands were introduced or modified:
|