Appendix C - Cisco IE Switches configuration

OSPF Configuration on Industrial Ethernet Switch

vrf definition employee
rd 11:11
!
address-family ipv4
route-target export 11:11
route-target import 11:11
exit-address-family
!
vrf definition video
rd 10:10
!
address-family ipv4
route-target export 10:10
route-target import 10:10
exit-address-family
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
no spanning-tree vlan 1,16-17,116,130-250,253-255,1006
interface GigabitEthernet1/1
switchport mode trunk
load-interval 30
!
!
interface Vlan15
ip address 10.12.15.1 255.255.255.252
ip ospf network point-to-point
!
interface Vlan16
ip address 10.12.16.1 255.255.255.252
ip ospf network point-to-point
!
interface Vlan17
ip address 10.12.17.1 255.255.255.0
!
interface Vlan115
vrf forwarding video
ip address 10.12.115.1 255.255.255.252
ip ospf network point-to-point
!
interface Vlan116
vrf forwarding video
ip address 10.12.116.1 255.255.255.252
ip ospf network point-to-point
!
interface Vlan117
vrf forwarding video
ip address 10.12.117.1 255.255.255.0
!
interface Vlan215
vrf forwarding employee
ip address 10.12.215.1 255.255.255.252
ip ospf network point-to-point
!
interface Vlan216
vrf forwarding employee
ip address 10.12.216.1 255.255.255.252
ip ospf network point-to-point
!
interface Vlan217
vrf forwarding employee
ip address 10.12.217.1 255.255.255.0
!
router ospf 1
router-id 10.12.16.1
auto-cost reference-bandwidth 100000
network 10.0.0.0 0.255.255.255 area 1
!
router ospf 10 vrf video
router-id 10.12.115.1
auto-cost reference-bandwidth 100000
capability vrf-lite
network 10.12.115.0 0.0.0.255 area 10
network 10.12.116.0 0.0.0.255 area 10
network 10.12.117.0 0.0.0.255 area 10
!
router ospf 11 vrf employee
router-id 10.12.217.1
auto-cost reference-bandwidth 100000
capability vrf-lite
network 10.12.215.0 0.0.0.255 area 11
network 10.12.216.0 0.0.0.255 area 11
network 10.12.217.0 0.0.0.255 area 11
 

Configuration on Industrial Ethernet Switch Connected to Routers Running VRRP

no spanning-tree vlan 1,16,116,130-250,1006
interface GigabitEthernet1/1
switchport trunk allowed vlan 2-300
switchport mode trunk
!
interface GigabitEthernet1/3
switchport trunk allowed vlan 2-300
switchport mode trunk
!