The following configurations enabled on the borderPE switch establish a Layer-3 link along with the MPLS/LDP configuration
between the borderPE switch and the WAN ASBR. After configurations on the borderPE switch and the WAN ASBR device, routes
are exchanged between the VXLAN fabric borderPE switch and the MPLS WAN ASBR.
Important |
Ensure that you follow these implementation pointers:
-
This document only contains Cisco Nexus 7000 Series borderPE switch related configurations. To complete Layer-3 DCI configurations,
you should also enable corresponding configurations on the WAN ASBR.
-
To forward traffic across the borderPE switch (from the VXLAN BGP EVPN fabric towards the WAN ASBR and the other way round),
the fabric forwarding switch-role border command should be mandatorily configured on the borderPE switch. Since the change of switch role requires a switch reload
(through write erase and reload commands), ensure that this command is included in the startup configuration. For the borderPE Layer-3 extension auto configuration
feature, use the fabric forwarding switch-role border dci-node command.
-
The physical interface connecting the VXLAN BGP EVPN fabric should be different from the IP/MPLS WAN facing interface. The
same physical Layer-3 interface or sub interface should not be used to connect the VXLAN BGP EVPN Fabric and the WAN Core.
-
For an F3 only VDC, the Layer-3 backup link that is used to protect the WAN facing interfaces from failure should not be the
peer link or SVI of the VLANs extended over the peer link. A separate Layer-2 interface with a dedicated VLAN/SVI, or a separate Layer-3 interface or sub interface should be used.
-
For an M3-F3 VDC, traffic received from the VXLAN BGP EVPN fabric should not be forwarded to a Layer-3 sub interface. VXLAN
terminated traffic can only be forwarded over a Layer-3 physical interface.
-
Host Mobility Manager (HMM) CLIs are removed with the no feature fab forwarding command even though the nv overlay evpn command is present.
The feature fabric forwarding command is not needed if nv overlay evpn is already configured.
|
On BorderPE1 switch, enable VXLAN BGP EVPN features
(config) #
install feature-set fabric
feature-set fabric
feature fabric forwarding
feature interface-vlan
feature ospf (OR feature isis)
feature nv overlay
feature bgp
feature vni
nv overlay evpn
install feature-set mpls
feature-set mpls
feature mpls l3vpn
feature mpls ldp
The VXLAN feature related configurations shown above are already enabled on all switches in the VXLAN BGP EVPN fabric. This
has been included here included for completeness only.
Note |
The install feature-set fabric command should only be used in the admin VDC. When using a VDC, ensure the VDC is of type F3 or M3, for EVPN. A sample configuration
is given below:
|
(config) #
vdc BorderPE1
limit-resource module-type f3
Configure the anycast gateway MAC address
(config) #
fabric forwarding anycast-gateway-mac 0202.0002.0002
On BorderPE1, configure a bridge domain and associate a Layer-3
network VNI
(config) #
fabric forwarding switch-role border
system bridge-domain 2500-3500
system fabric bridge-domain 2500-2999
vni 31000
bridge-domain 2500
member vni 31000
On BorderPE1, create a VRF and associate the previously
configured VNI to it. Then, enable importing and exporting of routes between
the VXLAN BGP EVPN fabric and the MPLS WAN side, and create the default routes
to be injected into the VXLAN fabric
(config) #
vrf context vni-31000
vni 31000
rd auto
address-family ipv4 unicast
route-target import 65551:1
route-target export 65551:1
route-target both auto
route-target both auto evpn
Type
exit and
configure IPv6 route import/export.
address-family ipv6 unicast
route-target import 65551:1
route-target export 65551:1
route-target both auto
route-target both auto evpn
65551:1 refers to the
import/export of WAN routes.
Within the VXLAN BGP EVPN fabric, NX-OS automatically assigns the correct route target. It is recommended that the commands
route-target both auto and route-target both auto evpn are used on the ToR/Leaf switches too.
Note |
The route target 65551:1 should be the same as the route target configured on the connected WAN ASBR since the importing/exporting of MPLS information
is based on this route target
|
By using route targets
as the glue, the BGP EVPN control plane (in the VXLAN fabric) and the BGP L3VPN
control plane (from the fabric to the WAN) are connected. Similarly, for a
tenant VRF, the same route target should be enabled on ToR/leaf switches and
the border leaf switch(es).
On BorderPE1, configure a bridge domain and BDI for the VRF
(config) #
interface BDI 2500
no shutdown
mtu 9192
vrf member vni-31000
no ip redirects
ip forward
ipv6 address use-link-local-only
ipv6 forward
no ipv6 redirects
After the above configuration, we ensure that a bridge domain interface is designated for Layer-3 traffic transportation.
Important |
The interface BDI configuration is not required to be configured manually, when the profile vrf-tenant-profile is configured. As soon the VRF
context is configured, NX-OS automatically calls the profile vrf-tenant-profile and applies appropriate configurations. vrf-tenant-profile
is always added when you deploy the BorderPE switch with POAP from DCNM. The resulting interface BDI configuration can be
verified with the show run inter bdi 2500 expand-port-profile command.
|
The vrf-tenant-profile
configuration is given below:
configure profile vrf-tenant-profile
vni $vrfSegmentId
bridge-domain $bridgeDomainId
member vni $vrfSegmentId
interface bdi $bridgeDomainId
vrf member $vrfName
ip forward
no ip redirects
ipv6 forward
ipv6 address use-link-local-only
no ipv6 redirects
mtu 9192
no shutdown
On BorderPE1, add the Layer-3 VRF VNI to the overlay
(config) #
interface nve 1
no shutdown
source-interface loopback 1
host-reachability protocol bgp
member vni 31000 associate-vrf
In the above
configuration, we ensure that the Layer-3 VNI is associated with the VXLAN
VTEP.
On BorderPE1, establish a multihop external BGP session to the
WAN ASBR and enable forwarding of L2VPN routes towards the WAN ASBR
(config) #
router bgp 65536
neighbor 209.165.200.225 remote-as 65551
update-source loopback 100 -> Optional
ebgp-multihop 10 -> Optional
address-family vpnv4 unicast
send-community both
import l2vpn evpn reoriginate
If the BGP session to
the WAN ASBR is on a directly connected interface, and the peering is done on
the interface address, then the
ebgp-multihop
and
update-source
commands are not required. Also, configure the VPNv6 address family as shown
below:
address-family vpnv6 unicast
send-community both
import l2vpn evpn reoriginate
Attention |
In the above configurations, the L2VPN EVPN information is being imported into the VPNv4/VPNv6 address families so that the
routes in the VXLAN BGP EVPN fabric can be sent over VPNv4/VPNv6 to the connected WAN ASBR. When the WAN ASBR sends routes
to the border leaf switch, the received VPNv4/VPNv6 routes need to be sent into the VXLAN BGP EVPN control plane. To achieve
that, the VPNv4/VPNv6 information (L3VPN routes) is imported into the L2VPN EVPN address family, as shown below.
|
Configure the BGP
EVPN neighbor within the fabric.
(config) #
router bgp 65536
neighbor 10.2.2.1 remote-as 65536
update-source loopback 0
address-family l2vpn evpn
send-community both
import vpn unicast reoriginate
On BorderPE1, create the
VRF under the BGP configuration to advertise the L2VPN EVPN address family
(routes) within the VRF
(config) #
router bgp 65536
vrf vni-31000
address-family ipv4 unicast
advertise l2vpn evpn
maximum-paths 2
label-allocation-mode per-vrf
exit
address-family ipv6 unicast
advertise l2vpn evpn
maximum-paths 2
label-allocation-mode per-vrf
Note |
Alternatively, you can enable a 0/0 default route origination in each tenant VRF (on the border leaf switch). The ToRs/leaf
switches will import the default route, resulting in a VRF default route towards the border leaf switch in the ToR switch
tenant VRFs.
|
Creation of default route
and route maps on the borderPE1 switch
Enable default route
origination in each VRF, for IP4 and IPv6 address families
(config) #
vrf context vni-31000
ip route 0.0.0.0/0 null 0 254
ipv6 route 0::/0 null 0 254
The ToR switches
will import this default route, resulting in a VRF default route for tenant VRF
vni-31000 on
the ToR switches.
Create a route-map to
ensure that the default route from the WAN ASBR is preferred over a default
route from other sources
(config) #
route-map PREFER-EXTERNAL-DEFAULT permit 100
set local-preference 50
Apply the route map to
tenant VRF vni-31000 address families (IP4 and IPv6 unicast)
(config) #
vrf vni-31000
address-family ipv4 unicast
network 0.0.0.0/0 evpn route-map PREFER-EXTERNAL-DEFAULT
exit
address-family ipv6 unicast
network 0.0.0.0/0 evpn route-map PREFER-EXTERNAL-DEFAULT
Restrict default routes
generated or learned on the BorderPE switch from being distributed to the
external WAN ASBR
(config) #
ip prefix-list default-route seq 5 permit 0.0.0.0/0 le 1
ipv6 prefix-list default-route-v6 seq 5 permit 0::0/0
route-map DENY-DEFAULT-ROUTE deny 10
match ip address prefix-list default-route
exit
route-map DENY-DEFAULT-ROUTE permit 1000
exit
route-map DENY-DEFAULT-ROUTE-v6 deny 100
match ipv6 address prefix-list default-route-v6
exit
route-map DENY-DEFAULT-ROUTE-v6 permit 1000
BGP specific default route
configurations
Restrict default routes
generated in the fabric from being distributed to external neighbors through
BGP
(config) #
router bgp 65536
neighbor 209.165.200.225 remote-as 65551
address-family vpnv4 unicast
route-map DENY-DEFAULT-ROUTE out
exit
address-family vpnv6 unicast
route-map DENY-DEFAULT-ROUTE-v6 out
After the above
configuration, we ensure that default routes will not be included in the VPNv4
and VPNv6 routes sent to the WAN ASBR.
Glossary
RD—Route Distinguisher
RT—Route Target
RR—BGP route reflector.
A route reflector reflects incoming routes to all other leaf switch nodes.
Typically, spine switches are configured as route reflectors.
BorderPE switch—A Cisco
Nexus 7000 Series switch with an F3 or M3 line card; acts as the collapsed
border leaf switch and Cisco Nexus 7000 Series data center edge switch. A
BorderPE switch includes the MPLS PE function. This is also referred to as a
one box solution.
A two box solution
comprises of two switches (A Cisco Nexus 5600 Series or 7000 Series border leaf
switch + a Cisco Nexus 7000 Series data center edge switch) to route IP frames
from an external network into the VXLAN BGP EVPN fabric