Configuring Any Transport over MPLS: Tunnel Selection

Restrictions for Any Transport over MPLS: Tunnel Selection

  • The preferred-path command is available only if the pseudowire encapsulation type is MPLS.

  • This feature is enabled when you exit from pseudowire submode.

  • The selected path should be a label switched path (LSP) destined to the peer PE router

  • The selected tunnel must be an MPLS TE tunnel.

  • If you select a tunnel, the tunnel tailend must be on the remote provider edge (PE) router.

  • If you specify an IP address, that address must be the IP address of the loopback interface on the remote PE router. The address must have a /32 mask. There must be an LSP destined to that selected address. The LSP need not be a TE tunnel.

Information About Any Transport over MPLS: Tunnel Selection

This feature allows you to specify the path that Any Transport over MPLS (AToM) traffic uses. You can specify either a Multiprotocol Label Switching (MPLS) Traffic Engineering tunnel or a destination IP address and Domain Name System (DNS) name. If the specified path is unreachable, you can specify that the virtual circuits (VCs) should use the default path, which is the path that MPLS Label Distribution Protocol (LDP) used for signaling. This option is enabled by default; you must explicitly disable it.

How to Configure Any Transport over MPLS: Tunnel Selection

The following section provides information about the procedures you can perform to configure Any Transport over MPLS: Tunnel Selection.

Configuring Any Transport over MPLS: Tunnel Selection

You can configure tunnel selection when you set up a pseudowire class. You can enable tunnel selection with the preferred-path command. Then you can apply the pseudowire class to an interface that has been configured to transport AToM packets.

To configure Any Transport over MPLS: Tunnel Selection, perform this procedure.

Procedure

  Command or Action Purpose

Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode. Enter your password, if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

psuedowire-class name

Example:

Device(config)# pseudowire-class ts1

Establishes a pseudowire class with a name that you specify and enters pseudowire configuration mode.

Step 4

encapsulation mpls

Example:

Device(config-pw)# encapsulation mpls

Specifies the tunneling encapsulation. For AToM, the encapsulation type is mpls.

Step 5

preferred-path{ interface-tunnel tunnel-number| peer{ ip-address| host-name} }[ disable-fallback]

Example:

Device(config-pw)# preferred path peer 10.18.18.18

Specifies the MPLS traffic engineering tunnel or IP address or host name to be used as the preferred path.

Step 6

exit

Example:

(config-pw)# exit

Exits pseudowire configuration mode.

Step 7

interface slot/port

Example:

Device(config)# interface atm1/1

Specifies an interface and enters interface configuration mode.

Step 8

encapsulation encapsulation-type

Example:

Device(config-if)# encapsulation aal5

Step 9

xconnect peer-router-id vcid pw-class name

Example:

Device(config-if)# xconnect 10.0.0.1 123 pw-class ts1

Binds the attachment circuit to a pseudowire VC.

Configuration Examples for Any Transport over MPLS: Tunnel Selection

The following section provides examples for configuring Any Transport over MPLS: Tunnel Selection.

Example: Configuring Tunnel Selection

The following example sets up two preferred paths for PE1. One preferred path specifies an MPLS traffic engineering tunnel. The other preferred path specifies an IP address of a loopback address on PE2. There is a static route configured on PE1 that uses a TE tunnel to reach the IP address on PE2.

Device PE1



mpls label protocol ldp
mpls traffic-eng tunnels
tag-switching tdp router-id Loopback0
pseudowire-class pw1
 encapsulation mpls
 preferred-path interface Tunnel1 disable-fallback
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
 no ip directed-broadcast
 no ip mroute-cache
!
interface Tunnel1
 ip unnumbered Loopback0
 no ip directed-broadcast
 tunnel destination 10.16.16.16
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 1500
 tunnel mpls traffic-eng path-option 1 explicit name path-tu1
!
interface gigabitethernet0/0/0
 no ip address
 no ip directed-broadcast
 no negotiation auto
!
interface gigabitethernet0/0/0.1
 encapsulation dot1Q 222
 no ip directed-broadcast
 xconnect 10.16.16.16 101 pw-class pw1
!
interface gigabitEthernet2/0/1
 ip address 10.0.0.1 255.255.255.0
 no ip directed-broadcast
 tag-switching ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 15000 15000
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.2.2 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
ip route 10.18.18.18 255.255.255.255 Tunnel2
!
ip explicit-path name path-tu1 enable
 next-address 10.0.0.1
 index 3 next-address 10.0.0.1

Device PE2

mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
interface Loopback0
 ip address 10.16.16.16 255.255.255.255
 no ip directed-broadcast
 no ip mroute-cache
!
interface Loopback2
 ip address 10.18.18.18 255.255.255.255
 no ip directed-broadcast
!
interface gigabitEthernet3/1
 ip address 10.0.0.2 255.255.255.0
 no ip directed-broadcast
 mpls traffic-eng tunnels
 mpls ip
 no cdp enable
 ip rsvp bandwidth 15000 15000
!
interface gigabitEthernet3/3 
 no ip address 
 no ip directed-broadcast 
 no cdp enable 
! 
interface gigabitEthernet3/3.1 
 encapsulation dot1Q 222 
 no ip directed-broadcast 
 no cdp enable 
 mpls l2transport route 10.2.2.2 101 
! 
interface ATM5/0
 no ip address
 no ip directed-broadcast
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
 pvc 0/50 l2transport
  encapsulation aal5
  xconnect 10.2.2.2 150 encapsulation mpls
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 10.16.16.16 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0

Example: Verifying the Configuration

In the following example, the show mpls l2transport vc command shows the following information (in bold) about the VCs:

  • VC 101 has been assigned a preferred path called Tunnel1. The default path is disabled because the preferred path specified that the default path should not be used if the preferred path fails.

  • VC 150 has been assigned an IP address of a loopback address on PE2. The default path can be used if the preferred path fails.

Device# show mpls l2transport vc detail

Local interface: Gi0/0/0.1 up, Eth VLAN 222 up
    Preferred path: Tunnel1,  active
    Default path: disabled
    Tunnel label: 3, next hop point2point
    Output interface: Tu1, imposed label stack {17 16}
  Create time: 00:27:31, last status change time: 00:27:31
  Signaling protocol: LDP, peer 10.16.16.16:0 up
    MPLS VC labels: local 25, remote 16
    Group ID: local 0, remote 6
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 10, send 10
    byte totals:   receive 1260, send 1300
    packet drops:  receive 0, send 0

Example: Troubleshooting Tunnel Selection

You can use the debug mpls l2transport vc event command to troubleshoot tunnel selection. For example, if the tunnel interface that is used for the preferred path is shut down, the default path is enabled. The debug mpls l2transport vc event command provides the following output:

AToM SMGR [10.2.2.2, 101]: Processing imposition update, vc_handle 62091860, update_action 
3, remote_vc_label 16 
AToM SMGR [10.2.2.2, 101]: selected route no parent rewrite: tunnel not up 
AToM SMGR [10.2.2.2, 101]: Imposition Programmed, Output Interface: Et3/2

Feature History for Any Transport over MPLS: Tunnel Selection

This table provides release and related information for the features explained in this module.

These features are available in all the releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Cupertino 17.7.1

Any Transport over MPLS: Tunnel Selection

The Any Transport over MPLS: Tunnel Selection feature allows you to specify the path that Any Transport over MPLS (AToM) traffic uses. You can specify either a Multiprotocol Label Switching (MPLS) traffic engineering tunnel or a destination IP address and Domain Name System (DNS) name.

Use the Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/