Configuring MPLS Traffic Engineering Forwarding Adjacency

Prerequisites for MPLS Traffic Engineering Forwarding Adjacency

Your network must support the following Cisco IOS XE features:

  • Multiprotocol Label Switching (MPLS)

  • IP Cisco Express Forwarding

  • IS-IS

Restrictions for MPLS Traffic Engineering Forwarding Adjacency

  • Using the MPLS Traffic Engineering Forwarding Adjacency feature increases the size of the IGP database by advertising a TE tunnel as a link.

  • When the MPLS Traffic Engineering Forwarding Adjacency feature is enabled on a TE tunnel, the link is advertised in the IGP network as a type, length, value (TLV) 22 object without any TE sub-TLV.

  • You must configure MPLS TE forwarding adjacency tunnels bidirectionally.

Information About MPLS Traffic Engineering Forwarding Adjacency

The following topics provide information about MPLS Traffic Engineering Forwarding Adjacency.

MPLS Traffic Engineering Forwarding Adjacency Functionality

The MPLS Traffic Engineering Forwarding Adjacency feature allows you to handle a TE LSP tunnel as a link in an IGP network based on the SPF algorithm. A forwarding adjacency can be created between devices regardless of their location in the network. The devices can be located multiple hops from each other, as shown in the figure below.

As a result, a TE tunnel is advertised as a link in an IGP network with the link’s cost associated with it.

Devices outside of the TE domain see the TE tunnel and use it to compute the shortest path for routing traffic throughout the network.

MPLS Traffic Engineering Forwarding Adjacency Benefits

TE tunnel interfaces advertised for SPF--TE tunnel interfaces are advertised in the IGP network just like any other links. Devices can then use these advertisements in their IGPs to compute the SPF even if they are not the headend of any TE tunnels.

Usage Tips

In the figure below, if you have no forwarding adjacencies configured for the TE tunnels between B and F and C and F, all the traffic that A must forward to F goes through B because B is the shortest path from A to F. (The cost from A to F is 15 through B and 20 through C.)

If you have forwarding adjacencies configured on the TE tunnels between B and F and C and F and also on the TE tunnels between F and B and F and C, then when A computes the SPF algorithm, A sees two equal cost paths of 11 to F. As a result, traffic across the A-B and A-C links is shared.

How to Configure MPLS Traffic Engineering Forwarding Adjacency

The following section provides information about the configuration steps for configuring MPLS Traffic Engineering Forwarding Adjacency.

Configuring a Tunnel Interface for MPLS TE Forwarding Adjacency

To configure a tunnel interface for MPLS TE Forwarding Adjacency, perform this procedure.

Procedure

  Command or Action Purpose

Step 1

enable

Example:


Device>enable

Enables privileged EXEC mode. Enter your password, if prompted.

Step 2

configure terminal

Example:


Devcie# configure terminal

Enters global configuration mode.

Step 3

interface tunnel number

Example:


Device(config)# interface tunnel 0

Designates a tunnel interface for the forwarding adjacency, and enters interface configuration mode.

Step 4

exit

Example:


Device(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 5

exit

Example:


Device(config)# exit

Exits global configuration mode and returns to privileged EXEC mode.

Configuring MPLS TE Forwarding Adjacency on Tunnels with ISIS

To configure MPLS TE Forwarding Adjacency on tunnels with ISIS, perform this procedure.


Note


You must configure a forwarding adjacency on two LSP tunnels bidirectionally, from A to B and B to A. Otherwise, the forwarding adjacency is advertised, but not used in the IGP network.


Procedure

  Command or Action Purpose

Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode. Enter your password, if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

interface tunnel number

Example:


Device(config)# interface tunnel 0

Designates a tunnel interface for the forwarding adjacency, and enters interface configuration mode.

Step 4

ip router isis area-tag

Example:

Device(config-if)# ip router isis 1

Configures an IS-IS routing process for IP on an interface and to attaches an area designator to the routing process.

Step 5

tunnel mpls traffic-eng forwarding-adjacency [holdtime value ]

Example:


Device(config-if)# tunnel mpls traffic-eng forwarding-adjacency 

Advertises a TE tunnel as a link in an IGP network.

Step 6

isis metric {metric-value | maximum } {level-1 | level-2 }

Example:


Device(config-if)# isis metric 2 level-1

Configures the IS-IS metric for a tunnel interface to be used as a forwarding adjacency.

  • You should specify the isis metric command with level-1 or level-2 to be consistent with the IGP level at which you are performing traffic engineering. Otherwise, the metric has the default value of 10.

Configuring MPLS TE Forwarding Adjacency on Tunnels with OSPF

To configure MPLS TE Forwarding Adjacency on tunnels with OSPF, perform this procedure.


Note


You must configure a forwarding adjacency on two LSP tunnels bidirectionally, from A to B and B to A. Otherwise, the forwarding adjacency is advertised, but not used in the IGP network.


Procedure

  Command or Action Purpose

Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode. Enter your password, if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

interface tunnel number

Example:


Device(config)# interface tunnel 0

Designates a tunnel interface for the forwarding adjacency, and enters interface configuration mode.

Step 4

ip ospf process-id area area-id

Example:

Device(config-if)# ip router ospf 1 area 0

Configures an OSPF routing process for IP on an interface and to attaches an area designator to the routing process.

Step 5

tunnel mpls traffic-eng forwarding-adjacency [holdtime value ]

Example:


Device(config-if)# tunnel mpls traffic-eng forwarding-adjacency 

Advertises a TE tunnel as a link in an IGP network.

Step 6

ip ospf cost cost

Example:


Device(config-if)# ip ospf cost 4

Configures the OSPF metric for a tunnel interface to be used as a forwarding adjacency.

Verifying MPLS TE Forwarding Adjacency

To verify MPLS TE Forwarding Adjacency, perform this procedure.

Procedure

  Command or Action Purpose

Step 1

enable

Example:


Device> enable

Use this command to enter the privileged EXEC mode. Enter your password, if prompted.

Step 2

show mpls traffic-eng forwarding-adjacency [ip-address ]

Example:


Device# show mpls traffic-eng forwarding-adjacency

Use this command to display the current tunnels.

Step 3

show isis [process-tag ] database [level-1 ] [level-2 ] [l1 ] [l2 ] [detail ] [lspid ]

Example:


Device# show isis database

Example:

Use this command to display information about the IS-IS link-state database. For example:

Step 4

exit

Example:


Device# exit

Use this command to exit to user EXEC mode.

Configuration Examples for MPLS Traffic Engineering Forwarding Adjacency

This section provides a configuration example for the MPLS Traffic Engineering Forwarding Adjacency feature using an IS-IS metric.

Example MPLS TE Forwarding Adjacency

The following output shows the configuration of a tunnel interface, a forwarding adjacency, and an IS-IS metric:


Device# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Device(config)# interface tunnel 7
Device(config-if)# ip router isis 1
Device(config-if)# tunnel mpls traffic-eng forwarding-adjacency 
Device(config-if)# isis metric 2 level-1

Following is sample command output when a forwarding adjacency has been configured:


Device# show running-config 
Building configuration...
Current configuration :364 bytes
!
interface Tunnel7
ip router isis 1
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 192.168.1.7
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng forwarding-adjacency
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng path-option 10 explicit name short
isis metric 2 level 1

Note


Do not specify the tunnel mpls traffic-eng autoroute announce command in your configuration when you are using forwarding adjacency.


Following is an example where forwarding adjacency is configured with OSPF:


Device# configure terminal
 
Device# show running-config

Building configuration...
Current configuration : 310 bytes
interface Tunnel1
ip router ospf 1 area 0
ip unnumbered Loopback0
ip ospf cost 6
tunnel destination 172.16.255.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng forwarding-adjacency  tunnel mpls 
traffic-eng priority 7 7  
tunnel mpls traffic-eng bandwidth 1000  
tunnel mpls traffic-eng path-option 10 dynamic 
end
Device# show mpls traffic-eng forwarding-adjacency

 destination 172.16.255.5, area ospf 172  area 0, has 1 tunnels
  Tunnel1      (load balancing metric 2000000, nexthop 172.16.255.5)
               (flags:  Forward-Adjacency, holdtime 0) 

Additional References

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

MPLS traffic engineering commands

Cisco IOS Multiprotocol Label Switching Command Reference

IP switching commands

Cisco IOS IP Switching Command Reference

IS-IS TLVs

Intermediate System-to-Intermediate System (IS-IS) TLVs (white paper)

Standards

Standard

Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

--

MIBs

MIB

MIBs Link

No new or modified MIBs are supported by this feature, and support for existing standards has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

--

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature History for MPLS Traffic Engineering Forwarding Adjacency

This table provides release and related information for the features explained in this module.

These features are available in all the releases subsequent to the one they were introduced in, unless noted otherwise.

Release

Feature

Feature Information

Cisco IOS XE Cupertino 17.7.1

MPLS Traffic Engineering Forwarding Adjacency

The MPLS Traffic Engineering Forwarding Adjacency feature allows a network administrator to handle a traffic engineering (TE) label switched path (LSP) tunnel as a link in an Interior Gateway Protocol (IGP) network based on the Shortest Path First (SPF) algorithm.

Use the Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/