Device(config)# ip explicit-path name foo
Device(config-ip-expl-path)# index 10 next-address 10.1.1.1 node address
Device(config-ip-expl-path)# index 20 next-address 10.12.12.2 link address
Note
IP アンナンバード インターフェイスを使用する場合、ネクスト ホップ アドレスを明示的パスのインデックスとして指定することはできません。これは、ノード アドレスまたはラベルである必要があります。
明示的パスは、セグメントルーティング SID として指定することもできます。
Device(config)# ip explicit-path name foo
Device(config-ip-expl-path)# index 10 next-label 20
ヘッドエンドは、指定された SR パスが設定されたアフィニティに準拠していることを検証します。これにより、SR パスの各セグメントのパスは、指定された制約に照らして検証される必要があります。パスの少なくとも 1 つのセグメントが設定されているアフィニティを満たさない場合、そのパスは設定されているアフィニティ制約に対して無効として宣言されます。
interface Tunnel1
no ip address
tunnel mode mpls traffic-eng
tunnel destination 10.5.5.5
tunnel mpls traffic-eng priority 5 5
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng affinity 0x1 mask 0xFFFF
tunnel mpls traffic-eng path-option 10 dynamic segment-routing
Router# show tunnel ??
Name: R1_t1 (Tunnel1) Destination: 10.5.5.5
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 10, (SEGMENT-ROUTING) type dynamic (Basis for Setup, path weight 20)
Config Parameters:
Bandwidth: 100 kbps (Global) Priority: 5 5 Affinity: 0x1/0xFFFF
Metric Type: TE (default)
Path Selection:
Protection: any (default)
Path-selection Tiebreaker:
Global: not set Tunnel Specific: not set Effective: min-fill (default)
Hop Limit: disabled
Cost Limit: disabled
Path-invalidation timeout: 10000 msec (default), Action: Tear
AutoRoute: disabled LockDown: disabled Loadshare: 100 [0] bw-based
auto-bw: disabled
Fault-OAM: disabled, Wrap-Protection: disabled, Wrap-Capable: No
Active Path Option Parameters:
State: dynamic path option 10 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
Node Hop Count: 2
History:
Tunnel:
Time since created: 10 minutes, 54 seconds
Time since path change: 34 seconds
Number of LSP IDs (Tun_Instances) used: 55
Current LSP: [ID: 55]
Uptime: 34 seconds
Prior LSP: [ID: 49]
ID: path option unknown
Removal Trigger: tunnel shutdown
Tun_Instance: 55
Segment-Routing Path Info (isis level-1)
Segment0[Link]: 192.168.2.1 - 192.168.2.2, Label: 46
Segment1[Link]: 192.168.4.2 - 192.168.4.1, Label: 49
インターフェイスのアフィニティの設定
インターフェイスでアフィニティを設定するには、次の手順を実行します。
interface GigabitEthernet2
ip address 192.168.2.1 255.255.255.0
ip router isis 1
negotiation auto
mpls traffic-eng tunnels
mpls traffic-eng attribute-flags 0x1
isis network point-to-point
ip rsvp bandwidth
OSPF のセグメント ルーティング トラフィック エンジニアリングの設定
OSPF で SR-TE を設定するには、次のエリア間およびエリア内の使用例を考慮してください。
エリア内トンネルの設定
エリア内トンネルを設定するには、次のトポロジを検討してください。
すべてのルータは、同じエリアである、エリア 0 内で設定されています。
ヘッドエンド ルータ R1 の構成
router ospf 10
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa
segment-routing mpls
mpls traffic-eng router-id Loopback1
mpls traffic-eng area 0
interface GigabitEthernet2 //interface connecting to the router 2
ip address 10.101.1.1 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface GigabitEthernet4 //interface connecting to the router 4
ip address 10.101.1.1 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface loopback1
ip address 10.1.1.1/32
ip ospf 10 area 0
テールエンド ルータ R6 の構成
router ospf 10
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa
segment-routing mpls
mpls traffic-eng area 0
mpls traffic-eng router-id Loopback1
interface GigabitEthernet2 //interface connecting to the router 3
ip address 10.101.2.1 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface GigabitEthernet4 //interface connecting to the router 5
ip address 10.101.2.1 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface loopback1
ip address 10.6.6.6/32
ip ospf 10 area 0
router ospf 10
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa
segment-routing mpls
mpls traffic-eng router-id Loopback1
mpls traffic-eng area 0
interface GigabitEthernet2 //interface connecting to the router 2
ip address 10.101.1.1 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface GigabitEthernet4 //interface connecting to the router 4
ip address 10.101.1.1 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface loopback1
ip address 10.1.1.1/32
ip ospf 10 area 0
テールエンド ルータ R6 の構成
router ospf 10
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa
segment-routing mpls
mpls traffic-eng area 1
mpls traffic-eng router-id Loopback1
interface GigabitEthernet2 //interface connecting to the router 3
ip address 10.101.2.1 255.255.255.0
ip ospf 10 area 1
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface GigabitEthernet4 //interface connecting to the router 5
ip address 10.101.2.1 255.255.255.0
ip ospf 10 area 1
ip ospf network point-to-point
negotiation auto
mpls traffic-eng tunnels
interface loopback1
ip address 10.6.6.6/32
ip ospf 10 area 1
エリア間トンネルの設定に関する制約事項
エリア間トンネルの設定に関する制約事項は次のとおりです。
ノードおよび隣接関係 SID を持つ動的オプションはサポートされていません。
ラベルのみおよび/または IP アドレスとラベルを含む明示的パスを使用して、エリア間トンネルを設定できます。
(注)
IP アドレスは、エリア境界ルータ(ABR)までのみ使用でき、その後はラベルのみを指定する必要があります。