例:DMVPN での BFD サポート
次に、ハブで DMVPN での BFD サポートを設定する例を示します。
bfd-template single-hop sample
interval min-tx 1000 min-rx 1000 multiplier 5
!
interface Tunnel0
ip address 10.0.0.1 255.255.255.0
no ip redirects
ip nhrp authentication cisco123
ip nhrp network-id 5
ip nhrp redirect
ip mtu 1400
ip tcp adjust-mss 1360
bfd template sample
tunnel source GigabitEthernet0/0/0
tunnel mode gre multipoint
tunnel key 6
!
interface GigabitEthernet0/0/0
ip address 10.0.0.1 255.0.0.0
negotiation auto
!
router eigrp 2
network 10.0.0.0 0.0.0.255
bfd all-interfaces
auto-summary
!
次に、スポークで DMVPN での BFD サポートを設定する例を示します。
bfd-template single-hop sample
interval min-tx 1000 min-rx 1000 multiplier 5
!
interface Tunnel1
ip address 10.0.0.10 255.255.255.0
no ip redirects
ip nhrp authentication cisco123
ip nhrp network-id 5
ip nhrp nhs 10.0.0.1 nbma 10.0.0.10 multicast
bfd template sample
tunnel source GigabitEthernet0/0/0
tunnel mode gre multipoint
tunnel key 6
!
interface GigabitEthernet0/0/0
mtu 4000
ip address 11.0.0.1 255.0.0.0
media-type rj45
negotiation auto
!
interface GigabitEthernet0/0/1
mtu 6000
ip address 111.0.0.1 255.255.255.0
negotiation auto
!
router eigrp 2
network 11.0.0.0 0.0.0.255
network 111.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
bfd all-interfaces
auto-summary
!
ip route 0.0.0.0 0.0.0.0 10.0.0.2
次に、スポークでのコンバージェンスを高速化する例を示します。
interface Tunnel1
ip address 18.0.0.10 255.255.255.0
no ip redirects
ip nhrp authentication cisco123
ip nhrp network-id 12
ip nhrp nhs 10.0.0.1 nbma 10.0.0.10 multicast
bfd template sample
tunnel source GigabitEthernet0/0/0
tunnel mode gre multipoint
tunnel key 18
tunnel protection ipsec profile MY_PROFILE
!
bfd-template single-hop sample
interval min-tx 1000 min-rx 1000 multiplier 3
echo
!
router eigrp 2
bfd interface Tunnel1 ------------------------> Specify the interface on which the routing protocol must act for BFD up/down events
network 11.0.0.0 0.0.0.255
network 111.0.0.0 0.0.0.255
上記の設定を使用すると、BFD のダウンがレポートされた直後に(3 秒で検出)、EIGRP は RIB からインストールされたルートを削除します。
次の出力例は、ハブのサマリー出力を示しています。
device#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel1, IPv4 NHRP Details
Type:Hub, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 172.17.0.1 10.0.0.1 UP 00:00:14 D
1 172.17.0.2 10.0.0.2 BFD 00:00:03 D
BFD が新しい状態であるということは、セッションは下位レイヤ(IKE、IPSec、および NHRP)で認識されるように UP 状態ですが、BFD がセッションを DOWN と認識したことを意味します。通常どおり、この状態はセッションが UP 状態ではない最下位レイヤを示しています。また、これは親キャッシュ エントリにのみ適用されます。この原因としては、BFD によって DOWN と検出されたこと、または BFD が反対側で設定されていないことが考えられます。
次の出力例は、スポークのサマリー出力を示しています。
device#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel2, IPv4 NHRP Details
Type:Spoke, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
2 172.17.0.2 10.0.0.2 BFD 00:00:02 DT1
10.0.0.2 UP 00:00:02 DT2
1 172.17.0.11 10.0.0.11 UP 00:05:35 S
次の例は、show ip/ipv6 nhrp コマンドの出力を示しています。
device#show ip nhrp
10.0.0.2/32 via 10.0.0.2
Tunnel2 created 00:00:15, expire 00:04:54
Type: dynamic, Flags: router nhop rib bfd
NBMA address: 172.17.0.2
10.0.0.11/32 via 10.0.0.11
Tunnel2 created 00:09:04, never expire
Type: static, Flags: used bfd
NBMA address: 172.17.0.11
192.168.1.0/24 via 10.0.0.1
Tunnel2 created 00:00:05, expire 00:04:54
Type: dynamic, Flags: router unique local
NBMA address: 172.17.0.1
(no-socket)
192.168.2.0/24 via 10.0.0.2
Tunnel2 created 00:00:05, expire 00:04:54
Type: dynamic, Flags: router rib nho
NBMA address: 172.17.0.2
上記の例の BFD フラグは、このピアに BFD セッションがあることを意味しています。このマーキングは親エントリ専用です。
次の例は、show tunnel endpoints コマンドの出力を示しています。
device#show tunnel endpoints
Tunnel2 running in multi-GRE/IP mode
Endpoint transport 172.17.0.2 Refcount 3 Base 0x2ABF53ED09F0 Create Time 00:00:07
overlay 10.0.0.2 Refcount 2 Parent 0x2ABF53ED09F0 Create Time 00:00:07
Tunnel Subblocks:
tunnel-nhrp-sb:
NHRP subblock has 2 entries; BFD(0x2):U
Endpoint transport 172.17.0.11 Refcount 3 Base 0x2ABF53ED0B80 Create Time 00:09:07
overlay 10.0.0.11 Refcount 2 Parent 0x2ABF53ED0B80 Create Time 00:09:07
Tunnel Subblocks:
tunnel-nhrp-sb:
NHRP subblock has 1 entries; BFD(0x1):U
すべてのトンネル エンドポイントに対して、新しいテキスト「
BFD(handle):state」が追加されます。状態は UP(U)、DOWN(D)、NONE(N)、または INVALID(I)のいずれかです。
次の例は、show nhrp interfaces コマンドの出力を示しています。インターフェイス上の設定状態またはグローバルな設定状態が示されます(動作状態ではありません)。
device#show nhrp interfaces
NHRP Config State
-----------------
Global:
BFD: Registered
Tunnel1:
BFD: Disabled
Tunnel2:
BFD: Enabled
これは内部の隠しコマンドです。現在は、NHRP が BFD のクライアントであるかどうか、および BFD が NHRP インターフェイスでイネーブルになっているかどうかが表示されます。