Configuring PortChannels

This chapter describes how to configure PortChannels.

This chapter includes the following topics:

Information About PortChannels

This section includes the following topics:

PortChannels Overview

PortChannels refer to the aggregation of multiple physical interfaces into one logical interface to provide higher aggregated bandwidth, load balancing, and link redundancy (See Figure 9-1). PortChannels can connect to interfaces across switching modules, so a failure of a switching module cannot bring down the PortChannel link.

Figure 9-1 PortChannel Flexibility

 

PortChannels on Cisco MDS 9000 Family switches allow flexibility in configuration. This illustrates three possible PortChannel configurations:

  • PortChannel A aggregates two links on two interfaces on the same switching module at each end of a connection.
  • PortChannel B also aggregates two links, but each link is connected to a different switching module. If the switching module goes down, traffic is not affected.
  • PortChannel C aggregates three links. Two links are on the same switching module at each end, while one is connected to a different switching module on switch 2.

E PortChannels

An E PortChannel refers to the aggregation of multiple E ports into one logical interface to provide higher aggregated bandwidth, load balancing, and link redundancy. PortChannels can connect to interfaces across switching modules, so a failure of a switching module cannot bring down the PortChannel link.

A PortChannel has the following features and restrictions:

  • Provides a point-to-point connection over ISL (E ports) or EISL (TE ports). Multiple links can be combined into a PortChannel.
  • Increases the aggregate bandwidth on an ISL by distributing traffic among all functional links in the channel.
  • Load balances across multiple links and maintains optimum bandwidth utilization. Load balancing is based on the source ID, destination ID, and exchange ID (OX ID).
  • Provides high availability on an ISL. If one link fails, traffic previously carried on this link is switched to the remaining links. If a link goes down in a PortChannel, the upper protocol is not aware of it. To the upper protocol, the link is still there, although the bandwidth is diminished. The routing tables are not affected by link failure. PortChannels may contain up to 16 physical links and may span multiple modules for added high availability.

Note See the Cisco MDS 9000 Family NX-OS Fabric Configuration Guide for information about failover scenarios for PortChannels and FSPF links.


F and TF PortChannels

An F PortChannel is also a logical interface that combines a set of F ports connected to the same Fibre Channel node and operates as one link between the F ports and the NP ports. The F PortChannels support bandwidth utilization and availability like the E PortChannels. F PortChannels are mainly used to connect MDS core and NPV switches to provide optimal bandwidth utilization and transparent failover between the uplinks of a VSAN.

An F PortChannel trunk combines the functionality and advantages of a TF port and an F PortChannel. This logical link uses the Cisco PTP and PCP protocols over Cisco EPP (ELS).


Note If a Cisco MDS 9124 or 9134 switch is used as a core switch, only a nontrunking F PortChannel is supported. Trunking is not supported on this platform when NPIV enabled.


PortChanneling and Trunking

Trunking is a commonly used storage industry term. However, the Cisco NX-OS software and switches in the Cisco MDS 9000 Family implement trunking and PortChanneling as follows:

  • PortChanneling enables several physical links to be combined into one aggregated logical link.
  • Trunking enables a link transmitting frames in the EISL format to carry (trunk) multiple VSAN traffic. For example, when trunking is operational on an E port, that E port becomes a TE port. A TE port is specific to switches in the Cisco MDS 9000 Family. An industry standard E port can link to other vendor switches and is referred to as a nontrunking interface (See Figure 9-2 and Figure 9-3). See “Configuring Trunking,” for information on trunked interfaces.

Figure 9-2 Trunking Only

 

Figure 9-3 PortChanneling and Trunking

 

 

PortChanneling and trunking are used separately across an ISL.

  • PortChanneling—Interfaces can be channeled between the following sets of ports:

– E ports and TE ports

– F ports and NP ports

– TF ports and TNP ports

  • Trunking—Trunking permits carrying traffic on multiple VSANs between switches.

See the Cisco MDS 9000 Family NX-OS Fabric Configuration Guide .

  • Both PortChanneling and trunking can be used between TE ports over EISLs.

Load Balancing

Two methods support the load-balancing functionality:

  • Flow based—All frames between source and destination follow the same links for a given flow. That is, whichever link is selected for the first exchange of the flow is used for all subsequent exchanges.
  • Exchange based—The first frame in an exchange picks a link and subsequent frames in the exchange follow the same link. However, subsequent exchanges can use a different link. This provides more granular load balancing while preserving the order of frames for each exchange.

Figure 9-4 illustrates how source ID 1 (SID1) and destination ID1 (DID1) based load balancing works. When the first frame in a flow is received on an interface for forwarding, link 1 is selected. Each subsequent frame in that flow is sent over the same link. No frame in SID1 and DID1 utilizes link 2.

Figure 9-4 SID1 and DID1-Based Load Balancing

 

Figure 9-5 illustrates how exchange-based load balancing works. When the first frame in an exchange is received for forwarding on an interface, link 1 is chosen by a hash algorithm. All remaining frames in that particular exchange are sent on the same link. For exchange 1, no frame uses link 2. For the next exchange, link 2 is chosen by the hash algorithm. Now all frames in exchange 2 use link 2.

Figure 9-5 SID1, DID1, and Exchange-Based Load Balancing

 

For more information on configuring load balancing and in-order delivery features, see the Cisco MDS 9000 Family NX-OS Fabric Configuration Guide .

PortChannel Modes

You can configure each PortChannel with a channel group mode parameter to determine the PortChannel protocol behavior for all member ports in this channel group. The possible values for a channel group mode are as follows:

  • ON (default)—The member ports only operate as part of a PortChannel or remain inactive. In this mode, the PortChannel protocol is not initiated. However, if a PortChannel protocol frame is received from a peer port, the software indicates its nonnegotiable status. This mode is backward compatible with the existing implementation of PortChannels in releases prior to Release 2.0(1b), where the channel group mode is implicitly assumed to be ON. In Cisco MDS SAN-OS Releases 1.3 and earlier, the only available PortChannel mode was the ON mode. PortChannels configured in the ON mode require you to explicitly enable and disable the PortChannel member ports at either end if you add or remove ports from the PortChannel configuration. You must physically verify that the local and remote ports are connected to each other.
  • ACTIVE—The member ports initiate PortChannel protocol negotiation with the peer port(s) regardless of the channel group mode of the peer port. If the peer port, while configured in a channel group, does not support the PortChannel protocol, or responds with a nonnegotiable status, it will default to the ON mode behavior. The ACTIVE PortChannel mode allows automatic recovery without explicitly enabling and disabling the PortChannel member ports at either end.

Table 9-1 compares ON and ACTIVE modes.

 

Table 9-1 Channel Group Configuration Differences

ON Mode
ACTIVE Mode

No protocol is exchanged.

A PortChannel protocol negotiation is performed with the peer ports.

Moves interfaces to the suspended state if its operational values are incompatible with the PortChannel.

Moves interfaces to the isolated state if its operational values are incompatible with the PortChannel.

When you add or modify a PortChannel member port configuration, you must explicitly disable (shut) and enable (no shut) the PortChannel member ports at either end.

When you add or modify a PortChannel interface, the PortChannel automatically recovers.

Port initialization is not synchronized.

There is synchronized startup of all ports in a channel across peer switches.

All misconfigurations are not detected as no protocol is exchanged.

Consistently detect misconfigurations using a PortChannel protocol.

Transitions misconfigured ports to the suspended state. You must explicitly disable (shut) and enable (no shut) the member ports at either end.

Transitions misconfigured ports to the isolated state to correct the misconfiguration. Once you correct the misconfiguration, the protocol ensures automatic recovery.

This is the default mode.

You must explicitly configure this mode.

PortChannel Deletion

When you delete the PortChannel, the corresponding channel membership is also deleted. All interfaces in the deleted PortChannel convert to individual physical links. After the PortChannel is removed, regardless of the mode used (ACTIVE and ON), the ports at either end are gracefully brought down, indicating that no frames are lost when the interface is going down (see the “Graceful Shutdown” section).

If you delete the PortChannel for one port, then the individual ports within the deleted PortChannel retain the compatibility parameter settings (speed, mode, port VSAN, allowed VSAN, and port security). You can explicitly change those settings as required.

  • If you use the default ON mode to avoid inconsistent states across switches and to maintain consistency across switches, then the ports shut down. You must explicitly enable those ports again.
  • If you use the ACTIVE mode, then the PortChannel ports automatically recover from the deletion.

Interfaces in a PortChannel

You can add or remove a physical interface (or a range of interfaces) to an existing PortChannel. The compatible parameters on the configuration are mapped to the PortChannel. Adding an interface to a PortChannel increases the channel size and bandwidth of the PortChannel. Removing an interface from a PortChannel decreases the channel size and bandwidth of the PortChannel.

This section describes interface configuration for a PortChannel and includes the following topics:


Note For information about PortChannel support on Generation 2 switching modules, see the “PortChannel Limitations” section.


Interface Addition to a PortChannel

You can add a physical interface (or a range of interfaces) to an existing PortChannel. The compatible parameters on the configuration are mapped to the PortChannel. Adding an interface to a PortChannel increases the channel size and bandwidth of the PortChannel.

A port can be configured as a member of a static PortChannel only if the following configurations are the same in the port and the PortChannel:

  • Speed
  • Mode
  • Rate mode
  • Port VSAN
  • Trunking mode
  • Allowed VSAN list or VF-ID list

After the members are added, regardless of the mode (ACTIVE and ON) used, the ports at either end are gracefully brought down, indicating that no frames are lost when the interface is going down (see the “Generation 1 PortChannel Limitations” section and “Graceful Shutdown” section).

Compatibility Check

A compatibility check ensures that the same parameter settings are used in all physical ports in the channel. Otherwise, they cannot become part of a PortChannel. The compatibility check is performed before a port is added to the PortChannel.

The check ensures that the following parameters and settings match at both ends of a PortChannel:

  • Capability parameters (type of interface, Gigabit Ethernet at both ends, or Fibre Channel at both ends).
  • Administrative compatibility parameters (speed, mode, rate mode, port VSAN, allowed VSAN list, and port security).

Note Ports in shared rate mode cannot form a PortChannel or a trunking PortChannel.


  • Operational parameters (remote switch WWN and trunking mode).

A port addition procedure fails if the capability and administrative parameters in the remote switch are incompatible with the capability and administrative parameters in the local switch. If the compatibility check is successful, the interfaces are operational and the corresponding compatibility parameter settings apply to these interfaces.

Suspended and Isolated States

If the operational parameters are incompatible, the compatibility check fails and the interface is placed in a suspended or isolated state based on the configured mode:

  • An interface enters the suspended state if the interface is configured in the ON mode.
  • An interface enters the isolated state if the interface is configured in the ACTIVE mode.

Forcing an Interface Addition

You can force the port configuration to be overwritten by the PortChannel. In this case, the interface is added to a PortChannel.

  • If you use the default ON mode to avoid inconsistent states across switches and to maintain consistency across switches, then the ports shut down. You must explicitly enable those ports again.
  • If you use the ACTIVE mode, then the PortChannel ports automatically recover from the addition.

Note When PortChannels are created from within an interface, the force option cannot be used.


After the members are forcefully added, regardless of the mode (ACTIVE and ON) used, the ports at either end are gracefully brought down, indicating that no frames are lost when the interface is going down (see the “Graceful Shutdown” section“Generation 1 PortChannel Limitations” section).

Interface Deletion from a PortChannel

When a physical interface is deleted from the PortChannel, the channel membership is automatically updated. If the deleted interface is the last operational interface, then the PortChannel status is changed to a down state. Deleting an interface from a PortChannel decreases the channel size and bandwidth of the PortChannel.

  • If you use the default ON mode to avoid inconsistent states across switches and to maintain consistency across switches, then the ports shut down. You must explicitly enable those ports again.
  • If you use the ACTIVE mode, then the PortChannel ports automatically recover from the deletion.

After the members are deleted, regardless of the mode (ACTIVE and ON) used, the ports at either end are gracefully brought down, indicating that no frames are lost when the interface is going down (see the “Generation 1 PortChannel Limitations” section and “Graceful Shutdown” section).

PortChannel Protocols

In earlier Cisco SAN-OS releases, PortChannels required additional administrative tasks to support synchronization. The Cisco NX-OS software provides robust error detection and synchronization capabilities. You can manually configure channel groups or they can be automatically created. In both cases, the channel groups have the same capability and configurational parameters. Any change in configuration applied to the associated PortChannel interface is propagated to all members of the channel group.

A protocol to exchange PortChannel configurations is available in all Cisco MDS switches. This addition simplifies PortChannel management with incompatible ISLs. An additional autocreation mode enables ISLs with compatible parameters to automatically form channel groups without manual intervention.

The PortChannel protocol is enabled by default.

The PortChannel protocol expands the PortChannel functional model in Cisco MDS switches. It uses the exchange peer parameters (EPP) services to communicate across peer ports in an ISL. Each switch uses the information received from the peer ports along with its local configuration and operational values to decide if it should be part of a PortChannel. The protocol ensures that a set of ports are eligible to be part of the same PortChannel. They are only eligible to be part of the same PortChannel if all the ports have a compatible partner.

The PortChannel protocol uses two subprotocols:

  • Bringup protocol—Automatically detects misconfigurations so you can correct them. This protocol synchronizes the PortChannel at both ends so that all frames for a given flow (as identified by the source FC ID, destination FC ID and OX_ID) are carried over the same physical link in both directions. This helps make applications such as write acceleration, work for PortChannels over FCIP links.
  • Autocreation protocol—Automatically aggregates compatible ports into a PortChannel.

This section describes how to configure the PortChannel protocol and includes the following sections:

Channel Group Creation


Note Channel groups are not supported on internal ports in the Cisco Fabric Switch for HP c-Class BladeSystem and the Cisco Fabric Switch for IBM BladeSystem.


Assuming link A1-B1 comes up first (see Figure 9-6), that link is operational as an individual link.When the next link comes up, for example, A2-B2, the PortChannel protocol identifies if this link is compatible with link A1-B1 and automatically creates channel groups 10 and 20 in the respective switches. If link A3-B3 can join the channel groups (the PortChannels), the respective ports have compatible configurations. If link A4-B4 operates as an individual link, it is because of the incompatible configuration of the two end ports with the other member ports in this channel group.

Figure 9-6 Autocreating Channel Groups

 

The channel group numbers are selected dynamically, and as such, the administrative configuration of the ports forming the channel group at either end are applicable to the newly created channel group. The channel group number being chosen dynamically may be different across reboots for the same set of PortChannels based on the order of ports that are initialized in the switch.

Table 9-2 identifies the differences between user-configured and auto-configured channel groups.

 

Table 9-2 Channel Group Configuration Differences

User-Configured Channel Group
Autocreated Channel Group

Manually configured by the user.

Created automatically when compatible links come up between two compatible switches, if channel group autocreation is enabled in all ports at both ends.

Member ports cannot participate in autocreation of channel groups. The autocreation feature cannot be configured.

None of these ports are members of a user-configured channel group.

You can form the PortChannel with a subset of the ports in the channel group. Incompatible ports remain in a suspended or isolated state depending on the ON or ACTIVE mode configuration.

All ports included in the channel group participate in the PortChannel—no member port becomes isolated or suspended; instead, the member port is removed from the channel group when the link is found to be incompatible.

Any administrative configuration made to the PortChannel is applied to all ports in the channel group, and you can save the configuration for the PortChannel interface.

Any administrative configuration made to the PortChannel is applied to all ports in the channel group, but the configurations are saved for the member ports; no configuration is saved for the PortChannel interface. You can explicitly convert this channel group, if required.

You can remove any channel group and add members to a channel group.

You cannot remove a channel group, or add/remove any of its members. The channel group is removed when no member ports exist.


Note Autocreation is not supported as of MDS NX-OS Release 4.1(1b) and later.


Autocreation

The autocreation protocol has the following functionality:

  • A port is not allowed to be configured as part of a PortChannel when the autocreation feature is enabled. These two configurations are mutually exclusive.
  • Autocreation must be enabled in both the local and peer ports to negotiate a PortChannel.
  • Aggregation occurs in one of two ways:

– A port is aggregated into a compatible autocreated PortChannel.

– A port is aggregated with another compatible port to form a new PortChannel.

  • Newly created PortChannels are allocated from the maximum possible PortChannel (128 for Generation 1 or a combination of Generation 1 and Generation 2 switches, or 256 for Generation 2 switches) in a decreasing order based on availability. If all 128 (or 256) numbers are used up, aggregation is not allowed.
  • You cannot change the membership or delete an autocreated PortChannel.
  • When you disable autocreation, all member ports are removed from the autocreated PortChannel.
  • Once the last member is removed from an autocreated PortChannel, the channel is automatically deleted and the number is released for reuse.
  • An autocreated PortChannel is not persistent through a reboot. An autocreated PortChannel can be manually configured to appear the same as a persistent PortChannel. Once the PortChannel is made persistent, the autocreation feature is disabled in all member ports.
  • You can enable or disable the autocreation feature on a per-port basis or for all ports in the switch. When this configuration is enabled, the channel group mode is assumed to be active. The default for this task is disabled.
  • If autocreation of channel groups is enabled for an interface, you must first disable autocreation before downgrading to earlier software versions or before configuring the interface in a manually configured channel group.

Tip When enabling autocreation in any switch in the Cisco MDS 9000 Family, we recommend that you retain at least one interconnected port between the switches without any autocreation configuration. If all ports between two switches are configured with the autocreation feature at the same time, you may face a possible traffic disruption between these two switches as the ports are automatically disabled and reenabled when ports are added to an autocreated PortChannel.


Manually Configured Channel Groups

A user-configured channel group cannot be converted to an autocreated channel group. However, you can convert an autocreated channel group to a manual channel group. Once performed, this task is irreversible. The channel group number does not change, but the member ports operate according to the properties of the manually configured channel group, and the autocreation of channel group is implicitly disabled for all member ports.


Tip If you enable persistence, be sure to enable it at both ends of the PortChannel.


 

Prerequisites for PortChannels

Before configuring a PortChannel, consider the following guidelines:

  • Configure the PortChannel across switching modules to implement redundancy on switching module reboots or upgrades.
  • Ensure that one PortChannel is not connected to different sets of switches. PortChannels require point-to-point connections between the same set of switches.

Note On switches with Generation 1 switching modules, or a combination of Generation 1 and Generation 2 switching modules, you can configure a maximum of 128 PortChannels. On switches with only Generation 2 switching modules, or Generation 2 and Generation 3 switching modules, you can configure a maximum of 256 PortChannels.


If you misconfigure PortChannels, you may receive a misconfiguration message. If you receive this message, the PortChannel’s physical links are disabled because an error has been detected.

A PortChannel error is detected if the following requirements are not met:

  • Each switch on either side of a PortChannel must be connected to the same number of interfaces.
  • Each interface must be connected to a corresponding interface on the other side (see Figure 9-8 for an example of an invalid configuration).
  • Links in a PortChannel cannot be changed after the PortChannel is configured. If you change the links after the PortChannel is configured, be sure to reconnect the links to interfaces within the PortChannel and reenable the links.

If all three conditions are not met, the faulty link is disabled.

Enter the show interface command for that interface to verify that the PortChannel is functioning as required.

Guidelines and Limitations

This section includes the guidelines and limitations for this feature:

General Guidelines and Limitations

Cisco MDS 9000 Family switches support the following number of PortChannels per switch:

  • Switches with only Generation 1 switching modules do not support F and TF PortChannels.
  • Switches with Generation 1 switching modules, or a combination of Generation 1 and Generation 2 switching modules, support a maximum of 128 PortChannels. Only Generation 2 ports can be included in the PortChannels.
  • Switches with only Generation 2 switching modules or Generation 2 and Generation 3 modules support a maximum of 256 PortChannels with 16 interfaces per PortChannel.
  • A PortChannel number refers to the unique identifier for each channel group. This number ranges from of 1 to 256.

Generation 1 PortChannel Limitations

This section includes the restrictions on creation and addition of PortChannel members to a PortChannel on Generation 1 hardware:

  • The 32-port 2-Gbps or 1-Gbps switching module.
  • The MDS 9140 and 9120 switches.

When configuring the host-optimized ports on Generation 1 hardware, the following PortChannel guidelines apply:

  • If you execute the write erase command on a 32-port switching module, and then copy a saved configuration to the switch from a text file that contains the no system default switchport shutdown command, you need to copy the text file to the switch again for the E ports to come up without manual configuration.
  • Any (or all) full line rate port(s) in the Cisco MDS 9100 Series can be included in a PortChannel.
  • The host-optimized ports in the Cisco MDS 9100 Series are subject to the same PortChannel rules as 32-port switching modules; only the first port of each group of 4 ports is included in a PortChannel.

– You can configure only the first port in each 4-port group as an E port (for example, the first port in ports 1–4, the fifth port in ports 5–8, and so on). If the first port in the group is configured as a PortChannel, the other three ports in each group (ports 2–4, 6–8, and so on) are not usable and remain in the shutdown state.

– If any of the other three ports are configured in a no shutdown state, you cannot configure the first port to be a PortChannel. The other three ports continue to remain in a no shutdown state.

F and TF PortChannel Limitations

The following guidelines and restrictions are applicable for F and TF PortChannels:

  • The ports must be in F mode.
  • Automatic creation is not supported.
  • The PortChannel interface must be in ACTIVE mode when multiple FCIP interfaces are grouped with WA.
  • ON mode is not supported. Only ACTIVE-ACTIVE mode is supported. By default, the mode is ACTIVE on the NPV switches.
  • Devices logged in through F PortChannel on an MDS switch are not supported in IVR non-NAT configuration. The devices are supported only in IVR NAT configuration.
  • Port security rules are enforced only on physical pWWNs at the single link level.
  • FC-SP authenticates only the first physical FLOGI of every PortChannel member.
  • Since the FLOGI payload carries only the VF bits to trigger the use of a protocol after the FLOGI exchange, those bits will be overridden. In the case of the NPV switches, the core has a Cisco WWN and will try to initiate the PCP protocol.
  • The name server registration of the N ports logging in through an F PortChannel will use the fWWN of the PortChannel interface.
  • DPVM configuration is not supported.
  • The PortChannel port VSAN cannot be configured using DPVM.
  • The Dynamic Port VSAN Management (DPVM) database will be queried only for the first physical FLOGI of each member, so that the port VSAN can be configured automatically.
  • DPVM does not bind FC_IDs to VSANs, but pWWNs to VSANs. It will be queried only for the physical FLOGI.

Valid and Invalid PortChannel Examples

PortChannels are created with default values. You can change the default configuration just like any other physical interface.Figure 9-7 provides examples of valid PortChannel configurations.

Figure 9-7 Valid PortChannel Configurations

 

Figure 9-8 provides examples of invalid configurations. Assuming that the links are brought up in the 1, 2, 3, 4 sequence, links 3 and 4 will be operationally down as the fabric is misconfigured.

Figure 9-8 Misconfigured Configurations

 

 

Default Settings

 

Table 9-3 lists the default settings for PortChannels.

 

Table 9-3 Default PortChannel Parameters

Parameters
Default

PortChannels

FSPF is enabled by default.

Create PortChannel

Administratively up.

Default PortChannel mode

ON mode on non-NPV and NPIV core switches.

ACTIVE mode on NPV switches.

Autocreation

Disabled.

Configuring PortChannels

This section includes the following topics:

Configuring PortChannels Using the WizardConfiguring PortChannels Using the Wizard

To create a PortChannel using the PortChannel Wizard in DCNM-SAN, follow these steps:


Step 1 Click the PortChannel Wizard icon in the toolbar.

You see the first PortChannel Wizard screen.

Step 2 Select a switch pair.

Step 3 Click Next .

Step 4 Select the ISLs.

Step 5 (Optional) Check the Dynamically form Port Channel Group from selected ISLs check box if you want to dynamically create the PortChannel and make the ISL properties identical for the Admin, Trunk, Speed, and VSAN attributes.

Step 6 Click Next .

Step 7 If you chose to dynamically form a PortChannel from selected ISLs, you see the final PortChannel Wizard screen. Set the VSAN List, Trunk Mode, and Speed and proceed to Step 11.

Step 8 If you did not choose to dynamically form a PortChannel, you see the third PortChannel Wizard dialog box.


Note Dynamic VSAN creation is not supported on NPV switches.


Step 9 Change the channel ID or description for each switch, if necessary.

Step 10 Review the attributes at the bottom of the screen, and set them if applicable.

The following attributes are shown in the screen:

– VSAN List—Provides a list of VSANs to which the ISLs belong.

– Trunk Mode—Enables trunking on the links in the PortChannel. Select trunking if your link is between TE ports. Select nontrunking if your link is between E ports. Select auto if you are not sure.

– Force Admin, Trunk, Speed, and VSAN attributes to be identical—Ensures that the same parameter settings are used in all physical ports in the channel. If these settings are not identical, the ports cannot become part of the PortChannel.

– Speed—The port speed values are auto, 1Gb, 2Gb, 4Gb, 8Gb, autoMax2G, and autoMax4G.

Step 11 Click OK .

The PortChannel is created. Note that it may take a few minutes before the new PortChannel is visible in the Fabric pane.


 

Creating a PortChannel

To create a PortChannel, follow these steps:

 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# interface port-channel 1

switch(config-if)#

Configures the specified PortChannel (1) using the default ON mode.

Configuring the PortChannel Mode

By default, the CLI and the Device Manager create the PortChannel in ON mode in the NPIV core switches and ACTIVE mode on the NPV switches. DCNM-SAN creates all PortChannels in ACTIVE mode. We recommend that you create PortChannels in ACTIVE mode.

Restrictions

  • An F PortChannel is supported only on ACTIVE mode.

Detailed Steps

To configure ACTIVE mode, follow these steps:

 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# interface port-channel 1

switch(config-if)#

Configures the specified PortChannel (1) using the default ON mode.

Step 3

switch(config-if)# channel mode active

Configures the ACTIVE mode.

switch(config-if)# no channel mode active

Reverts to the default ON mode.

To configure ACTIVE mode using DCNM-SAN, follow these steps:


Step 1 Expand ISLs and then select Port Channels in the Physical Attributes pane.

You see the PortChannels configured in the Information pane.

Step 2 Click the Protocols tab, and then from the Mode drop-down menu, select the appropriate mode for the PortChannel.

Step 3 Click the Apply Changes icon to save any modifications.


 

Deleting PortChannels

To delete a PortChannel, follow these steps:

 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# no interface port-channel 1

port-channel 1 deleted and all its members disabled

please do the same operation on the switch at the other end of the port-channel

switch(config)#

Deletes the specified PortChannel (1), its associated interface mappings, and the hardware associations for this PortChannel.

 

To delete a PortChannel using the PortChannel Wizard in DCNM-SAN, follow these steps:


Step 1 Click the PortChannel Wizard icon in the toolbar.

You see the first PortChannel Wizard screen.

Step 2 Select the existing PortChannel that you want to delete and click Next. You see a list of the ISLs currently associated with this PortChannel.

Step 3 Click Next. You see an editable list of associated ISLs and available ISLs for this PortChannel.

Step 4 Click each associated ISL and click the left arrow to remove all ISLs from the PortChannel.

Step 5 Check the Delete Port Channel If Empty check box to delete this PortChannel.

Step 6 Click Finish to save any modifications or click Cancel to discard any changes.


 

Adding an Interface to a PortChannel

To add an interface to a PortChannel, follow these steps:

 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# interface fc1/15

switch(config-if)#

Configures the specified port interface (fc1/15).

Step 3

switch(config-if)# channel-group 15

Adds physical Fibre Channel port 1/15 to channel group 15. If channel group 15 does not exist, it is created. The port is shut down.


Note To add a range of ports to a PortChannel, follow these steps:By default, the CLI adds a interface normally to a PortChannel, while DCNM-SAN adds the interface by force, unless specified explicitly.


 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# interface fc1/1 - 5

switch(config-if)#

Configures the specified range of interfaces. In this example, interfaces from 1/1 to 1/5 are configured.

Step 3

switch(config-if)# channel-group 2

Adds physical interfaces 1/1, 1/2, 1/3, 1/4, and 1/5 to channel group 2. If channel group 2 does not exist, it is created.

If the compatibility check is successful, the interfaces are operational and the corresponding states apply to these interfaces.

 

To add an interface or range of interfaces to a PortChannel using DCNM-SAN, follow these steps:


Step 1 Expand ISLs and then select Port Channels in the Physical Attributes pane.

You see the PortChannels in the Information pane.

Step 2 Click the Channels tab and find the switch and PortChannel that you want to edit.

Step 3 Set Members Admin to the interface or list of interfaces that you want to add to the PortChannel.

Step 4 Click the Apply Changes icon to save any modifications or click Undo Changes to discard any changes.


 

Forcing an Interface Addition

To force the addition of a port to a PortChannel, follow these steps:

 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# interface fc1/1

switch(config-if)#

Specifies the interface fc1/1.

Step 3

switch(config-if)# channel-group 1 force

Forces the addition of the physical port for interface fc1/1 to channel group 1. The port is shut down.

To force the addition of a port to a PortChannel using DCNM-SAN, follow these steps:


Step 1 Expand ISLs and then select Port Channels in the Physical Attributes pane. You see the PortChannels in the Information pane.

Step 2 Click the Channels tab and find the switch and PortChannel that you want to edit.

Step 3 Set Members Admin to the interface or list of interfaces that you want to add to the PortChannel.

Step 4 Check the Force check box to force this interface addition.

Step 5 Click the Apply Changes icon to save any modifications.


 

Deleting an Interface from a PortChannel

To delete a physical interface (or a range of physical interfaces) from a PortChannel, follow these steps:

 

 
Command
Purpose

Step 1

switch(config)# interface fc1/1

switch(config-if)#

Enters the selected physical interface level.

switch(config)# interface fc1/1 - 5

switch(config-if)#

Enters the selected range of physical interfaces.

Step 2

switch(config-if)# no channel-group 2

switch(config-if)#

Deletes the physical Fibre Channel interfaces in channel group 2.

 

To delete a physical interface (or a range of physical interfaces) from a PortChannel using DCNM-SAN, follow these steps:


Step 1 Expand ISLs and then select Port Channels in the Physical Attributes pane.

You see the PortChannels in the Information pane.

Step 2 Click the Channels tab and find the switch and PortChannel that you want to edit.

Step 3 Remove the interface or list of interfaces you want deleted in the Members the Admin column.

Step 4 Click the Apply Changes icon to save any modifications.


 

Enabling and Configuring Autocreation

To configure automatic channel groups, follow these steps:

 

 
Command
Purpose

Step 1

switch# config t

switch(config)#

Enters configuration mode.

Step 2

switch(config)# interface fc8/13

switch(config- if)#

Enters the configuration mode for the selected interface(s).

Step 3

switch(config- if)# channel-group auto

Automatically creates the channel group for the selected interface(s).

switch(config- if)# no channel-group auto

Disables the autocreation of channel groups for this interface, even if the system default configuration may have autocreation enabled.

To configure PortChannel autocreation, check the Dynamically form Port Channel Group from selected ISLs option in the PortChannel Wizard. For more information, see the “Configuring PortChannels” section.

Converting to Manually Configured Channel Groups

You can convert autocreated channel group to a user-configured channel group using the port-channel channel-group-number persistent EXEC command. If the PortChannel does not exist, this command is not executed.

To convert an autocreated channel group to a user-configured channel group using DCNM-SAN, follow these steps:


Step 1 Expand ISLs and then select Port Channels in the Physical Attributes pane.

Step 2 Click the Protocol tab.

You see the switch protocols.

Step 3 Check the Persist check box for each channel that you want to convert to a manually configured channel group.

Step 4 Click the Apply Changes icon to save any modifications.


 

Verifying PortChannel Configuration

To display PortChannel configuration information, perform one of the following tasks:

 

Command
Purpose

show port-channel summary

Displays a summary of PortChannels within the switch. A one-line summary of each PortChannel provides the administrative state, the operational state, the number of attached and active interfaces (up), and the first operational port (FOP), which is the primary operational interface selected in the PortChannel to carry control-plane traffic (no load-balancing). The FOP is the first port that comes up in a PortChannel and can change if the port goes down. The FOP is also identified by an asterisk ( * ).

show port-channel database

Displays the PortChannel configured in the default ON mode and ACTIVE mode.

show port-channel consistency

Displays the consistency status without details.

show port-channel consistency detail

Displays the consistency status with details.

show port-channel usage

Displays the PortChannel usage.

show port-channel compatibility-parameters

Displays the PortChannel compatibility.

show interface fc slot/port

Displays autocreated PortChannels.

show port-channel database interface port-channel number

Displays the specified PortChannel interface.

For detailed information about the fields in the output from these commands, refer to the Cisco MDS NX-OS Command Reference .

You can view specific information about existing PortChannels at any time from EXEC mode. The following show commands provide further details on existing PortChannels. You can force all screen output to go to a printer or save it to a file. See Examples 9-1 to 9-6 .

Example 9-1 Displays the PortChannel Summary

switch# show port-channel summary
------------------------------------------------------------------------------
Interface Total Ports Oper Ports First Oper Port
------------------------------------------------------------------------------
port-channel 77 2 0 --
port-channel 78 2 0 --
port-channel 79 2 2 fcip200

Example 9-2 Displays the PortChannel Configured in the Default ON Mode

switch# show port-channel database
port-channel 77
Administrative channel mode is on
Operational channel mode is on
Last membership update succeeded
2 ports in total, 0 ports up
Ports: fcip1 [down]
fcip2 [down]
port-channel 78
Administrative channel mode is on
Operational channel mode is on
Last membership update succeeded
2 ports in total, 0 ports up
Ports: fc2/1 [down]
fc2/5 [down]
port-channel 79
Administrative channel mode is on
Operational channel mode is on
Last membership update succeeded
First operational port is fcip200
2 ports in total, 2 ports up
Ports: fcip101 [up]
fcip200 [up] *
 

Example 9-3 Displays the PortChannel Configured in the ACTIVE Mode

switch# show port-channel database
port-channel 77
Administrative channel mode is active
Operational channel mode is active
Last membership update succeeded
2 ports in total, 0 ports up
Ports: fcip1 [down]
fcip2 [down]
port-channel 78
Administrative channel mode is active
Operational channel mode is active
Last membership update succeeded
2 ports in total, 0 ports up
Ports: fc2/1 [down]
fc2/5 [down]
port-channel 79
Administrative channel mode is active
Operational channel mode is active
Last membership update succeeded
First operational port is fcip200
2 ports in total, 2 ports up
Ports: fcip101 [up]
fcip200 [up] *
 

The show port-channel consistency command has two options: without details and with details.

Example 9-4 Displays the Consistency Status without Details

switch# show port-channel consistency
Database is consistent

Example 9-5 Displays the Consistency Status with Details

switch# show port-channel consistency detail
Authoritative port-channel database:
================================================
totally 3 port-channels
port-channel 77:
2 ports, first operational port is none
fcip1 [down]
fcip2 [down]
port-channel 78:
2 ports, first operational port is none
fc2/1 [down]
fc2/5 [down]
port-channel 79:
2 ports, first operational port is fcip200
fcip101 [up]
fcip200 [up]
================================================
database 1: from module 5
================================================
totally 3 port-channels
port-channel 77:
2 ports, first operational port is none
fcip1 [down]
fcip2 [down]
port-channel 78:
2 ports, first operational port is none
fc2/1 [down]
fc2/5 [down]
port-channel 79:
2 ports, first operational port is fcip200
fcip101 [up]
fcip200 [up]
================================================
database 2: from module 4
================================================
totally 3 port-channels
port-channel 77:
2 ports, first operational port is none
fcip1 [down]
fcip2 [down]
port-channel 78:
2 ports, first operational port is none
fc2/1 [down]
fc2/5 [down]
port-channel 79:
2 ports, first operational port is fcip200
fcip101 [up]
fcip200 [up]
...
 

The show port-channel usage command displays details of the used and unused PortChannel numbers.

Example 9-6 Displays the PortChannel Usage

switch# show port-channel usage
Totally 3 port-channel numbers used
===================================
Used : 77 - 79
Unused: 1 - 76 , 80 - 256

Example 9-7 Displays the PortChannel Compatibility

switch# show port-channel compatibility-parameters
physical port layer fibre channel or ethernet
port mode E/AUTO only
trunk mode
speed
port VSAN
port allowed VSAN list
 

Use the existing show commands to obtain further details on autocreated channel group attributes. Autocreated PortChannels are indicated explicitly to help differentiate them from the manually created PortChannels. See Examples 9-8 to 9-10 .

Example 9-8 Displays Autocreated PortChannels

switch# show interface fc1/1
fc1/1 is trunking
Hardware is Fibre Channel, FCOT is short wave laser
Port WWN is 20:0a:00:0b:5f:3b:fe:80
...
Receive data field Size is 2112
Beacon is turned off
Port-channel auto creation is enabled
Belongs to port-channel 123
...

Example 9-9 Displays the Specified PortChannel Interface

switch# show port-channel database interface port-channel 128
port-channel 128
Administrative channel mode is active
Operational channel mode is active
Last membership update succeeded
Channel is auto created
First operational port is fc1/1
1 ports in total, 1 ports up
Ports: fc1/1 [up] *

Example 9-10 Displays the PortChannel Summary

switch# show port-channel summary
------------------------------------------------------------------------------
Interface Total Ports Oper Ports First Oper Port
------------------------------------------------------------------------------
port-channel 1 1 0 --
port-channel 2 1 1 fc8/13
port-channel 3 0 0 --
port-channel 4 0 0 --
port-channel 5 1 1 fc8/3
port-channel 6 0 0 --
 

You can use the Information pane in DCNM-SAN to verify your PortChannel configuration.

Configuration Examples for F and TF PortChannels

This example shows how to configure F PortChannel in shared mode and bring up the link (not supported on the MDS 91x4 switches) between F ports on the NPIV core switches and NP ports on the NPV switches:


Step 1 Enable the F port trunking and channeling protocol on the MDS core switch.

switch(config)# feature fport-channel-trunk
 

Step 2 Enable NPIV on the MDS core switch:

switch(config)# feature npiv
 

Step 3 Create the PortChannel on the MDS core switch:

switch(config)# interface port-channel 1
switch(config-if)# switchport mode F
switch(config-if)# channel mode active
switch(config-if)# switchport trunk mode off
switch(config-if)# switchport rate-mode shared
switch(config-if)# exit
 

Step 4 Configure the PortChannel member interfaces on the core switch:

switch(config)# interface fc2/1-3
switch(config-if)# shut
switch(config-if)# switchport mode F
switch(config-if)# switchport trunk mode off
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode shared
switch(config-if)# channel-group 1
switch(config-if)# no shut
switch(config-if)# exit
 

Step 5 Create the PortChannel on the NPV switch:

switch(config)# interface port-channel 1
switch(config-if)# switchport mode NP
switch(config-if)# switchport rate-mode shared
switch(config-if)# exit
 

Step 6 Configure the PortChannel member interfaces on the NPV switch:

switch(config)# interface fc2/1-3
switch(config-if)# shut
switch(config-if)# switchport mode NP
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode shared
switch(config-if)# switchport trunk mode off
switch(config-if)# channel-group 1
switch(config-if)# no shut
switch(config-if)# exit
 

Step 7 Set the administrative state of all the PortChannel member interfaces in both NPIV core switch and the NPV switch to ON:

switch(config)# interface fc1/1-3
switch(config-if)# shut
switch(config-if)# no shut
 
switch(config)# interface fc2/1-3
switch(config-if)# shut
switch(config-if)# no shut
 


 


Note The speed configuration must be the same for all member interfaces in a PortChannel. While configuring the channel in dedicated mode, ensure that required bandwidth is available to the ports.


This example shows how to configure channeling in dedicated mode and bring up the TF-TNP PortChannel link between TF ports in the NPIV core switch, and TNP ports in the NPV switch:


Step 1 Enable the F port trunking and channeling protocol on the MDS core switch:

switch(config)# feature fport-channel-trunk

 

Step 2 Enable NPIV on the MDS core switch:

switch(config)# feature npiv
 

Step 3 Create the PortChannel on the MDS core switch:

switch(config)# interface port-channel 2
switch(config-if)# switchport mode F
switch(config-if)# switchport rate-mode dedicated
switch(config-if)# channel mode active
switch(config-if)# exit
 

Step 4 Configure the PortChannel member interfaces on the MDS core switch in dedicated mode:

switch(config)# interface fc1/4-6
switch(config-if)# shut
switch(config-if)# switchport mode F
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode dedicated
switch(config-if)# switchport trunk mode on
switch(config-if)# channel-group 2
switch(config-if)# no shut
switch(config-if)# exit
 

Step 5 Create the PortChannel in dedicated mode on the NPV switch:

switch(config)# interface port-channel 2
switch(config-if)# switchport rate-mode dedicated
switch(config-if)# switchport mode NP
switch(config-if)# no shut
switch(config-if)# exit
 

Step 6 Configure the PortChannel member interfaces on the NPV switch in dedicated mode:

switch(config)# interface fc3/1-3
switch(config-if)# shut
switch(config-if)# switchport mode NP
switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode dedicated
switch(config-if)# switchport trunk mode on
switch(config-if)# channel-group 2
switch(config-if)# no shut
switch(config-if)# exit
 

Step 7 Set the administrative state of all the PortChannel member interfaces in both NPIV core switch and the NPV switch to ON:

switch(config)# interface fc1/4-6
switch(config-if)# shut
switch(config-if)# no shut
 
switch(config)# interface fc3/1-3
switch(config-if)# shut
switch(config-if)# no shut