ファイアウォール ステートフル シャーシ間冗長性機能では、冗長グループのトラフィックは、その冗長グループの入力インターフェイスに関連付けられている仮想 IP アドレスを使用してルーティングされます。仮想 IP アドレスに送信されたトラフィックは、冗長グループがアクティブ状態になっているルータで受信されます。冗長グループのフェールオーバー中は、仮想
IP アドレスへのトラフィックが新しくアクティブになった冗長グループに自動的にルーティングされます。
冗長グループのトラフィックがスタンバイ ルータの物理 IP アドレスを使用してルーティングされてスタンバイ冗長グループに到達した場合、ファイアウォールはスタンバイ冗長グループに到達したトラフィックをドロップします。一方、トラフィックがアクティブ冗長グループに到達した場合は、確立された
TCP または UDP セッションがスタンバイ冗長グループに同期されます。
! Configures redundancy, control and data interfaces
redundancy
mode none
application redundancy
group 2
preempt
priority 200 failover threshold 100
control GigabitEthernet 0/0/4 protocol 2
data GigabitEthernet 0/0/3
!
protocol 2
timers hellotime ms 250 holdtime ms 750
!
! Configures a VRF
ip vrf vrf1
!
! Configures parameter maps to add parameters that control the behavior of actions and match criteria.
parameter-map type inspect pmap-udp
redundancy
redundancy delay 10
!
parameter-map type inspect pmap-tcp
redundancy
redundancy delay 10
!
! Defines class-maps to describes traffic between zones
class-map type inspect match-any cmap-udp
match protocol udp
!
class-map type inspect match-any cmap-ftp-tcp
match protocol ftp
match protocol tcp
!
! Associates class-maps with policy-maps to define actions to be applied
policy-map type inspect p1
class type inspect cmap-udp
inspect pmap-udp
!
class type inspect cmap-ftp-tcp
inspect pmap-tcp
!
! Identifies and defines network zones
zone security z-int
!
zone security z-hi
!
! Sets zone pairs for any policy other than deny all and assign policy-maps to zone-pairs by defining a service-policy
zone-pair security hi2int source z-hi destination z-int
service-policy type inspect p1
!
! Assigns interfaces to zones
interface GigabitEthernet 0/0/1
ip vrf forwarding vrf1
ip address 10.1.1.3 255.255.0.0
ip virtual-reassembly
zone-member security z-hi
negotiation auto
redundancy rii 20
redundancy group 2 ip 10.1.1.10 exclusive decrement 50
!
interface GigabitEthernet 0/0/2
ip vrf forwarding vrf1
ip address 192.0.2.2 255.255.255.240
ip virtual-reassembly
zone-member security z-int
negotiation auto
redundancy rii 21
redundancy group 2 ip 192.0.2.12 exclusive decrement 50
!
interface GigabitEthernet 0/0/4
ip address 198.51.100.17 255.255.255.240
!
interface GigabitEthernet 0/0/4
ip address 203.0.113.49 255.255.255.240
!
ip route vrf vrf1 192.0.2.0 255.255.255.240 GigabitEthernet0/0/2 10.1.1.4
ip route vrf vrf1 10.1.0.0 255.255.0.0 GigabitEthernet0/0/1 10.1.0.4
!
スタンバイ デバイスである Device 2 の設定を以下に示します。
! Configures redundancy, control and data interfaces
redundancy
mode none
application redundancy
group 2
preempt
priority 200 failover threshold 100
control GigabitEthernet 0/0/4 protocol 2
data GigabitEthernet 0/0/3
!
protocol 2
timers hellotime ms 250 holdtime ms 750
!
! Configures a VRF
ip vrf vrf1
!
! Configures parameter maps to add parameters that control the behavior of actions and match criteria.
parameter-map type inspect pmap-udp
redundancy
redundancy delay 10
!
parameter-map type inspect pmap-tcp
redundancy
redundancy delay 10
!
! Defines class-maps to describes traffic between zones
class-map type inspect match-any cmap-udp
match protocol udp
!
class-map type inspect match-any cmap-ftp-tcp
match protocol ftp
match protocol tcp
!
! Associates class-maps with policy-maps to define actions to be applied
policy-map type inspect p1
class type inspect cmap-udp
inspect pmap-udp
!
class type inspect cmap-ftp-tcp
inspect pmap-tcp
!
! Identifies and defines network zones
zone security z-int
!
zone security z-hi
!
! Sets zone pairs for any policy other than deny all and assign policy-maps to zone-pairs by defining a service-policy
zone-pair security hi2int source z-hi destination z-int
service-policy type inspect p1
!
! Assigns interfaces to zones
interface GigabitEthernet 0/0/1
ip vrf forwarding vrf1
ip address 10.1.1.6 255.255.0.0
ip virtual-reassembly
zone-member security z-hi
negotiation auto
redundancy rii 20
redundancy group 2 ip 10.1.1.12 exclusive decrement 50
!
interface GigabitEthernet 0/0/2
ip vrf forwarding vrf1
ip address 192.0.2.5 255.255.255.240
ip virtual-reassembly
zone-member security z-int
negotiation auto
redundancy rii 21
redundancy group 2 ip 192.0.2.10 exclusive decrement 50
!
interface GigabitEthernet 0/0/4
ip address 198.51.100.21 255.255.255.240
!
interface GigabitEthernet 0/0/4
ip address 203.0.113.53 255.255.255.240
!
ip route vrf vrf1 192.0.2.0 255.255.255.240 GigabitEthernet0/0/2 10.1.1.4
ip route vrf vrf1 10.1.0.0 255.255.0.0 GigabitEthernet0/0/1 10.1.0.4
!
右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web
サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。